Windows 10 is blocking the LimeSDR driver from starting

I have been using my LimeSDR on a laptop with Windows 10 using the Myriad-RF LimeSDR-USB driver version I just got a new desktop computer and installed Windows 10. When I installed the same driver on my new system, it installed but won’t run. The Device Manager reports the device status as follows:

"The driver for this device has been blocked from starting because it is known to have problems with Windows. Contact the hardware vendor for a new driver. (Code 48)

Click ‘Check for solutions’ to send data about this device to Microsoft and to see if there is a solution available."

When I click “Check for solutions” nothing happens. I’ve searched the internet for a solution with no luck. Has anyone else seen this problem?

I rarely use Windows and have not come across this. Tagging @martywittrock in case it’s something he’s seen.

Thanks for looking into this. Since Microsoft is saying that I need to get a new driver from the hardware vendor, maybe someone from Lime or MyriadRF could contact Microsoft and see what the problem is.

I did some more research on the internet and did find a few references to the same problem with other devices that use the Cypress USB chip, although these seemed to be mostly prototypes and not commercial products.

Here’s a post I found on a Cypress Developer Community Forum:

when I use the driver you just provided (WIN10/x64), the device (Cypress FX3 USB BootLoader Device) does not work and I have the following error message in the device manager :

" The driver for this device has been blocked from starting because it is known to have problems with Windows. Contact the hardware vendor for a new driver. (Code 48) "

I also tried WIN10/x86 with the same result…

Well I tried a lot of versions, Driver version from 21/08/2014 is the only one my Win10 lets work.

Is there an earlier version of the LimeSDR driver that I could try?

I called Microsoft and here’s what I found out. The LimeSDR driver is listed in the Windows Driver Protection database as causing problems when used with my ASUS motherboard. I just bought this motherboard, and it has the new Intel Coffee Lake i7 CPU and Z370 chipset, which have just been released. The USB controller is ASMedia.

Microsoft said that I had to contact ASUS and try and resolve it with them. If there really is a problem, it may affect other motherboards using these chips.

Edit: By the way, there is NO WAY to override the block. Microsoft apparently thinks it has the right to completely prevent you from running a driver on your computer that it doesn’t like.

A possible solution would be to reinstall Windows with no internet connection, then disable Windows Update (if that’s even possible anymore) before connecting to the internet.

Edit: I also sent this info to Cypress to see if they might be interested in looking into it, since it is basically their driver that is getting blocked.

@allan - Allen,

Hey, no kidding, get a different machine that doesn’t have this issue. I realize that this may sound a bit harsh, but you’re trying to move a mountain the size of Everest with a snow shovel working with the corporate entities that are going to prevent you from using the driver on your Lime for a machine that can probably be replaced with something comparable. Staying with your Asus that Microsoft refuses to allow you to load that driver puts you into one of three situations:

1.) Stay with the Asus and keep beating on the doors of the corporate entities that will not listen to you because they’re not spending money on this issue to make you and and handful of other people happy.

2.) Get a different Windows PC and participate in what everyone else has been doing with their Limes that don’t own Asus machines.

3.) Drop everything, ditch Windows, load Ubuntu 17.10 (Artful Aardvark) Linux on that Asus for free and then install all the same drivers and most of the same apps on it and be happy that your Lime runs enormously fast on that i7.

There are your choices in this matter - Get going on the solution because contacting Cypress will get you a lot of lip service and not much else. Microsoft is on record that they’re digging their heels in. #3 is a really good option unless you change machines.

73 de Marty, KN0CK

Now that I understand the problem, I agree that there is not much that I can do about it except forward the information to Lime and Cypress. I’ve done this, and Cypress has someone working on it. Hopefully this will lead to a solution.

I have other computers I can use, including some with Linux, so I’m not dead in the water.

1 Like

@allan - Allen,

Since you have other PCs at-hand, try one that’s at least a 2 - 2.2GHz i3 with 4GB of memory, at least 1 USB 3.0 port, (again, these are minimum specs) and load a fresh install of Artful (Ubuntu 17.10) on it. Then follow the directions here ----->

…to install everything you need for LimeSuite. Once you get that going and LimeSuite works, then you’ll be able to install the other apps for receive and transmit like SDRAngel or just use the receive apps like GQRX, CubicSDR, etc.

Good luck and have fun…!

73 de Marty, KN0CK

Hi Andrew,

Cypress sent me a new driver, version, along with a statement from Microsoft that this was certified for Windows 10… However, it looks like this is their generic driver. I modified it by replacing the strings in the cyusb3.inf file with the corresponding strings in the LimeSDR version of the same file. When I tried installing the modified driver, Windows started the process then quit, saying that Windows already has the best driver for the LimeSDR.

I suppose I could try wiping the firmware from the Cypress USB chip and revert it to the default firmware so that Windows would see it as a Cypress device, and then install their new generic driver, but I think that at this point it would be better if someone from Lime/MyriadRF got involved. You seem to be a good person to talk to about this.

The engineer from Cypress that I have been working with is “Hemanth” and the tech support case number is 00400410. I also suggested to him that he might contact Lime himself, since you are his customers.

My concern is that if there truly is an incompatibility with your driver and the ASUS motherboard, it will probably affect other motherboards for the Intel 8th gen CPU since they all tend to use the same chipsets and BIOS. Also, I assume that you don’t like the fact that Microsoft has blacklisted your driver even if it is just for ASUS.

Meanwhile, as Marty says, there’s always Linux!

I’m not sure this would help, since once you loaded our firmware — which obviously you would have to do — it would presumably stop using the Cypress driver.

Well, when Microsoft say there is I do not know what this actually means in practical terms. My guess is that it just means a device combination got blacklisted due to some errors being reported.

Functionally, the USB PHY interface is going to remain the same whether the FX3 identifies the board as a Cypress or Lime device. Cypress being a major vendor and the FX3 being part of a lineage of USB microcontrollers, I’d be surprised if there were a fundamental issue.

We have seen incompatibility issues before, but this has been tracked down to a USB host chipset, this is not entirely uncommon with USB 3.0 and you see this with other peripherals also, where the issue is resolved using a different host.

In your case I would try Linux on the same computer if you can, just to try and isolate the problem.

1 Like

I guess my question is, did you actually write your own firmware for the Cypress chip, or are you using the Cypress default firmware with different vendor and product IDs ?

More generally, I’d like to solve this problem but I don’t really have the time or expertise. Microsoft says that I should contact the LimeSDR vendor for an updated driver, so that’s what I’m doing.

Cypress is a major vendor of these chips, as you say, but they have updated their driver to, while yours is at, so maybe you could look into what changes they made, and whether you should update your driver to the new version. Otherwise, I’ll do as you suggest and switch to another computer or OS, but I’m not really a Linux guy. My goal is to write software for the board that would run on Windows.

Anyway, thanks for your help.

Yes, the FX3 runs our own firmware.

@Zack, does it look like we may need to update the Windows driver?

An advantage of updating to is that this is the current Cypress version, and this version is certified by Microsoft for Windows 10. If you update, you could ask Microsoft to lift the block based on this. If they refuse, or if ASUS still thinks there is a problem, then you could ask Cypress to get involved. Right now, Cypress is basically just saying to do the update.

Obviously, it would be better if you were talking to Cypress, Microsoft and ASUS directly. If there is a way to override the block, I’d be happy to help by testing either the old or new driver on my system.

By the way, I am currently using the LimeSDR with the driver on my Windows 10 laptop with USB 3.0, and it works but there are frequent freezes with LimeSuite, SDRConsole and CubicSDR requiring that I restart the applications, so there may actually be a problem with the Win10 driver.

Aren’t computers fun?

Impertinent question: Since you guys are English and work for Lime Microsystems, do you mind being called “Limeys” ? I’m a California Canuck.

Hi @allan, @andrewback,

Well, to be able to use an updated ( driver, we have to go through certification process again :frowning:
Actually, we can re-compile FX3 firmware using default Cypress IDs for you just to check if the issue is gone with driver.

Hi @allan,

Here is FX3 firmware with Cypress VID and PID. Could you check please if it works with driver on your machine. Instructions on how to re-flash FX3 firmware you will find here:

You have to use working machine for this, of course.

Surprise, my driver is no longer blocked !

I just uninstalled it (for the umpteenth time), removed Pothos from my system, reinstalled Pothos to a different drive, updated the driver (for the umpteenth time) and now it is no longer blocked. I’m running CubicSDR right now.

I’ve turned off Windows update (yes, it is possible in Windows 10) so maybe that will stop it from being blocked again.

Do you still want me to try the driver? I’m assuming that if I reflash the FX3 firmware, the device will now appear as a Cypress device rather than a LimeSDR, so I shouldn’t lose my LimeSDR driver.

What is the status of this 4 months later?

I have tried for two days to get my LimeSDR-USB working on a Windows 10 machine with an ASUS motherboard. I have followed the Myriad instructions on how to get started and installed the “Myriad-RF LimeSDR-USB” driver, but I have numerous problems such as the PC not starting up in case the LimeSDR-USB is connected to the PC, the PC not switching off when the LimeSDR-USB is connected, the LimeSDR-USB being taken for a USB 2 device both by Device Manager and LimeSuiteGUI.

I have managed to run LimeSDR Quick Test successfully, but I have to restart the PC if I want to run the test twice.

All very annoying.

I want as you to write Windows software for my LimeSDR-USB, but it has to be a stable configuration first. Linux is not an alternative for me unless that LimeSDR-USB can run satisfactorily on a Raspberry Pi 3. Can it? There is n o USB 3.0 port.

Actually, when I connected the LimeSDR-USB to the PC for the first time, Windows 10 assigned the WinUSB driver top it.

I have also tried the Pothos software, but that made things worse.

Please, inform me of a good stable way forward with Windows 10 keeping update alive.

All I can tell you is that once Windows 10 stopped blocking the LimeSDR-USB driver from running, all of my software started working fine. I can run LimeSuite, Pothos and all of the SDR receiver apps that use the Soapy drivers.

The fact that you can’t start or shutdown your PC with the LimeSDR connected suggests some sort of hardware problem. At one point when I was using a PC at another location, I was having a problem where the USB connection to the LimeSDR was failing, and I discovered that it was due to the fact that I was powering a small fan in the LimeSDR case from a DC power supply that was plugged into a different AC socket than the PC. There must have been some sort of ground loop issue, because plugging in the fan would kill the USB connection every time. The only electrical connection between the fan and the LimeSDR was that the power connector for the fan was grounded to the case. This happened with several different power supplies, both of which were isolated from the AC ground. Plugging the fan power supply into the same AC socket as my PC completely solved the problem, so I wonder if there is a problem with the grounding of the USB port on the LimeSDR?