USB 2 Windows USB 3 Linux


I have had my LimeSDR (Aluminium) for a few months now. Not having a lot of time to spend on the LimeSDR specifically, I have not overly worried about something that has been bugging me about it.

Despite connecting to my PC via USB 3. And using the supplied Y cables USB 3 cable and other specifically USB 3 cables. The unit only ever shows up as a USB 2 device under windows 10, but when connected to one of my linux systems, including the same PC it shows up as a USB 3 device.

Is this normal ? If not, do I need to play around with Zadig to utilise the generalised Windows driver or something ?

Updating the firmware has not fixed this issue either so I am at a loss to how to get the unit to show up in LimeSuite in Windows 10 as a USB 3 device.



I had the same problem with my LimeSDR albeit on Win7 x64. Same as you, it was fine on Linux, even on the same PC. I tried to remove and re-install my Intel USB3 drivers. I also tried latest Intel USB3 drivers. Nothing would fix the issue. I ended up doing a fresh install of Win7 x64 and now my LimeSDR is correctly detected as being on USB3 and all is working well. I have been able to sample at up to 60MHz (180MB/s on USB bus).
I hope this information is helpful in resolving your problem. Let us know how you go.

Kindest regards,
Brendan Jenkins,

Hi Brendan,

Thanks for the help. I think I might have to go for a drive to VK3 land and jump of the highest point on the Great Ocean Road. In fact, spending another week doing Sea Survival at HMAS Cerberus, might be preferable to doing a re-Windows 10 install LoL.

The band width was exactly the reason I wanted it show up properly. Just one more reason to hate on Microsoft.

Ive got my PC dual booting, my Intel Based Laptop booting into Kali Linux, my Macbook Pro dual booting MacOS and Ubuntu, and a UDOO X86 Advanced pro booting into Ubuntu, and nothing else has an issue with the LimeSDR.

The only reason I wanted it working with Windows is most of the things I do end up being Adobe Cloud Based, And if it wasnt for Adobes affinity to staying with microsoft I would have culled every Windows Box Ive ever had by now. Also Ham Radio Deluxe needs a good Linux Port

What a pain. I will consider a re-install but the funny thing is, Ive just done one, so perhaps Windows 10 is more problematic than Windows 7 64.

Not sure. Perhaps I will play with the Zadig Drivers. I use them for my Racing Drones. I am also considering getting the LimeSDR Companion to extend the Frequency range to 10 GHz so I can get a better look at 5.8 GHz than I do with a HackRF, for frequency allocation purposes on Race Days, as most Racing Drones are running 5.8Ghz camera systems, albeit not all.

PS Merry Christmas and thanks for the help!



Not sure if this will help or not, but I found that using apps that use different drivers you cannot have both operational - only one or the other. Here are the details…

Most apps like GNU Radio Companion, Cubic SDR, GQRX, and most certainly SDRConsole V3.0, etc. all use the Cypress Drivers that you can load from’s recommendations (it’s well documented). If you do that, you can use the USB 3.0 resources from Windows 7 through 10 with no issues at all.

All Hell breaks loose when you try to use ZADIG with SDRAngel…You lose your Cyrpress drivers for USB 3.0 (they’re rep,laced) and you obtain USB 3.0 resources using the WinUSB drivers that it produces once you install the drivers via ZADIG. Then you can run SDRAngel without any issues since it requires the WinUSB drivers from ZADIG.

It’s weird - the two drivers are NOT compatible and you cannot just have the Cypress drivers just laying back until you instantiate them again - they are physically removed when you install WinUSB drivers. I’ve had to ‘toggle’ back and forth between the two drivers when I want to use certain apps like SDRConsole and then SDRAngel on the same Win10 64 bit machine (makes no difference if it’s Win32, too - same results).

So this is my take on the issue. I’ve not had to reload Windows to ‘toggle’ back and forth between them, just reload them as needed - usually through means of removing the LimeSDR from the USB port, and then plugging it back in to load the signed Cypress Windows drivers once the LimeSDR is recognized when plugged back in and just watch them load. When it’s done, you can check to make sure that the ‘MyriadRF’ driver is installed (Cypress USB 3.0 driver). This will also deactivate the WinUSB driver for ZADIG and SDRAngel will not work properly.

One more - you don’t have this issue in Linux because it can only use the Cypress drivers that are part of the compile you do for LimeSuite and other support apps (SoapySDR, etc). ZADIG is a Windows app for USB drivers and does not come into play on Linux at all.

Let me know if you have any questions on this - it’s a really strange observation that I’ve eventually seen in operation, but that’s the way it plays on a Windows machine with apps that use different USB 3.0 drivers.

73 de Marty, KN0CK

1 Like

Thanx for the reply mate, roger that. Windows (insert number here) is definately why I prefer Linux, or even a hole in the head :slight_smile:

1 Like