Windows - trouble free start?

I have spent two full days trying to get my LimeSDR-USB working properly on a Windows 10 machine with an ASUS motherboard following the instruction on the Myriad-RF webpage. I have also read in topic “Windows 10 is blocking the LimeSDR driver from starting” the advice to change PC and use Linux. This advice is half a year old.

I can’t find new information on how to make LimeSDR-USB work on a Windows 10 machine. I experience erratic behaviour such as the LimeSDR-USB being recognized sometimes as a USB 2 device and at some other times as a USB 3 device. Sometimes my PC is blocked and will not be turned off until I unplug the LimeSDR-USB.

Please, has all the issues been solved on Windows 10?

Please, inform me of a trouble free and safe way to get going on Windows 10 with an ASUS motherboard.


I’ve had both the LimeSDR and the LimeSDR-Mini deployed onto Windows 10 systems for the better part of a year now and fully operational. For the LimeSDR-USB (the original LimeSDR V1.4) the first consideration you have to make is this:

1.) Am I going to use SDRConsole as my primary application?
1A.) If so, you MUST install the Cypress Drivers or the Windows 10 signed driver (MyriadRF driver)

2.) Am I going to use SDRAngel, HDSDR, or the gr-osmocom drivers (ZADIG)?
2A.) If so, then you MUST uninstall the Cypress or signed MyriadRF drivers before that can take effect.

You CANNOT have both drivers present - it’s an either/or situation. SDRConsole V3.0 relies upon the MyriadRF/Cypress driver to make that app work. If the WinUSB drivers from ZADIG are present for SDRAngel, HDSDR, or other apps then you have to ensure that the MyriadRF/Cypress drivers are uninstalled. If both reside, you will not have predictable operation.

Hope this helps - let me know if there’s any further questions on this,

73 de Marty, KN0CK

Thank you for replying.

I am not aiming for using a particular set of SDR software. Primarily, I want to access the LimeSDR-USB itself and set frequency, bandwidth, gain and program the ASIC to do some preprocessing before sending the data on the USB to my PC. Which software is best for that?

Currently, my concern is to get the LimeSDR-USB to behave friendly on my PC.

I do the following.

  1. Turn the PC on without having the LimeSDR-USB plugged in. The PC turns on as it should. I do not use an external power supply, but plug in both USB connector.
  2. I plug the LimeSDR-USB into a USB 3.0 connector. Two LEDs light green and one LED is blinking red green red green etc.
  3. I run ZADIG. It shows that the LimeSDR is using the CYUSB(v1.2.3.14) driver. I do not change to the WinUSB. I close ZADIG without doing anything.
  4. I run Device Manager. There is a USB device named “Myriad-RF LimeSDR-USB”. The Device Manager states that the USB device is working properly. The driver is C:\WINDOWS\System32\Drivers\CYUSB3.sys and C:\WINDOWS\system32\WdfCoInstaller01011.dll. The file version is The provider is Cypress and the digital signer is Lime Microsystems Ltd. The device description is “Myriad-RF LimeSDR-USB”. Under the tab “Events” the latest is “2018-06-11 17:52:54 Device installed(cyusb3.inf_amd64_f…) “ the information supplied for this event is: “Driver Management concluded the process to install driver cyusb3.inf_amd64_f360f8a7ee43801e for Device Instance ID USB\VID_1D50&PID_6108\0009060B00461B07 with the following status: 0x0.”
  5. I close the Device Manager without changing anything.
  6. I start “LimeSuiteGUI_20180406_d6bc28.exe”
  7. I go “Options” -> “ConnectionSettings” and no board connections shows up.
  8. I close the "ConnectionSettings"
  9. I keep LimuSuitGUI running.
  10. I push the reset button on the LimeSDR-USB
  11. I go “Options” -> “ConnectionSettings” and the LimeSDR shows up as a USB 2.0 unit.
  12. I click on the unit and click on the "Connection"
  13. The LimeUSB is connected to the LimeSuiteGUI.
  14. I can repeat the process from step 8 above.

Still, the LimeSDR-USB does not get connected as a USB 3.0 device.

There is an incompatibility between the Myriad-RF driver, the FX3 firmware and the Windows 10 hardware USB port driver. I can’t prove it, but somehow the driver must be hanging in a loop or waiting for something from the LimeSDR-USB starting shortly after plugging the LimeSDR-USB into the PC. Could it be the enumeration that does not complete properly? This stops when I push the reset. My PC uses Asmedia.

Please, advice on how to solve this incompatibility.

My understanding is that there are two ways to get the LimeSDR-USB connected to a Windows 10 PC. One is to use Myriad-RF driver and LimeSuit software. The other is to use Zadig to install a WinUSB driver and then use the Pothos software.

Does anyone have experience with both and a recommendation on which one of the two is most likely to be successful?

Any advice or help would be highly appreciated.

Will all the trouble disappear, if I switch to a Linux PC? Which Linux should I use? Is Ubuntu good?



The Windows startup and the actions you’re seeing with LimeSuite indicate that you’re using the Cypress/MyriadRF signed drivers that Windows loads when the LimeSDR is plugged in. You would have to remove the Cypress/MyriadRF driver and run ZADIG to load the WinUSB driver that would work with those applications that use ZADIG (HDSDR, SDR#, SDRAngel, etc). But as it is now you can use it for Pothos and GNU Radio Companion (for Windows) to perform receive and transmit applications per your specific use using flow diagrams you either develop yourself or obtain from other LimeSDR users. Also, using the Cypress/MyriadRF drivers you can develop your own C++ code to make applications using the calls from LimeSuite within the code to make the LimeSDR transmit and receive by setting frequency, adjusting receive and transmit settings, etc.

What’s puzzling is why the Windows install is showing USB 2.0 instead of 3.0 when you have it plugged into a USB 3.0 port. The only thing I can relate that to is that there’s either a incompatibility of the USB 3.0 device to LimeSuite or there’s something odd about the USB 3.0 resources itself.

You’re ALWAYS best to install Ubuntu (the OS that is generally accepted as the standard for running LimeSDR) and all the LimeSuite resources and obtain better results overall. Windows has restrictions that makes it maddening sometimes to understand why something may not work with the LimeSDR, while Ubuntu installs are fairly free of bugs and annoyances that often plague a Windows install for LimeSDR. The only thing I want to add here is that there is a known sequence how you install things in Ubuntu to make the install operational for LimeSuite and the LimeSDR. You must follow that sequence of installs for it to be 100% error free. There are several topics on this forum that address that and there’s also guidance from the MyriadRF webpages that address how to successfully install all the resources to make the LimeSDR play right with Ubuntu.

Let us all know if you have any further questions on this, Jorgen,

73 de Marty, KN0CK

Dear Marty,

Thank you for your reply.
When I plug into the same connector another USB 3 device, it is recognised as a USB 3 device (I use usbview.exe to see that).
I have spent another day on getting the LimeSDR-USB working using the “Myriad-RF LimeSDR” driver. No progress today.
I am inclined to get Ubuntu on a PC and learn how to use that.
Can one do anything meaningful with Raspberry Pi 3 and the LimeSDR-USB, or will there be an annoying speed bottleneck since Raspberry Pi 3 has USB 2 only?



Don’t waste any time with the Raspberry Pi 3.0 at all - while there’s ways to make it work, it’s NOT optimal and the USB 2.0 performance will not suit you well either. I would highly recommend a PC that’s at least 2.5GHz, 4GB RAM, 50GB HD, and has USB 3.0 resources to load Ubuntu on that PC as normal and then install all the LimeSuite and SoapySDR resources with this guidance:

1.) Install LimeSuite and all the MyriadRF drivers as you normally would from the MyriadRF instructions using the PPAs, and that follows:

sudo add-apt-repository -y ppa:myriadrf/drivers
sudo apt-get update
sudo apt-get install limesuite liblimesuite-dev limesuite-udev limesuite-images
sudo apt-get install soapysdr soapysdr-module-lms7

Once you get that done, verify that your LimeSDR is capable of being seen by LimeSuite by doing the following in a Terminal window:

SoapySDRUtil --find


LimeUtil --find

And see if your LimeSDR responds. If it does, then you’re done - you have all the LimeSDR resources to make the LimeSDR play fine in Ubuntu OS (18.04LTS recommended).

Let me know if you need anything else, Jorgen -

73 de Marty, KN0CK

Dear Marty,

Thank you for the advice.

I have ordered a new PC, so it will take some days before I am up and running Linux Ubuntu. I really look forward to a trouble free LimeSDR experience.

Regards, Jorgen

There is a new Maker’s board coming out towards the end of the year. If space is an issue, you may want to wait.

It is 4X as fast & powerful as my Udoo X86 Ultra. It also has CUDA cores, with it’s integrated 950 Graphics (NVIDIA).
Martywittrock , have you looked at it?