Start from scratch - Ubuntu or Windows?

#1

One year ago I tried LimeSDR on a Windows machine, but I did not manage to get it running smoothly.
Now, I have a spare PC with USB 3. Currently Windows 10 is installed.

Do you recommend I install Ubuntu 18.04.2 to ensure trouble free running of LimeSDR? That was the advice 1 year ago. Is it still valid?

Regards,
Jorgen

#2

I found that the Windows install bundle worked as well as the files I built for Ubuntu 18.04. The bundle includes Pothos and GnuRadio along with LimeSuite.

#3

@Jorgen - Jorgen,

If you’ve had your LimeSDR for a year, I would highly recommend that you use LimeSuite (the app) or LimeUtil (command line) to update the firmware/gateware of your LimeSDR. There’s been several big changes that have occurred over the year that make older firmware/gateware not work at all with the apps. Again, update using LimeSuite or LimeUtil for best results.

73 de Marty, KN0CK

#4

Thank you for these replies. Now I know where to start.

Regards,
Jorgen

#5

Dear Marty,

I have been trying and trying, but no success…

I started about one year ago with a Windows 10 machine. I used a USB 3 port on the machine, but it did not recognize the LimeSDR as USB 3 but as USB 2 using UsbView. I exchanged a couple of e-mails with you, and you recommended to use a Linux machine.

It has taken about a year to get to that. Now I have a Linux machine and I have installed Ubuntu 18.04.02.

I have installed Lime Suite GUI.

I attach the LimeSDR to a USB 3 port on the machine. I have verified using lsusb and lsusb -t that it indeed is a USB 3 port.

When I run lsusb after having attached the LimeSDR, the lsusb does not indicate that the LimeSDR is attached. Lsusb clearly shows a SanDisk USB 3 when I attach that to the very same port in place of the LimeSDR, hence I believe the port is working properly.

I run Lime Suite GUI. I go ->Options -> Connection settings and get the text: First line: , module FX=3, addr=1d50:6108 Second line: LimeSDR-USB[USB2.0] 9060B00461B07 and in the Lime Suite GUI lower window in red letters the text: [19:05:26] ERROR: failed to get serial number

When I click on “Connect” button in the Connection settings window, the Connection settings window disappears, and in the Lime Suite GUI lower window a line is added in red letters stating [19:17:29] ERROR: failed to get serial number. In the Lime Suite GUI second line from the top the label A CHANNEL becomes red and the radio button just before the label is also red with a black dot in the middle.

I click on the button in the second line GUI->chip and I get another line in the lower window of the Lime Suite GUI stating: [19:21:29] ERROR: no device connected

The I close the Lime Suite GUI and open a terminal window. I enter the command: LimeUtil –update. I get 14 lines of text stating:

Line 1: failed to get serial number

Line 2: Connected to [USB 3.0]

Line 3: failed to get serial number

Line 4: failed to get serial number

Line 5: Cannot claim interface – Entity not found

Line 6: Failed to open device

Line 7: connection is not open

Line 8: Write(64 bytes) failed

Line 9: connection not open

Line 10: Write(64 bytes) failed

Line 11: connection not open

Line 12: Write(64 bytes) failed

Line 13: Update not supported: UNKNOWN[HW=0]

Line 14: Programming update failed

Please, help me to get it working or, is the board broken?

Do you have a service centre that can check that the board is working, or is it cheaper to buy a new?

Regards,

Jorgen

#6

I would guess that the failure to get serial number is because the FPGA isn’t working. Either one of the FPGA voltages is missing or the FPGA is not running good firmware.

#7

Dear yindra,

Thank you for your reply. What can I do about it?

Regards,
Jorgen

#8

do you have a multimeter to check the voltages? you could check all the voltage rails on the LimeSDR.

are you able to run LimeUtil --update? or are you able to run the application in this link: LimeSDR Mini Programming failed - Help or RMA please

#9

Dear yindra,
Yes, I have a voltmeter. On the VCC INT pin close to the USB connector is 4.78V. On the fan connector is 3.3V, while the ground pin is not connected. On the LP38503 chip is 1.2V on pin4.

The FPGA gets warm when the LimeSDR-USB is connected to my PC running Linux.

I can’t rum limeUtil --update. The respons is: failed to get serial number. Connected to [USB 3.0] and then some lines saying failed to get serial number. Connection is not open. Write (64bytes) failed.

I do not have the mini. I have one of the early LimeSDR-USB. I was one of those who waited several month on getting the LimeSDR from Crowd Supply.

I have observed, that the PC does not give any sound when I connect or disconnect the LimeSDR, while it does when I connect or disconnect a USB memory stick with USB 3 interface.

What can I do either to test that it is not broken? And if not broken to get it updated and running. There is a 10 pin ICSP connector for the FPGA on the board.

Regards,
Jorgen

#10

I have not attempted to reprogram the firmware from JTAG. I do know there are other posts that detail how other people have reprogrammed the firmware over JTAG.

#11

Dear Linda,
My impression is that the USB 3 interface does not work. When the response is “failed to get serial number” which serial number does that refer to? Is it the USB 3 interface chip?

Regards,
Jorgen

#12

Sorry, your name is Laura not Linda,

Regards,
Jorgen

#13

I am uncertain whether the serial number is stored in FX3 firmware flash, or FPGA config flash, or EEPROM (https://wiki.myriadrf.org/LimeSDR-USB_hardware_description#LimeSDR-USB_board_architecture)

The serial number it is referring to is probably the unique identifier for that board.

#14

Dear Laura,

I appreciate your help. You are the only one, who has bothered to help me.

I have some further investigations trying to locate the error.

When I attach the LimeSDR-USB to my PC, the PC does not make a sound indicating successful enumeration of the USB device. It does that when I attach for example a USB memory stick.

I have gone one step further and used the Linux command lsusb -v to gain insight into the enumeration. The Linux system detects the presence of the LimeSDR, but it can’t complete the enumeration successfully. The 3 enumeration parameters iManufacturer, iProduct and iSerial are all flagged “(error)” in the output of the lsusb -v command. Therefore, I conclude that the USB interface does not work properly. Do you agree in this conclusion?

Looking at the datasheet of the USB controller CYUSB301X, it is clear that this chip is not firm and fixed. It is a programmable controller. There is also a JTAG ICSP connector on the LimeSDR board marked FX3. I do not have tools for programming the CYUSB301X chip, so I can’t simply reprogram the chip.

However, do you have some software to identify whether the interface hardware has failed or it is the software only?

Do you have a repair shop?

Regards,
Jorgen

#15

I’m not the right person to ask. I’m a limeSDR user myself, and I have not attempted to reprogram any of these chips over JTAG.

#16

Dear Laura,

Thank you for your reply. I hope someone from Myriad will answer my questions.

I need instructions on how to solve my problems with the LimeSDR-USB, else I see no other way than throwing it in the bin. I have spent several days trying to get it working, but no luck.

I have searched the internet for possibilities to have a LimeSDR repaired, but I have not found any such possibility. The people from Myriad seem to ditch the question each time it is raised.

Regards,
Jorgen

#17

Have you tried to reload the USB firmware with the Cypress tool?

Ed

#18

Dear Ed,

No, I have not tried that. I have been on the Cypress website. A programming kit costs $ 99.

Have you reloaded the USB firmware with a Cypress tool?
Which of the Cypress tools do you recommend?
Did you access the USB chip via the JTAG or the USB port?
Which file did you reload?

Regards,
Jorgen

#19

The CyUSB suite is free. It is programmed through the USB port.

Ed

#20

@Jorgen,

Sorry for the delayed response - I’ve been on vacation in Wisconsin and just returned home last night. Since you’re running the LimeSDR USB the first thing you should do, and this is if you have a V1.4 version LimeSDR USB, is to first make sure it’s on a USB 3.0 connection, and secondly make sure you have the latest version of LimeSuite installed on your platform of choice. Windows or Linux (and usually Ubuntu 18.04 LTS - Bionic Beaver) will work fine. Just make sure it’s the latest version of LimeSuite. Usually, if you’re on a Windows PC, most will download the Pothosware install located here:

…and it will install ALL the dependencies for the LimeSDR USB and also install the latest version of LimeSuite. Once you have LimeSuite installed, all that needs to be done is connecting your LimeSDR USB to the application (connection settinga) and then perform the autoprogramming step to bring your LimeSDR USB to the current gateware and firmware.

Do that much and then report back with your results.

73 de Marty, KN0CK