Ubuntu 18.04 LTS, GQRX, Limesuitegui, gr-limesdr, LMS7002Soapy and Qspectrum

#1

Ubuntu 18.04 LTS x86_64 Desktop on an I3-4005u laptop (fresh install and update)
sudo apt install mc pavucontrol hexchat git cmake python-setuptools python-soapysdr
touch ~/Templates/Untitled\ Document ## creates “New Document menu”

http://gqrx.dk/download/install-ubuntu
sudo add-apt-repository -y ppa:bladerf/bladerf
sudo add-apt-repository -y ppa:myriadrf/drivers
sudo add-apt-repository -y ppa:myriadrf/gnuradio
sudo add-apt-repository -y ppa:gqrx/gqrx-sdr
sudo apt-get install gqrx-sdr

https://wiki.myriadrf.org/Lime_Suite
sudo apt-get install limesuite liblimesuite-dev limesuite-udev limesuite-images
sudo apt-get install soapysdr-tools soapysdr-module-lms7

https://wiki.myriadrf.org/Gr-limesdr_Plugin_for_GNURadio
sudo apt-get install libboost-all-dev swig
git clone https://github.com/myriadrf/gr-limesdr


(have to install 0.1.0 from zip below)
pySmithPlot 0.1.0 from https://github.com/vMeijin/pySmithPlot/archive/65ad9db09276a5c7fb4cf4371647293c5e910bbc.zip . Please note that at the time of writing the current master branch (0.2.0) does not work with Python 2.7.
sudo python setup.py install


sudo apt-get install python3-pip python3-pyqt5 python3-numpy python3-scipy soapysdr-tools python3-soapysdr
sudo apt install soapysdr-module-all ## I did this instead of their command ‘sudo apt-get install soapysdr-module-rtlsdr soapysdr-module-airspy soapysdr-module-hackrf soapysdr-module-lms’
pip3 install --user qspectrumanalyzer

will be located in ".local/bin’

1 Like
CubicSDR, gqrx can't work with LimeSDR Mini
LimeSDR RF Loopback Test Failing
#2

@en1gma - Tim,

You totally RULE…! I’m going to do this install tonight to check this out, too.

Stay tuned…73 de Marty, KN0CK

1 Like
#3

I have tried to follow your instructions, but as many others have problem to get Gqrx running with LimeSDR Mini.
I have a “clean” Mint 19.1 and I have not tried to mix apt-installs with any builds. I have only done apt-installs from repos to 18.04.
I have problems doing “sudo python setup.py install” and couldn’t install the LMS7002Soapy Python package. I have the driver soapysdr-module-lms7 installed, but I only get the error:

terminate called after throwing an instance of ‘std::runtime_error’
what(): SoapySDR::Device::make() no match

when I start: sudo gqrx and type driver-info as:
Device: Other, Device string: driver=lime,soapy=0

I am not able to start gqrx as non-root.

#4

I have the same issue and cant seem to get anything to work…

#5

We need a solid instruction for installing Gqrx via PPA’s on a “clean” Ubuntu 18.04. If it is possibly at all?
My LimeSDR Mini can receive on Quisk and linhpsdr, even linhpsdr is a little weak and abort often.
I will give up now and clean my laptop with a fresh Mint 19.1, and maybe try building all packages from source instead.

73 OZ1OY, Jan