LimeSDR RF Loopback Test Failing

Hey Folks,

I’m having some problems with my LimeSDR-USB; I was one of the original backers, and since I first got it I haven’t had any luck in using it. I tried reinstalling and following multiple guides, but had no luck - I even got to the stage that I was recompiling the libraries in case it was a dependancy problem.

Never the less, recently I’ve tried again from scratch - running Ubuntu 18.04.1 LTS, and installed from scratch following this guide: Ubuntu 18.04 LTS, GQRX, Limesuitegui, gr-limesdr, LMS7002Soapy and Qspectrum

I’ve then run LimeQuickTest and consistently get the RF Loopback tests failing (as shown below). I’ve run LimeUtil --update to update to the latest firmware successfully, and LimeUtil --find shows the device.

Does anyone have any suggestions/recommendations, or am I out of luck?

Thanks in advance.

LimeQuickTest --no-gui

->Start time: Wed Jan 16 02:46:16 2019

->Device: LimeSDR-USB, media=USB 3.0, module=FX3, addr=1d50:6108, serial=0009061C02C7051A
Serial Number: 0009061C02C7051A

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 39750; 43506; 47262 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112937 (min); 5113062 (max) - PASSED
->Clock Network Test PASSED

->Read data: 11 05 12 11 05 12 02

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2-> LNA_L):
CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-18.8 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-17.9 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-21.4 dBFS, 5.00 MHz) - FAILED
CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-24.2 dBFS, 5.00 MHz) - FAILED
->Run Tests (TX_2-> LNA_H):
CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-59.9 dBFS, -0.81 MHz) - FAILED
CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-55.3 dBFS, 0.83 MHz) - FAILED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.30 seconds

@Zack, do you have anything to suggest?

Hi @au_sdr, I’m told that TX_2 and/or LNA_H must be damaged, but while TX_1 and LNA_W failed the QuickTest it should be OK.