Ubuntu 18.04 LTS Lime Suite install issues

#1

Hey all, I’m trying to follow the directions at: https://wiki.myriadrf.org/Lime_Suite to install Lime Suite to support my LimeSDR-mini on Ubuntu 18.04 LTS workstation.

Unfortunately when I get to the step to install limesuite I get the following:

ubuntu@ubuntu:~$ sudo apt-get install limesuite liblimesuite-dev limesuite-udev limesuite-images
Reading package lists… Done
Building dependency tree
Reading state information… Done
liblimesuite-dev is already the newest version (18.04.1-myriadrf1~bionic).
limesuite-udev is already the newest version (18.04.1-myriadrf1~bionic).
limesuite-images is already the newest version (18.04.1-myriadrf1~bionic).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
limesuite : Depends: libfltk1.3 (>= 1.3.1) but it is not installable
Depends: libwxbase3.0-0v5 (>= 3.0.4+dfsg) but it is not installable
Depends: libwxgtk3.0-0v5 (>= 3.0.4+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.

If I skip limesuite then everything works just fine, but now I still don’t have limesuite. I ran into the same exact issue last night back on Ubuntu 16.04.

Also, if I try to install soapysdr I get:

ubuntu@ubuntu:~$ sudo apt-get install soapysdr soapysdr-module-lms7
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package soapysdr

There’s no step to add another repo, so where should soapysdr be?

Thanks

#2

I had the same problem yesterday, it seems that soapysdr is renamed to cubicsdr, so do “sudo apt install cubicsdr” instead. Someone needs to update those instructions :slight_smile:

#3

I managed to install “soapysdr-module-lms7” only through Synaptic.

#4

Having the exact same issue on 16.04 as well. Seems like limesdr on Ubuntu is totally uninstallable. It’s been months I’ve had this SDR and I’m STILL waiting for software that I can actually install. Terribly frustrating!!!

#5

Trying to install from sources following:
https://wiki.myriadrf.org/Lime_Suite I get
ubuntu@ubuntu:~/gr-limesdr/build$ sudo apt-get install libsoapysdr-dev libi2c-dev libusb-1.0-0-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libi2c-dev

and

ubuntu@ubuntu:~/gr-limesdr/build$ sudo apt-get install libwxgtk3.0-dev freeglut3-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libwxgtk3.0-dev
E: Couldn’t find any package by glob ‘libwxgtk3.0-dev’
E: Couldn’t find any package by regex ‘libwxgtk3.0-dev’
E: Unable to locate package freeglut3-dev

So yeah, why did I buy this again???

#6

@unregistered436,

I hope this can help you:
https://en.dlyang.me/limesdr-mini-on-ubuntu/

#7

Thanks for the link. It’s well documented and I love the detail. Unfortunately it just doesn’t work for me when I get to the pothos install.

ubuntu@ubuntu:~$ sudo apt-get install pothos-all
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pothos-all : Depends: pothos-util but it is not going to be installed
Depends: pothos-flow but it is not going to be installed
Depends: pothos-modules-audio but it is not going to be installed
Depends: pothos-modules-blocks but it is not going to be installed
Depends: pothos-modules-comms but it is not going to be installed
Depends: pothos-modules-plotters but it is not going to be installed
Depends: pothos-modules-widgets but it is not going to be installed
Depends: pothos-modules-soapy but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

#8

Nope, these are very different things.

#9

Just did a fresh install on 18.04 working with the mini

If on ubuntu guess u also want gqrx and gnu radio

Remove old stuff
sudo apt-get purge --auto-remove gqrx
sudo apt-get purge --auto-remove gqrx-sdr
sudo apt-get purge --auto-remove libgnuradio*

Add ppa archives
sudo add-apt-repository -y ppa:bladerf/bladerf
sudo add-apt-repository -y ppa:myriadrf/drivers
sudo add-apt-repository -y ppa:myriadrf/gnuradio
sudo add-apt-repository -y ppa:gqrx/gqrx-sdr
sudo apt-get update

Install gqrx
sudo apt-get install gqrx-sdr

Install Limesuite
sudo apt-get install limesuite

Optional to speed up processing create a VOLK profile (dont use computer while this runs)
volk_profile

Done,

Howto install: Gqrx Gnuradio Soapysdr Pothosware Limesuite on ubuntu
#10

Looks like @csete packaged a Lime Suite build for 18.04, but it’s not been added to the regular builds. Just pinged @IgnasJ to see about packaging Lime Suite for Bionic also.

SoapySDR packages live in the same PPA and not sure if @joshblum will be packaging for 18.04.

#11

I’m willing to go with another Linux version, but didn’t see guidance on which is the best / most stable. If you think something like 16.04 is better I will move today, but I am hoping for something stable that I can actually get installed.

#12

Thanks! I will try this out in a few hours!

#13

Right now you’ll get the latest packages via the PPA with Ubuntu 16.04.x, but we should be adding 18.04 packages to the PPA soon I hope.

#14

Thanks! Are there install instructions? Following the ones for LimeSDR from a fresh install doesn’t work for me.

#15

@andrewback could the gnuradio release also be updated in the PPA?
Running into some qt bugs with 3.7.11

#16

This is the updated for 18.04 from the 16.04-17.10 howto version without pothosware and ettus UHD drivers

#17

SWEET, thanks! Will try in a bit.

#18

I can’t recall if there was some discussion of possibly stopping updating the GNU Radio PPA, in favour of either using O/S packages or some other install means. @csete, have I imagined this?

See also this post regarding SoapySDR packages in Bionic/18.04:

#19

The goal has always been to use as much as possible from the distributions and only package newer versions where it is necessary. With Ubuntu 18.04, packaging GNU Radio is no longer necessary but other packages are still out of date or are missing important device support.

#20

@csete I really like that goal, it should be easy for new users, and you did a great job there.

Although i can install gnu-radio from source or using pip i see enough user still struggle just to get started in linux and with sdr.

So should the ppa:myriadrf/gnuradio be removed from the iunstructions and bugs in gnu radio be reported to ubuntu ?
Or keep it there and report bugs to myriadrf and have a updated version there?