Failing starter guides, LimeSDR mini / GQRX, Win 10 & Buntu 18.04

I feel terrible posting this but I have been failing to get my new lime sdr mini to work the last few days. Before posting I read the discourse readme, followed install instructions by myriadrf, and ran the sdrtest. I’ve tried following guides to install on fresh install of ubuntu 18.04 and windows 10. I will separate my post into two sections for each OS and where each gets stuck.

I have been able to update firmware with the limesuite.exe on win 10 as well.

Windows 10:
LimeUtil and SoapySDRUtil can find device however cannot listen to anything in gqrx.
As you can see I have many different options. I am able to connect with the ettus soapy lime sdr mini,and using other with “driver=lime,soapy=3” (since soapySDRUtil returns the lime mini as device 3). I cannot connect to gqrx using the option in the drop down staring with LimeSDR.

Fresh Ubuntu 18.04 w/ Virtual Box:
I tried installing using both PPA and building from source using this guide mainly;

I have ensured I have guest additions and am using usb 3.0 LimeUtil and SoapySDRUtil can find the device.

However when i launch gqrx and use other as device and “driver=lime,soapy=0” and start DSP processing no waterfall appears.

Hopefully I’ve provided enough information to show that I have attempted to solve this problem myself and someone can help me! Admittedly I am very new to the world of sdr. Thank you for taking the time to read my post.

For Ubuntu (apologies, I dont have windows), try installing GQRX from the snap store. Check -> “The LimeNET store”
I personally never had any success with the default GQRX Ubuntu 18.04 version.

This is expected behaviour. For some reason selecting LimeSDR in Gqrx doesn’t work and you have to use the device string.

I’m afraid we don’t officially support use inside a VM. It should work in theory and it may work, or may not. Too many variables and device passthrough can just generally be problematic.

You can find the snap store documentation here:

And browse them via:

Snaps bundle a given application or set of apps with Lime Suite (the driver). However, we don’t offer support on using these inside a Linux VM.

If you’re running Windows and want a general purpose SDR application I would highly recommend SDR Console:

Thank you both for taking the time to reply. Today I am going to try to get in running either on a dual boot laptop with ubuntu 18.04 or i have pi 4 i will have to see if there is support for ubuntu core though. looks cool ill check that out for something easy. Really want it get everything up running!