[specific to preproduction 1.4 boards] limesdr issues with recent firmware


#1

I can’t seem to get my limesdr working with sdr-console v3. The software detects the lime but when I go to “start” the radio the GUI hangs for ~5 seconds then comes to life but there’s no waterfall or sound. The board is detected by LimeUtil and I can connect to the board with LimeSuite. The address string in sdr-console matches the string in LimeUtil.

If I plug in an RTLSDR, sdr-console works as expected.

@martywittrock I know you have several videos using sdr-console v3 with the Lime. Any tips/tricks?

thanks

philip


ExtIO_LimeSDR.dll not working in HDSDR
#2

tagging @SimonG4ELI also.


#3

Phillip,

The most important thing to remember when working with a Lime under Windows is that you can only use the Cypress (Windows signed) drivers with SDRConsole V3.0. If for any chance you’re using drivers that ZADIG assigns, the Lime will either not work at all or hang. Please ensure that you’re using the ‘MyriadRF’ USB driver or that the Cypress drivers have been installed and the drivers for ZADIG are disabled. Once you get that running you’ll have to select the LimeSDR from the radio select list and then click on the instance of the Lime that it sees. Once you have that going for you, you’ll start and play fine.

Again, check to make sure that the MyriadRF (signed Windows driver for the LimeSDR) are installed and shows as a device in the Device Manager in Windows.

Let me know if there’s any other issues on this, Phillip,

73 de Marty, KN0CK


#4

Thanks Marty. I believe I am using the correct, signed driver from github:


If I load zadig, just to view the driver, I see the current drivers are the cypress ones:

image

And to be clear LimeSuite and LimeUtil are both being run under Windows.

Radio works fine in gnuradio under Linux so I know the hardware is OK. I get the same UI pause if I change bandwidth, but no spectrum.

Thanks,

Philip (KI4VUP)


#5

Phillip,

All good and I figured the drivers were right on your machine, it just goes with the territory to ask. :slight_smile:

When I’ve had this issue occur on my machine (and I’ve had it happen a time or two) it’s because the install wasn’t quite right and I do these things:

1.) Uninstall the application
2.) Reset my PC completely
3.) Re-install the app
4.) Reset the PC one more time
5.) Try the app

If you’ve already been through those steps, then disregard, but I’d go that far given your results. SDRConsole works pretty well with ‘well heeled’ (FAST) PCs - and with you running GNSS-SDR I would figure you’re on an i5 or much better. So It should work great and not hesitate/stop with the Lime.

Write back with your results - we’re all here to help,

73 de Marty, KN0CK


#6

I’ll give it a go, thanks. Part of the problem may be I had an early 1.4 board installed on this machine (back when you were supposed to manually install the Cypress drivers, then the LimeSDR drivers, I see the old wiki page now has a warning that those instructions are dated) and maybe that is mucking things up. Thanks.

Related question: Do you have pothos installed on the same machine?

philip


#7

A clue! When I try to test timing, I get the following:

The delay between the initial request to set frequency, and the failure message, is about the length that SDR Console pauses!

I also get this under ubuntu:

Looks like perhaps it is a hardware issue, or at least a systemic software issue between ubuntu and windows?

any ideas?

philip


#8

Phillip,

Yep - sure do…I did the ‘full boat’ installation that includes Pothos, Cubic SDR, GQRX, etc.

Marty


#9

Phillip,

Do a ‘programming’ of the firmware for your LimeSDR 1.4 using LimeSuite - that may straighten out the issues you’re seeing.

Marty


#10

Marty,

I tried this. Both times LimeUtil tells me

“Gateware version mismatch!
Expected gateware version 2, revision 12
But found version 0, revision 0”

So then I update with LimeUtil --update, with the same result as earlier (can’t set frequency).

Programming in Lime Suite is serving the same function as LimeUtil --update, correct?

philip


#11

Phillip,

Pretty common bug with LimeSuite to show a version 0, revision 0. Did you do the connection settings to connect your lime to read it? Try that and then try the programming again. LimeUtil serves a similar purpose as SoapySDRUtil - they’re both there to dun simple diagnostics on your Lime to make sure it’s there.

Again, do the connection settings and then try programming again - sometimes after programming it takes connecting and disconnecting your Lime from the USB 3.0 to make it see it correctly and then query it.

Marty


#12

Thanks Marty. I open up Lime Suite, connect to the board, go to the programming menu, select “FPGA Flash”, pick the rbf file (“LimeSDR-USB_HW_1.4_r2.12.rbf”) then click “Program”. After that I repeat with “FX3 Flash” and file (“LimeSDR-USB_HW_1.4_r4.0.img”). I then disconnect Lime Suite, unplug/replug USB, and run “LimeUtil --timing” with the same error (although this time it does not complain about gateway mismatch, so thanks for the tip!)


#13

Phillp,

I think this is a job for @joshblum now or @Zack could sort this issue out for you…They’re the heavy hitters on the hardware (Zack) and the Software (Josh)…Let’s see if they have any suggestions.

Great to hear things are moving in the right direction…Keep at it…!

73 de Marty, KN0CK


#14

Hi @hahnpv,

Could you try this procedure, please:

  1. Use this software:
    https://wiki.myriadrf.org/LimeSDR-USB#LimeSuiteGUI_for_Windows
  2. Perform quick test procedure up to step 3.7 at least:
    https://wiki.myriadrf.org/LimeSDR-USB_Quick_Test
  3. Post print screen of the message log window.

#15

Philip,

For support I recommend the SDR-radio.com community (See help panel in the Console’s ribbon bar). I don’t monitor this forum.

I expect your problem is available USB power as is so often the case.

Again, for help with my software please use the SDR-radio.com community.


#16

Thanks Sam. It looks like a larger issue with my LimeSDR as the RTLSDR and HackRF work just fine. Thanks for the great software,

philip


#17

Do you have a powered hub? Remove all USB devices not needed - hackRF, RTL Dongle etc. These eat USB power even when not started.


#18

Thanks @Zack

Here’s a screen cap of the FFT and the main window with message log.

Also, if you attempt to read chip temperature it fails:

image

Let me know what else I can do. Obviously the MIMO works although the receive FFT looks wonky. I also tried the test on a brand new machine that had never touched the LimeSDR and saw a similar FFT.

philip


#19

Brand new VM. Worlds second-simplest GNURadio flowgraph.

When I hit play on the flowgraph it takes several seconds to “program MCU” then fails. Screen cap below:

Osmocom block:

Admittedly I haven’t used the Lime on receive in a few months but I don’t recall the MCU programming.

philip


#20

Right, this is a new behaviour AFAIK.

@IgnasJ, could you advise, please.