LimeSDR 1.4s out in the wild. Numerous issues

For those who are coming to this post, having just got their SDR and having some issues: Please see the bottom of this post for helpful links. Be sure to grab the latest PothosSDR build as it has patches for SoapySDR that appear to be required.

First off, I’d like to say I have been happily/furiously playing/fighting with my device for nearly 8 hours now and here’s some of the issues I’ve ran into.

Most links strewn about the redirected landing page point to horribly outdated or flat out incorrect information. Unless you stumble on the root MyriadRF github right off the bat, you will undoubtedly end up with old drivers and Lime Suite GUI. Not only that, but from the available documentation, users will be under the impression that Lime Suite will automatically download and update firmware. It’s quite the mess.

Now, to the issues I’m currently experiencing:

I have acquired the latest Lime Suite. I have removed the drivers that I hand massaged into working with the revised device ID and installed the new signed drivers. I have also flashed the new gateware/firmware/what-have-you for both the cypress and altera chips.

I’ve had several odd behaviors from SoapySDRUtil and Lime Suite through this process, but after all this, I’m back to the same behavior as I had out of the box. Lime Suite will enumerate the device and connect to it, I can run calibration with varying degrees of success usually, and can occasionally get the FFT module to display a live feed. Unfortunately this live feed is of nothing of importance and does not change with different parameters, and that’s assuming LS doesn’t just crash. In addition to that, the “Read Temp” button usually reports a semi-random temp, ranging from 130C to +1000C and only seems to stabilize after LS has had the FFT running for a bit.

SoapySDRUtil will enumerate the devices, but when I “probe” or “make” the utility throws an error with a call to setBandwidth(Rx, 0, 30 MHz). The error being CFB_TIA_RFE step size out of range. Error probing device: CFB_TIA_RFE step size out of range.

I’m in contact with several people who are expecting their early bird units to arrive within days and am hoping to have most of the issues worked out before then to save them the headache.

MyriadRF Github
Download all drivers, firmware, gateware, Lime Suite GUI from here. Any other sources are outdated.

PothosSDR Wiki
Download links are on the right hand side.

Lime Suite User Guide
A little outdated, but useful for flashing new gateware and the like.

LimeSDR User Guide
Also currently a little outdated, but might give you some insight into the blinking lights.

The team is currently working on getting links updated and producing a more accurate “Quick Setup Guide” that helps in understanding the bare minimum to test the hardware and possibly use other SDR software, once a few more issues are resolved. I can post links to this guide along with the software required for a quick start, assuming I get the go ahead from the team. I don’t want to release any documents I don’t have approval for.

Hi @tktech,

The URL should be redirecting to the main project page:

And will be updated to do so very soon. That page will also be rearranged slightly this coming week to put more of the key links at the top of the main content.

The automatic download for FPGA and FX3 images will be in imminent new build.

I’ll drop you a line via e-mail so that we can get any issues resoled promptly and to ensure that others have a much smoother experience.

Thanks for your patience!


Thank you for the response Andrew, I look forward to working with you.

For those that might be looking for the Windows 10 drivers, here is the github link for the LimeSDR. I did try the older CyUSB3 driver that I had from other projects and this did not work for me, but the ones that are packaged in the LimeSDR Github page did.

I am just getting started so we will see if I run into any issues. Andrew, you mentioned a new build of the Lime Suite, but it seems that the latest build is from a handful of days ago. Source code seems to indicate that fixes are coming, but I am guessing that they have not yet made it into a final build. Can you confirm this?


Please see this discussion, too, that Paul started (outside of the LimeSDR - I think he meant to put it under LimeSDR):

I’m sure all the Backers with new LimeSDRs will be waiting for the answers…Like, me, too (the link I sent shows what I’m seeing with my new LimeSDR, too).

73 de Marty, KN0CK

Have a new one running here. Board is seriously hot while in gqrx. Heatsinks and fans needed?


Seriously? What’s your secret? Did you update the firmware/gateware or are you running stock? Linux or Windows? Can you post a SoapySDRUtil --probe output?

And mine gets pretty toasty too when running through Lime Suite alone. It does have a 3.3V fan header on it, so I figure they do intend for it to be heatsunk and cooled for any heavy usage.

EDIT: PothosSDR came out with a new build today. This solved the SoapySDR issue.

@Aeroengineer1 yes, the older Windows driver used the default Cypress VID and PID, so will not work with more recent firmware versions, which switched to using our own PID under the Openmoko VID.

For a Lime Suite binary build on Windows please use the PothosSDR installer, which got updated yesterday:

I was using the updated but unsigned driver that I was using with the 1.2s board and the latest Pothos version.

I saw mention of a signed driver now. Any different from the one that I have? Where is it available at?

I think the only difference is that it will be signed, if you are currently running the latest build of Lime Suite and have the latest firmware and gateware images loaded and everything is working fine.


do we need to do any upgrades to the new boards that we got yesterday, or should they have the latest version on them, and how often do you expect these upgrades, is this going to be a constant thing that could break the support every week? It seems in the Linux world drivers are constantly updated daily, one reason I dropped Linux for my radio stuff, I want to actually listen to a radio not experiment, and have to be constantly upgrading to fix broken issues…?

Paul - NN4F

Hi Paul,

The firmware has been updated since backer boards were programmed, so they should be updated. I’m not sure whether these were critical fixes, but it’s worth doing anyway and Lime Suite now automates the downloading of the latest FX3 and FPGA images, with the actual update process being fairly quick.

Also please note that it should be very rare that an update to firmware or Lime Suite requires application software to be updated, if it makes use of supported APIs.

With modern, complex platforms such as this periodic updates are inevitable, much in the same way that application authors update their software. If for no other reason that we build on top of lots of existing open source software, which receives fixes, new features and performance improvements etc.

Here’s my oobe (and a nice box it is!) on Ubuntu 16.04 LTS:
Installed packages per

The LimeSDR is seen by LimeUtil --find (sorry for usb2, older hardware!)
root@acer1:~# LimeUtil --find

  • [USB 2.0 (LimeSDR-USB), media=USB, module=STREAM, addr=1d50:6108, serial=0009060B00471F23]

What is now called LimeSuiteGUI instead of lms7suite - connects, reads values, etc.

And nothing here
root@acer1:~# SoapySDRUtil --find=“driver=lime”

Soapy SDR – the SDR abstraction library


linux; GNU C++ version 5.3.1 20160413; Boost_105800; UHD_003.010.git-216-gb1c2d4bb

No devices found!


Someone posted a link to the download section for the images etc, can’t find it now, can you repost it, I did the program module, but it seems to be taking for ever to download, want to check the files area, so I can grab them separately… it’s trying to grab 1.3r2.0, not sure if that is the latest…



I’d agree with Paul that the location for the new(er) .IMG and .RBF files is confusing to know what’s the current version. I’m assuming from the list that the following are the current versions:


Please let me know if this isn’t correct because I’m planning on reflashing my older LimeSDR and then checking (and potentially updating) the new LimeSDR I just got yesterday in the mail.

I know this sounds a little ‘newbie’ of me, but it would decrease the confusion for others if the older versions of the IMG and RBF files went into an ‘Archive’ subdirectory on the same link and then the current versions could be on the shell so you know what to download. Right now there are so many old versions mixed with the new version that it would make it confusing for the other Backers what to download (and I will say that the boards we received should be the latest version…Hopefully).

I’ll keep my ear to the ground if there’s anything else that happens, but I’m planning to try to get my new USB drivers installed for Win10 for my new LimeSDR and at least see LimeSuite see that new LimeSDR…Right now I’m still on the older drivers and older SDRConsole that works with my older LimeSDR.

73 de Marty, KN0CK


GO here… Http://

LimeSDR-USB_HW_1.3_r3.0.img looks like the latest

I just updated both of these files…


Thanks for the info - - You’re updating with the new LimeSuite, right? I’m assuming so, so I’ll have to change that, too…Agree with your observation that the rollout was a little rough on this one… :confused:

73 de Marty, KN0CK

@martywittrock, @nn4f_radio
I could be a little behind on things,as I’m at work and away from my device, but something does not look right with those files. It could be just a renaming of the files, but there is little to clearly distinguish which is the current fx3 firmware and which is the gateware. A checksum will probably confirm that they are what they should be, but I would probably stick with the github repos.
FX3 Firmware
and to be complete:
Flashing Images

Haven’t heard of anyone having that particular issue yet, even with the older Soapy release. Of course, ensure you are running with the latest drivers, firmware, and gateware. The FX3 firmware was patched recently for an enumeration issue, perhaps that’s where the answer lies.


Im using the limesuite that installed with the pothos setup from yesterday…

@TKtech, those are the files that are in the download section that was posted, they installed OK here
just not sure how to check what version you have installed, apart from the device info module, but it only say firmware 3 and hardware 4, no specific image names…

this is what Limesuite now says I have installed…