[Need help] LimeSDR Upgrade failed :-(

#1

Hardware:LimeSDR
System:windows 10
software:LimeSuite GUI ver 19.04.0-PothosSDR-2019.06.09-vc14-x64

Yesterday,I Installed a new LimeSuite version(19.04.0),but when I Open the FFT Viewer, I can’t see any single wave, I noticed a hint below.(In previous versions, it was working normally.)


So,I clicked the buttons in turn.

I think I may have made a big mistake, because this module is not working properly now :frowning:
Now I Open LimeSuite and connect LimeSDR. It looks like this::sob:

Very desperate, really need help!

Test info:

[ TESTING STARTED ]
->Start time: Thu Sep 19 11:06:51 2019

Write(64 bytes) failed
Gateware version mismatch!
Expected gateware version 2, revision 17
But found version 0, revision 0
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
->Device: LimeSDR-USB, media=USB 3.0, module=FX3, serial=0009070602501436, index=0
Serial Number: 0009070602501436
Write(64 bytes) failed

[ Clock Network Test ]
->FX3 GPIF clock test
Write(64 bytes) failed
Write(64 bytes) failed
->FX3 GPIF clock test FAILED
->Si5351C test
Write(64 bytes) failed
Write(64 bytes) failed
FAILED
->ADF4002 Test
Write(64 bytes) failed
FAILED
->VCTCXO test
Write(64 bytes) failed
FAILED
->Clock Network Test FAILED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 03 01 12 03 01 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
Write(64 bytes) failed
SPI_write() failed
Write(64 bytes) failed
SPI_write() failed
Write(64 bytes) failed
SPI_write() failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
->LMS7002M Test FAILED

[ RF Loopback Test ]
->Configure LMS
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
Write(64 bytes) failed
SetFrequencyCGEN(491.52 MHz) failed
Failed to set sample rate
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 42.09 seconds

#2

The “version 0, revision 0” error usually means corrupted firmware and/or a bad USB cable or port that is unable to deliver enough current.

Can you try another USB port and/or cable (both USB 3.0 or better) and firmware update again. Worst case if it will not update via the GUI or LimeUtil, you can use the Cypress utilities. See:

https://wiki.myriadrf.org/LimeSDR-USB_Board_Programming

#3

Warm it up with a hair dryer for a bit and then try to use it…no really. Try that.