LimeSDR only works with external power

#1

Hi everyone!

I’ve had a LimeSDR USB board for some time now and all seemed fine until recently it wouldn’t power up when connected to my computer (the same USB3 port that used to work previously). No LEDs blinking on the LimeSDR, board not found on PC.

Then I’ve checked my LimeSDR when connected to an external power adapter (12V) that I’ve used previously with this board and computer and… Surprise - the LEDs started blinking on the LimeSDR!
But when I’ve tried connecting the LimeSDR and external power to my laptop - everything goes dark (e.g. my laptop actually shuts down totally!).

Not sure what happened, as everything used to work absolutely fine in this exact configuration (laptop, LimeSDR and external power adapter).

What do I need to do to be able to use my LimeSDR again?

Help, please!

Michal

#2

There is a USB power switch IC. You have fried it. Even though it’s rated for 16VDC & Lime specs it at 12VDC max, some have found them to pop. There is a resistor pad (R167 I think) that you can bridge for bypassing the IC & powering only through USB.
I went through the same thing & now will not use external power at all.
If a computer is not supplying enough power, use a quality USB3.0 hub. NOT a cheap Chinese one.

Ed

1 Like
#3

Thanks, Ed!
Before having a go at soldering this I thought I’d do a quick test and manually shorted R167 and then plugged the USB connector into my laptop, which results in the LimeSDR LEDs blinking (yeay! both the LEDS2 are green and the LEDS1 closed to the edge of the board blinking red/green) but the device doesn’t seem to be showing up on my laptop (e.g. no familar USB device plugged in sound in Windows…).
Have you had this issue as well?

Michal

#4

You will probably have to flash the FX3 firmware with the Cypress tool.
Search " Cyperss FX aa7qq "

Ed

#5

I think I’ve found the post you’re referring to - but the issue is that for limeutil to work, my device needs to be recognised first (e.g. otherwise I’ll have a “No devices found” message) - but I can’t get to that stage…
I’m wondering whether there’s some permanent issue with the USB and it’s no longer visible as a device in Windows?

#6

I went through it many times. You need to download the Cypress tool kit & the FX3 firmware.
Are you seeing it as a “Westbridge device”? Might be in USB or “Other” in Device manager.
After you get it reflashed, you can use Limesuite.
Look up " Westbridge "
Things changed through that thread. You will see that I put up directions towards the end. Use them & you should be all set.

Ed

Ed

#7

I had a look, tried it on two laptops - but the thing is, there’s no Westbridge device in Device Manager either… Also when I try looking at the " No device found problem, Westbridge device" post and follow the steps to upload the firmware - that doesn’t help, as LimeSuite doesn’t see this board at all in the list after clicking “Options,” then “Connection Settings,” (not even as a Westbridge…).

It’s like the system doesn’t recognize any device at all when I connect my Lime via USB… There’s absolutely no reaction from Windows / Device Manager when I plug in my LimeSDR (but whenever I try a different USB device like an AirSpy in the same USB port, there is the familiar Windows sound and it appears in Device Manager).

#8

Again, you need the Cypress tool to start the process.
First thing to do is to open “Device manager” & show a screenshot. (Are you using Windows?) This should show the “Westbridge” or “Unknown” device.
Once you confirm that, we can move forward.
Download the Cypress Suite & install it on your computer.

Ed

#9

I am using Windows 10, I’ve went through the devices in Device Manager, but like I stated earlier - I don’t see any Westbridge device. I also don’t see any Unknow devices or any changes to the device tree when I plug in my Lime.

I do have the Cypress tool, I’ve tried running CYControl.exe (as Admin, of course), but it doesn’t see any devices at all (not even the Cypress USB BootLoader that’s shown on MyriadRF screenshots). I’ve tried removing and replacing the bootloader jumper, but that has no effect (only difference is that with no jumper, both LEDS1 leds are a constant red).

#10

It shows a “USB storage device”. Do you have one? If not, it may be the one you want.

Ed

#11

I do have a flash drive connected, so that’s not it. (also checked that it’s still there when I disconnect my LimeSDR).

I really had a thorough look throughout multiple categories in the Device Manager tree. tried scanning for HW changes, tried noticing any differences between having my LimeSDR plugged in and unplugged and nothing… It’s like my laptop does not see anything connected to it (despite powering it).

Also if I understood some of the other entries re: flashing, the device should be seen one way or another in tools like CyControl from the Cypress Suite or in the Connection Settings in LimeSuite (or show up with LimeUtil --find) - yet none of these tools show any device whatsover.

#12

OK, you are on the right track. When I whacked my USB port with 12VDC, like you did, those 2 USB ports never worked right with the Lime.
If you have access to a different computer, try that.
Your process of finding it is right.
Now, one more question. Have you bridged the R167 pads? If not, it may never recognize.

Ed

#13

Yes, I have bridged R167 with a nice piece of solder today - best proof are the LEDs blinking (without it the board was fully dead) - so thanks for the tip!

But I am clueless as what to do next - I’ve tried already on two different PCs as well as a Mac. In all of these cases, it looks like the USB device is not seen at all by the computer - like if there was absolutely nothing there (not even an “Unknown Device” or Other or anything like that - total emptiness) - despite the LEDs lighting up on the LimeSDR.

Michal

#14

And my worries have been confirmed as I managed to get my hands onto USBView, a tool from Microsoft’s Windows SDK, that shows all the USB ports and devices. I’ve managed to identify which port I was connecting to (with the use of another device) and when connecting my LimeSDR, this tool does not see anything there (No device) - just like if it was an empty port…
Now I’m starting to lose hope that my LimeSDR will ever become working again…

#15

Of course it can work. It’s just the USB end.
At this point, you should download the V1.4 schematics (Plug or socket) in .PDF from the Lime Wiki.
Even if you don’t understand schematics, familiarize yourself some. Then, I’ll spend some time to figure out all of the power & signal measurements that I can.
What do you have for test equipment & what is your electronics experience?

Ed

#16

Ok, so there’s hope, good! :slight_smile:

I’ve just downloaded the schematics.
As for test equipment, I have a digital multimeter.
As for electronics experience… Well, it’s been ages since I studied basics of electronics as part of Computer Science at the Uni…
I am able to do very basic soldering, but not really the tiny SMD stuff like on the LimeSDR (so, soldering R167 to bypass the IC was probably at the limits of my capabilities).
Had a look at the schematics - but I’m afraid I have no idea how to get from that + my multimeter to any conclusions and solutions - so any help here would be greatly appreciated.

Michal

#17

OK I will have a good look at things this weekend. Even with a DMM, we should be able to figure out where the continuity ends.
Keep looking over the FX3 & Board power schematics Top one on left is USB power switch.
You need not understand it, but familiarize it. If possible, have them printed out on 11"X17" paper for better clarity & easier flipping back & forth.
Luckily, the Lime folks gave us some good test points.
If we can diagnose the bad part, you can bring it to a PCB house to have it replaced.
What Country are you from?

Ed

#18

Thanks, Ed!
I’m from Poland, but also spending a lot of time (2-3 days each week) in the UK (London).

#19

OK, if you were in the US, we could do it over the phone. If we narrow it down, I might put International calling on for a month. It’s cheap.
Is your English decent?

I will probe around on mine in the USB/Power chain & get some readings. THat way, you can check all of those & we will collaborate on it.

Ed

#20

@AA7QQ - Ed,

Skype works excellent, too… :slight_smile:

73 de Marty, KN0CK