LimeSDR-USB - USB not working

Hi,

I have a LimeSDR-USB (v1.4s) that has suddenly stopped working. It is no longer recognised as a USB device when connected to a computer. (E.g. on Windows I no longer get the sound indicating a new USB device has been connected when plugged in - and there is no new device displayed is device manager). Have tried on multiple computers with the same result. Have also tried hub and direct USB 3 ports.

When connected, all four LEDs are solid (2 green, 2 red). I tried disconnecting the FX3 jumper - no difference. Neither does pressing it’s reset button.

Probing the USB differential data pins shows them as both being low. Probing the FX3’s 19.2MHz crystal XT1 also seems to show no activity. Neither does there appear to be any activity on the clock line to its SPI flash. The FX3 seems to have some power, as it’s getting warm.

Any ideas?

Thanks,
Jon

May be related to LimeSDR USB doesn't work with MacOS 10.15.6 Catalina I reported a similar issue with MacOS not a long time ago. (I’m pretty sure LimeSDR worked with MacOS until something went wrong.) Do you have a chance to check your LimeSDR with Linux to make sure this is not a hardware issue?

There’s no USB activity so appears to be a HW/firmware issue.

DO you see a Westbridge device in your Device Manager?

Ed

Hi Ed,

Nope. No new devices appear when plugged in.

Have you tried a different cable or plugging it in directly? How long have you had it?

Ed

Hi Ed,

Yes, I’ve tried different hubs, direct to a variety of PCs (Windows, Linux and Mac) and no joy, so I presume it’s a h/w issue. Had it since Jan this year.

I have a similar but slightly different problem: I get the USB LED blinking red/green, but the device does not show up in lsusb when plugged in, nor do I see any messages in dmesg. I’ve tried pulling the jumper, and the 2 USB status LEDs are red, but again, no USB device, no dmesg. I’ve tried both USB2.0 and USB3.0 ports (multiple ports, too).

To my knowledge, just pulling the FX3 reset does nothing, unless you have the Cypress suite & flash the unit. Give that a try. Just pulling the jumper & powering it up probably wipes everything, I think.

Ed