LimeSDR Mini USB 3.0 no more working

I am using three LimeSDR mini for more than 6 months - everything was fine but in two weeks, two LImeSDR are connecting only in usb2.0 (the third one in USB 3.0). I am using Lime Suite 19.01. Try on several PC same issue. Firmware update done. Any idea?

Are they all using, or at least have been tried, with the very same PC/USB port and cable?

Thanks for your answer
I have three LimeMini with three different cables and two PC (one Windows, one PC).
The LimeMini still working in USB3.0 is working whatever the PC whatever the cable.
I don’t think this is to do with the issue

I suspect more the following issues but they is not rational and give no idea how to solve:

  • the USB connector is fragile on a mechanical point of view. But if some problems due to this fragility, why usb2.0 is working?
  • all problems aeve happen after intensive use of limesdr with gr-iridium. But I don’t see any technical reason that after a few days, USB3.0 is no more working

What is also strange is that the default appears on the second Lime juste a few days after the problem appears on the first one. It’s the same root cause but which one.

These are using different pins. Hence it is possible that USB3 pins were damaged. Try to inspect pins of USB connector.

Hi, i have a similar problem, my lime mini wasn’t used very often for more than 20 connections, for the first time I realized that there was a problem when I tried to update the firmware through the built-in utility and it failed! and the device was not detected anymore, after a long investigation I could not understand what happened, it turned out that the connection was usb 2.0 although all the ports in computer 3.0 I use dell xps 9570. by many reboots and reinstalling the driver it was detected as 3.0 and the firmware install was successful. and even now when it works it connects via 2.0 and reinstalling the driver allows you to connect as 3.0 and then, through some re connections, rebooting the same, any idea?

Hi @tony_copper,

Have you tried another machine?