LimeSDR Mini - USB 2.0 - USB device not recognized

Hi guys,

I understood that LimeSDR Mini should work also on USB 2.0, at least one fellow ham radio operator has a Mini that is working properly.

I have board version 1.2 and I believe I am running on the latest firmware version.

Firmware: 6
Hardware: 2
Protocol: 1
Gateware: 1.30

I have tried on 3 different Windows 10 machines, but the operating system is not recognizing the LimeSDR Mini on USB 2.0. However, it is working properly on USB 3.0 connection.

I have tried to downgrade to older firmware versions, than upgrade again. The LimeSDR Mini is still not recognized on USB 2.0 on older versions or the latest version.

I am getting the “USB device not recognized” error and in Device Manager appears as “Unknown USB device (port reset failed)”, screenshot attached.

While connected to USB 3.0, all tests are successfully passed using the LimeQuickTest utility.

Is there any way to make the LimeSDR Mini work on USB 2.0?
Is this forum the only way to get support from the manufacturer?

Thank you in advance,


@yo3ihg - Vlad,

You have to use the FTDI Driver for Windows PCs for the Mini to work with the apps. You can find that information here how to download and install the driver:

Hope this helps, and let us know when it’s working for you -

73 de Marty, KN0CK

Hi Marty,

I have followed exactly the steps from the provided link. On USB 3.0 works perfect, but on USB 2.0, Windows says that the best driver is already installed. Then I uninstalled and erased the driver and tried to install it from scratch, but again I am getting the same message “the best driver software for your device is already installed”.

When I replace my LimeSDR Mini with another, it works on USB 2.0 as it should be.

73, Vlad YO3IHG

I even disabled driver signature enforcement and started Windows in safe mode, then manually installed the driver. The USB device still appears with an exclamation mark on device manager.


This is my expirience with USB 2.0: I was experimenting with old PC, no USB 3.0 ports, upgraded with 3.0 PCIe card (NEC chipset), OS fresh Win 10 x64. Everything was fine until I try old 2.0 port just out of curiosity. It worked fine for low sample rates (did not test higher SR). After I try again USB 3.0 port device was not recognized! No caracteristic Win sounds about device hotplug or removed! Nothing! Mini LED worked as usual. Then I try my main PC with identical result! After several driver removal-instal Mini finaly decide to work via USB 3.0 ports. And this is not first time FT601 refused to work!. I suppose there is some locking mechanism inside FT601 (or maybe bug) which prevent normal op mode, something that even Lime develop team is not informed about.

Is there any way to get technical support from the LimeSDR manufacturer?



Apparently not.

I think I will sell my LimeSDR Mini and use the Adam Pluto, which is perfectly working.

Hi @yo3ihg,

Do you mean another LimeSDR Mini? If yes, then contact CrowdSupply regarding RMA.

Hi Zack,

Exactly, another LimeSDR Mini is working on the same conditions with USB 2.0.

Please let me know how can I contact CrowdSupply?
The only way that I was able to find to get support is this forum.
The LimeSDR Mini was bought from Passion Radio.


In which case I suspect you would need to go back to them for RMA.