LimeSDR and GnuRadio 3.10

I seem to be having problem getting the Lime to work with GnuRadio 3.9 or 3.10 - no matter what interface I try to use (gr-limesdr, gr-soapy, gr-osmo), when push comes to shove and the flowgraph runs, I get a failure to connect a port on the Lime stuff.

Does anybody have a PPA for a version of the Lime interfaces that works with 3.10? or have a success story building from source?

Gnuradio is the master branch, the work in progress, there is no release (yet). Trying to use 3.10 would be like trying to drive a car while it is still in the factory being assembled.
The latest official release right now of Gnuradio was v3.9.1.0, which was released about a month ago (2021/03/22).

Currently gr-limesdr ( ) only supports Gnuradio 3.8 which you could probably install using pybombs, but me personally I’ve not tried since I posted this thread nearly three months ago when was initially released. For gr-limesdr to work with gnuradio 3.9 will require changes and a new release branch of gr-limesdr.

Or if you absolutely do need to use Gnuradio 3.9, and you can forego all the advantages of using gr-limesdr, then you could probably access LimeSDR hardware via gr-osmosdr, which recently accepted a pull request to added support for Gnuradio 3.9 (2021/01/18), using the soapy bind instead.

The problem is that 3.8 doesn’t work due to other problems, 3.9 doesn’t work, 3.10 doesn’t work. I’ve fully removed Gnuradio and reinstalled 3.8, 3.9, and 3.10, and at every step, something is broken. 3.10 works except for the LimeSDR stuff.

Use the osmosdr soapy binding then ? (soapy=0,driver=lime)

I tried Soapy directly and OSMO - port connection fails in all cases.