Gr-limesdr plugin for GNURadio

I m trying to use gnuradio and gr-limesdr plugin. It works well for gnuradio version 3.7…
But when I try to open some of the gnuradio sample projects with gnuradio version 3.7, program gives an error such as "1:1:FATAL:PARSER:ERR_DOCUMENT_EMPTY: Start tag expected, ‘<’ not found >>> Failure ". I have installed last version of gnuradio (version so the error problem has solved. But it seems gr-limesdr not working with last version of gnuradio :slight_smile:
Please advice…

You might want to use the maintained 3.8 branch ( ) which was officially released 2019-08-09 instead of trying to use what is actively being coded right now.
If you look at the official pybombs recipe for gnuradio it currently points at the maint-3.8 branch and that would be what everyone else would be using.

This is how I would “pybombs install gr-limesdr” and/or “pybombs install gnuradio” from source code.

1 Like

I just read the pybombs recipe for gr-limesdr and it is currently pointing to the gr-limesdr master branch (3.7) instead of to the gr-limesdr gr-3.8 branch and that will be a problem.

Just needs one line in the recipe changed from:
gitbranch: master
gitbranch: gr-3.8

EDIT: I submitted a request for the update:

The gnuradio recipe was changed to default from 3.7 to 3.8 on the 19 Sep 2019, that is over 4 months ago.

1 Like

thank you mzs
I will try gnuradio maint-3.8 version

when I try to install version 3.8, it gives compiler error

[ 52%] Building CXX object gr-filter/swig/CMakeFiles/filter_swig.dir/CMakeFiles/filter_swig.dir/filter_swigPYTHON_wrap.cxx.o
c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-7/README.Bugs> for instructions.
gr-filter/swig/CMakeFiles/filter_swig.dir/build.make:62: recipe for target ‘gr-filter/swig/CMakeFiles/filter_swig.dir/CMakeFiles/filter_swig.dir/filter_swigPYTHON_wrap.cxx.o’ failed
make[2]: *** [gr-filter/swig/CMakeFiles/filter_swig.dir/CMakeFiles/filter_swig.dir/filter_swigPYTHON_wrap.cxx.o] Error 4
CMakeFiles/Makefile2:7222: recipe for target ‘gr-filter/swig/CMakeFiles/filter_swig.dir/all’ failed
make[1]: *** [gr-filter/swig/CMakeFiles/filter_swig.dir/all] Error 2
Makefile:140: recipe for target ‘all’ failed
make: *** [all] Error 2

The very first search hit on “c++: internal compiler error: Killed (program cc1plus)” was
check your log files to see if your OS killed cc1plus because the OS was running out of memory.

How much RAM in the machine ( “cat /proc/meminfo” ) and how many CPU cores (“cat /proc/cpuinfo”). My guess would be that there is no swap space configured and the compile is building two times as many processes in parallel as you have CPU cores and the machine does not have enough RAM for that to happen.

Try something like the following to check the currently number of build processes to run in parallel:
$ pybombs config makewidth
And something like the following to reduce that to less if your log files do show that the build process was killed by the OS because it was using too much memory (the lower the number the slower the build will be, but the build will use far less RAM):
$ pybombs config makewidth 1

I have increase the ram and compiler error problem is solved.
and Installetion is completed, but when I started gnuradio-companion there is an error
Module Not Foundgnuradioerror

And you did setup your environment after a reboot or opening a new shell ?

Something along the lines of, it depends on where you installed everything:
$ source ~/prefix/
$ gnuradio-companion

How did you increase the RAM ,are you using a virtual machine ? Because I’ve seen dire problems using VM’s in the past with virtual USB drivers adding latency and limiting throughput, but maybe those problems have been resolved since.

Yes I use virtual machine VMware Player 15. I havent tested usb connection delay untill now. But I have noted usb problem that you highlighted .

I installed latex and dvips (in compilation stage there was error about them )

after that I installed gnuradio again by using instruction at the page

and then I installed gr-limesdr gr-3.8 branch in your previous post

It is working now. :slight_smile:
thank you for your support

1 Like

I forgot all about this, and I should have updated this thread earlier, but I’m doing it now in case someone finds it at a future date and and thinks that this is still a problem, it is not. Or that it is in any way related to gnuradio 3.9.x.y, it is not. This thread is about the change from gnuradio 3.7 to gnuradio 3.8.

The pull was merged into the master branch at the end of March, so the gnuradio gr-recipes for gr-limesdr.lwr is now pointing at the gr-3.8 branch of the gr-limesdr repository which is where it should be pointing. So installing gnuradio from source code using bybombs should work since at least April.