Faulty LimeSDR but passes quick test

Hey Group.

Is It possible that i have a faulty LimeSDR-USB module despite it passes the quick test.

I have a feeling that it is a small detail that makes my LimeSDR total deaf.
But weeks, days and hours have passed testing reading and fiddling and still no signal in my LimeSDR.

Things that i have tried or looked at:
Faulty U.fl - SMA cords and plugs RP vs non RP SMA.
Multiple input plugs RX1 and RX2 all 6 have been tested.
Gain controllers and knobs in end user software, just raises the flat spectrum.
Different computers with different USB controllers USB3 and USB2.
Only one driver tested, (there is only one v1.2.3.14 dated 2015-08-15)
Different versions of firmware and gateware files tested v20.01 v19.04 v19.01 img rbf.

Curious behavior and observations:
when i connect Lime Suite from windows i get:
[09:00:02] INFO: Reference clock 30.72 MHz
[09:00:03] INFO: Connected Control port: LimeSDR-USB FW:4 HW:4 Protocol:1 GW:2.21 Ref Clk: 30.72 MHz

and when i connect Lime Suite from Linux i get:
[11:05:47] INFO: Disconnected control port
[11:05:58] WARNING: Gateware version mismatch!
Expected gateware version 2, revision 22
But found version 2, revision 21
Follow the FW and FPGA upgrade instructions:
Or run update on the command line: LimeUtil --update

[11:05:58] INFO: Reference clock 30.72 MHz
[11:05:58] INFO: Connected Control port: LimeSDR-USB FW:4 HW:4 Protocol:1 GW:2.21 Ref Clk: 30.72 MHz

and when i switch a nob or set a setting in Lime Suite and do GUI->chip and remove the same setting again and then do a Chip->GUI i don´t get my setting back?

In SDR Console and SDR Sharp, the receiver tends to hang and lock up the software after a short while.

any one… help :slight_smile:
if some one have the will for it, then i´ll open a VNC to my LimeSDR box.

This just means that you have different versions of Lime Suite installed on Windows and Linux. Looks like the Windows version is older, since it doesn’t complain, whereas the Linux install wants you to upgrade from revision 21 to 22.

@Zack, do you have anything further to suggest for testing?

Hi, did you tried the loopback test ?
I suggest also that you try your limesdr with HDSDR.
I never had good results with SDR#.

My results from all test including the loopback test is my previous posts. :slight_smile:
HDSDR is just as flat spectrum as all the others SDR software packages.
LimeSDR is my first SDR, but i got 20 years experience with GNU/Linux and I´m a Danish “A” class radio licensed HAM (eq. US, amateur extra) but no hands on experience with SDR.
If just one software package under Win or Linux gave me a received signal, then I know it´s my fault, but here i´m in a dead zone, it must be the Lime that is faulty.

Hi, i do not see in this thread where you talk about the loopback test.

I´m sorry, my fault, got a little desperate because nobody was able to push me in any direction, so i got 2 threads in here…

Here I was proposed to do the old manual test, including the loopback test.
in that other thread I document it step by step along the test, with log dumps and screen shots.

sorry for the inconvenience, and thanks for you time.

So, the loopback test worked or not ?

I´m not sure, If i interpret the loopback test right then I do receive my own signal, but the receive test at the same test page, shows a dead quiet FM broadcast band, and my test receive frq, is the most powerful signal around Danish P3 @ 99.6Mhz is transmitting 100kW WFM 30kM from my lime, so it is a coat hanger job, but the hole band is silent in the displayed spectrum (should be a lot of spikes), regarding my loopback test, the absolute only signals i have been able to receive is from my own local transmitters from 1m away, I have tested with 2 hand stations, a 144Mhz and a 27Mhz 3-5watts, these 2 signals I do receive, and then lime it self, but no other than that, my own ISM WiFi 2.4Ghz spectrum is silent too, despite i got two 802.11g and one 802.11n i that frq. area, these WiFi accesspoints is 6m away and @ 0.1watt.
So as I see it, the lime behaves like there is no antenna connected at all, perhaps a faulty PCB or some connection some were?
Some helping sole suggest RP SMA and SMA, and it sure looks like it, but no, and I have tried several U.fl pigtails too, at all 6RX connectors. so I´m getting a bit desperate here. :smiley: should be doing all sorts of weird and wonderful experiments here, but no Sour Lime RF for me yet…

If loopback works with a nice FFT , chances are good that board is ok.
Did you try hdsdr with all lna inputs?
These inputs are configurable in HDSDR.
You can choose them in the menu.
Did you set the gains accordingly ?
LNA gain PGA gain BB gain ?

Hi Again and thanks.

HDSDR start error?
nevertheless HDSDR looks to play just as nice as the other SDR software suits.
Have tested the lime on 3 different computers 2xUSB3 1xUSB2
so it is not a RAM error or some USB issue.

to flat spectrum for FM Broadcast, right?

Hi, your screen captures show you used a 50dB per division fft scale. No wonder why you see nothing.


Huge and big thanks, but but but…
still I don´t hear anything either?
I´m not sure what you want me to do, turn/dial but in this screen shot i have adjusted the scaling nobs, and still RX1_L and full gain allover
but still flat spectrum, just a ghost of some sort

just for fun (who knows what your eye sees)

And my antenna in this exact test is a 2.4 wifi laptop internal antenna with a 30cm test cable, just to test a other U.fl plug, have been using a small SMA WiFi whip in earlier tests.

Again just for fun

Hi, you tuned hdsdr to receive at 100Mhz but you used an antenna tuned to 2.4Ghz.
Maybe try a vhf antenna would be a better test.
Another thing, do you have a screen capture of the loopback test please ?


No, my small 2.4Ghz antenna have a test cord on it, around a 1/4 100Mhz wave length, so it is not a 13cm wifi antenna anymore, but just for the fun of it, I just hang it up with 3 radials 45degres down and one up, all four at approx. 75cm, so now it is a nice 100Mhz GP antenna, and again 30Km away is the 100kW 99.6Mhz transmitter.

the loopback test screenshot

/thanks again :slight_smile:

Ah ok. I see your loopback test is good.
No reason then to not receive a signal.
Just for fun, did your try to transmitt ?


Yes but only the transmit test from here
and i did receive very nice, with a 2m transceiver.
this is a mystery.
and also receive at 144.2 with the lime…
but some thing is wrong, it seams deaf, but perhaps only in some bands
broadcast 88-108Mhz and the 2.4Ghz ISM band too…

Just for fun… :smiley:
I´ll do the loopback test on 10 spots on the entire capable spectrum to see if there is some areas my lime is deaf and some parts not.
I´ll get back when the results are in.

@andrewback and other helpful guys :slight_smile:
Do this look like a successful loopback test?
to me it looks like problem under 100Mhz
I´m not sure?












Ok, now i got my head around this LimeSuiteGUI
so the test guide also guided me to a receive test, that could be adjusted accordingly.
So i do receive 2.472Ghz in FFT Viewer from my old 802.11g AP
that tells me that I got a problem with communication between
SDRSharp, SDRConsole, HDSDR, and all the other SDR Software packages that I have tried. because none of them did receive any local 2.4Ghz. I have to test some more here, but instead of 99.6Mhz as my primary test RX frq, I´ll try with 2.4 Wifi channels, because of my success in LimeSuiteGUI.
But still It can´t be right that the sensitivity under 100Mhz is that bad, so I can´t receive a 100kW station 30Km away.

Hope some of you helpful people can see if my loopback tests is normal or not.
as you all probably have figured out by now i´m desperate here. :slight_smile: