Is this LimeSDR broken?

I’m new to this.
Few days ago I had the westbridge issue with the USB driver, so I fixed it and then did self_test and everything was fine. Suddenly I noticed the noise floor is very low (-100dBFS) and I barely can hear radio stations.
I tried to switch antennas and channels and did tests on both SDR# and GQRX (on ubuntu) - no difference.
Everything seems fine when I perform the Quick test.

Library info: 19.04.0-g8ee7053c
Firmaware:4
Gateware: 2.21

Another issue, When connect to LimeSuite I get the following messages:

Win10:

WARNING: Gateware version mismatch!
Expected gateware version 2, revision 21
But found version 0, revision 0
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

ubuntu 20.04:

[03:28:42] WARNING: Gateware version mismatch!
Expected gateware version 2, revision 22
But found version 2, revision 21
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

Is there a fix for this?
is there a way to do “hard reset” and return to factory settings?
How to program the correct version of the gateware?

Update.
I solved the issue with the gateware. it appears that there is differences in the GW versions between the environments (Win/Ubuntu) even though Lime suite is the same version. 2.21 vs. 2.22 respectively.

But i still have very low signal reception and and it’s annoying, I don’t know what to do :frowning:
current GW version is now: 2.22

This is the result from the quick test:

[ TESTING STARTED ]
->Start time: Thu Jan 7 22:24:42 2021

->Device: LimeSDR-USB, media=USB 3.0, module=FX3, addr=1d50:6108, serial=XXXXXXXXXXXXX
Serial Number: XXXXXXXXXXX

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 22907; 26663; 30419 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112948 (min); 5113083 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 07 1A 12 07 1A 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
->Run Tests (TX_2-> LNA_L):
CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-13.7 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-15.2 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-18.4 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-20.7 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_2-> LNA_H):
CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-15.1 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-13.3 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 1.73 seconds

Please find attached .jpeg

The loopback results look good and so it suggests a software/configuration issue. If you have a Windows system, perhaps give SDR Console a go:

https://www.sdr-radio.com/console

Hi,
Same symptoms in sdr-radio console:

You’ve tried the different antenna posts (LNAs) ?

Experiment with gain?

What antenna do you have connected?

yeah, I’ve tried LNAL/LNAW/LNAH.
Also tried experiment with gain, it doesn’t seem to help much.
I’ve tested dipole antenna and a variety of omni-directional antennas too.

Did the self_test again, the channels doesn’t seem to match:


Another disturbing example. this is how it looks like when I tune to LTE basestations (the pink thing in the left corner caused by the B channel):

@Zack, any suggestions?

Hi @THW,

The latest gateware version is 2.23. Update it to the latest and try.

Hi Zack,

Already tried that, no change.