Faulty Lime SDR - Please Help! RMA


#1

Upon extensive testing the LIme SDR does not have reception. It was tested both in Linux and Windows, using 2 different sets of Drivers - there is no signal on the antenna.
Any help is greatly appreciated.


#2

Sure, can you post the output of running LimeQuickTest.


#3

[ TESTING STARTED ]
->Start time: Tue Mar 12 15:44:31 2019

->Device: LimeSDR-USB, media=USB 3.0, module=FX3, serial=000907060246131C, index=0
Serial Number: 000907060246131C

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 41572; 45328; 49084 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112917 (min); 5113044 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 11 09 0D 11 09 0D 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
->Run Tests (TX_2-> LNA_L):
CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-13.6 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-15.3 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-14.4 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-17.0 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_2-> LNA_H):
CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-16.3 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-15.6 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 3.92 seconds


#4

I see no issue with your board.


#5

Sorry I was not able to append additional information before.

While attempting to scan the broadcast FM band, I am not getting any discernible signal in GQRX or SDR-Console. I have appended a screen shot of my GQRX settings and waterfall. Swapping to RTLSDR gives me a clear FM station, but I can’t pick it up with the LimeSDR.

LimeSDR (GQRX)Broadcast FM waterfall:

LimeSDR (SDR–Console) Broadcast FM waterfall:

RTL-SDR (SDR–Console) Broadcast FM waterfall:


#6

Following… interested in how this issue is addressed.


#7

To add more information:
LimeSDR-USB FW:4 HW:4 Protocol:1 GW:2.20
Currently on [LimeSuiteGUI_19.01.0]
USB Driver reporting version [1.2.3.14]

Double Tested on fresh builds of Windows Server 2016/Win10, and Ubuntu 18.04. Updated to latest LimeSuite on both and flashed latest firmware updates. Latest (cypress?) USB drivers from github. Also tested WinUSB driver in a previous build with zadig. I have tested in GQRX, SDR-Console(3.02 build1234 64bit), HDSDR with ExtIO plugin, and CubicSDR. I have selected antenna LNAL by default but tested LNAW and even LNAH.

I also confirmed the antenna connections and re-seated them because I can almost see a ghost of a signal but its like there’s no antenna connected. I tried many gain variations but I cant see a definite signal even with gains turned high. I am on on a USB3 port but i tried reducing bandwidths from 60Mhz to 40 to 20(USB2), then 10Mhz and 2.5.

Attaching image of zoomed in FM transmission channel that has no signal with LimeSDR but a strong signal on RTLSDR.


#8

Hi cal70,
I am also new to LimeSDR USB and had the very same problem as you. Please read here what worked for me about zadig drivers.


#9

Thank you @Boult, I have the device up and viewable from the terminal (btw I am using a Mac). I have gnu radio installed (finally0 and now playing with the FM block set up (attached) BUT I still have no audio, funny I have a cheap SDR and it works without any troubles.

I guess what they say, The more complex the more issues is TRUE. There is a learning curve, I am trying to get it set up. Want to see 2.4 GHz to play with some of that freq. range. Not there yet. Can’t even get basic FM :wink: LOL.

Thank you for the good write up too… nice resource.