Sdrangel wont detect limesdr mini

Pretty much tried everything by now zadig the other dll run as admin etc.
So whats the magic sauce here as others are saying it works?

As far as I know you shouldn’t need to install any O/S drivers for the Mini, as it’s FTDI USB interface should be supported by the drivers that come with Windows. Guessing @martywittrock may be able to advise.

@andrewback - Andrew,

It’s confirmed by me that Zadig drivers for Windows for the Lime-Mini are not compatible for Windows installs (Win7 to Win10). For some reason I thought I’d ran the '-Mini on Windows, but as it turns out I ran it on my UDOO Advanced system running Ubuntu 17.10 (Artful) and it worked fine. Tests using my Lattepanda Win10-64bit and my Dell 9010 Win10-64bit with Zadig were not ‘seen’ by SDRAngel, yet the traditional LimeSDR was.

Can the Lime team or @joshblum look into this? It’s also being reported on RTL-SDR this morning, too - Carl Laufer (the editor of RTL-SDR.com) cannot get his Lime-Mini to operate on Windows with the Zadig drivers installed and reported it that way - - appears only Cypress drivers work with this (and I’m making the assumption that this also extends to Linux builds because they, too, use the MyriadRF.org driver load and those are Cypress since Zadig uses WinUSB drivers). SDRConsole can see the Lime-Mini, but it’s because Simon uses the Cypress driver and not Zadig. That causes the issue with SDRConsole and SDRAngel compatibility issues because they use competing drivers (SDRConsole = Cypresss/MyriadRF-signed, SDRAngel = Zadig).

Anyway, Andrew, keep us advised…This will be an issue for the Lime-Mini on Windows until resolved.

73 de Marty, KN0CK

1 Like

The Mini uses an FTDI device and not Cypress, hence why if Windows through search does not provide a suitable driver, you need to get one from FTDI.

https://wiki.myriadrf.org/LimeSDR-Mini_driver_installation

1 Like

i do have the ftdi driver installed works fine with sdr-console but sdrangel wont have any of it .

@andrewback - Andrew,

Thanks for the new into - I’ll look into this and try the FTDI driver and see what the situation is with SDRAngel and other apps that use Zadig to see if there’s a compatibility issue. It would seem strange to me that a change to the USB driver would be changing things in the protocol that the apps would be rendered incompatible - - but I guess that may be a possibility. I will look into this further and let you know my findings - Stay tuned…

73 de Marty, KN0CK

@andrewback - Andrew,

As promised, I did some testing with the Lime-Mini last night on my Windows 10 PC (Dell 9010 i5, 8GB RAM) and found some interesting results that I want to share here…keep reading…

Here’s what happened when I ran the Lime-Mini with the FTDI driver on SDRConsole V3.0 (latest revision) - notice the weird issue with sampling, makes all the voices seem like a record player on slow speed (I know I’m showing my age here… :slight_smile: ):

Then I did a wideband FM receive with GQRX and it seemed real good, but I found that I could not use the LimeSDR driver, I had to apply a trick I learned from GNU Radio Companion and use the Ettus USRP driver that was also pointing to the Lime-Mini to play it in GQRX - here is the result:

Then I tried narrowband FM with GQRX with the same settings and had the following results:

So from my analysis of it, It’s possible to get the Lime-Mini running in Windows with GQRX using the USRP driver or driver arguments, but there is definitely something strange about the sampling for SDRConsole. I could not get SDRAngel to work and I know that’s because it doesn’t support the FTDI driver yet that I’m aware of - I will check with Edouard on that and report back…But this is what I have found thus far…Stay tuned for more as I have it…

73 de Marty, KN0CK

P.S. - The Lime-Mini RULES in Linux - No issues with it at all transmit and receive running it on Artful (Ubuntu 17.10).

i have zero issues in sdr-console thou :slight_smile:

1 Like

@oh2eko - Jan,

It’s strange…When I loaded the FTDI driver onto my PC for the Lime-Mini, SDRConsole could finally recognize it, but the sampling was really strange - this could be app dependent and I just need to look for the audio sampling control and see if that fixes it, but this is what I got right out of the chute as-configured like I would have done with any other LimeSDR I’ve applied (that hasn’t had any audio issues like this). I’ll look for that this evening and report back any findings.

73 de Marty, KN0CK

Win 10 64bit.
SDRangel doesn’t work, no device found?
Console ok up to 20mhz bw some slow motion things, 25mhz totally mess (usb3 speed isn’t real?)
First smokes …

I’m afraid there is an issue with Zadig driver and Lime-mini. I can’t get it recognized either while the Lime-USB is.

DO NOT use zadig with the mini!

LimeSDR mini and sdrangel from the current release on win10 x64 shows limesdr plugin loaded, but there is no option to select it with the hand icon in either tx or RX.

I verified that sdrangel does work with limesdr mini by rebooting my laptop into ubuntu and testing there. RX works fine. I was unable to get TX to work, but that’s probably my fault, even though sdrangel says “may have issues or not work at all” for tx at this time.

I’m hoping that the community continues to improve support and documentation for the mini, as time goes on. I think it is just “too new” and like the Icom 7300 when it first was released, took 6+ months for the major software to support it directly instead of via hacks designed for the larger LimeSDR.

If you can’t or don’t want to use Zadig then nothing will work with SDRangel on Windows. The build is made with a mingw toolchain and the USB communications are supported with the mingw build of libusb and therefore a driver installed via Zadig must be used. That’s it. I do not intend to use MSVC. clang-cl might work but it is not my priority to set up a clang-cl toolchain which wouldn’t be a Qt standard anyway.

Tx should be working on Linux if you compile from source with the latest version of LimeSuite. The build for the next version will come with an upgraded LimeSuite.

So you have to constantly uninstall and reinstall drivers (ftdi/zadig winusb) and unplug and plug in the mini if you want to use sdrangel and anything else?

Updated 18:53 April 17th: Also i just tested with SDRangel 3.14.2 and zadig 2.3, sdrangel still says the limesdr plugin is loaded, but it is not available to select. I tried running as administrator as well. So i am not sure how you are getting it to work.

Today i tried to get sdrangel to run in a VM. I got it all compiled with all the accoutrements like digital voice and MBE, airspy (i have one so may as well), 24 bit sampling, limesdr, etc. everything from source on 16.04. Turns out virtualbox doesn’t support XHCI properly (yet, it’s only been years give oracle a minute!) so i downgraded it to 2.0. SDRangel segfaults. so that’s a no-go, yet.

So i’m going to pull out the trusty ubuntu laptop and try the same thing again, and if Oracle ever fixes the USB3.0 Superspeed issue i will report back with a complete how-to guide on the wiki, for us windows users.

It appears that for some reason the Zadig driver does not work with the Mini but does with the LimeSDR-USB. The USB chips are different: Cypress FX3 for the USB and FTDI FT601 for the Mini. So there is something different with the FT601. So yes your best option is to switch to Linux for which the software is originally designed and maintained anyway.

does anyone know if there is work being done to fix the zadig issue with limsdr mini?

thanks,

@richcatena - Richard,

Not that I’m aware of - I have not seen anything regarding the driver difference between the Mini and the original LimeSDR and a spin of Zadig to support it. Using SDRAngel with the Mini requires Linux (Ubuntu, Arch, etc) to function because it doesn’t require Zadig.

73 de Marty, KN0CK

I also have a LimeSDR-USB (1.4 r2.21), that is listed in the Device Manager as using driver: CYUSB3.sys/WdfCoInstaller01011.dll

Using Win8, when I open SDRAngel-4.11.8 as admin, it doesn’t list it under the devices.

Do I need to change to the WinUsb.sys driver (via Zadig), if so, will it break the Lime Suite Util GUI connection?

@blipton - Ben,

If my memory serves, the latest version of SDRAngel does not require the ZADIG driver anymore and so long as you have the driver that’s used for LimeSuite installed and it’s working then SDRAngel will also work. So please use the driver set shown here:

https://wiki.myriadrf.org/LimeSDR-USB_driver_installation

…then it should work fine for Windows 8.1 and also work for the latest versions of SDRAngel, too. Please advise if that isn’t the case for your LimeSDR.

Also, please make sure you update your firmware for the LimeSDR in LimeSuite before using the latest versions of SDRAngel, too.

Hope this helps - 73 de Marty, KN0CK