Problems with LimeSDR mini


I am currently playing with my newly received LimeSDR mini and I’ve being having some issues. It was suggested to me that I setup the LimeSDR Suite GUi and test it out and so I did. I used the PPA for Ubuntu and install the LimeSDR Suite GUi and some utils.

Please see screenshot here:

I can never get this to work. No FFT no samples, nothing. There are also some timeout errors below. It was suggested to me also that the LimeSDR mini might be defective. Please see my ticket here:

Can you please instruct on how to verify that the LimeSDR mini is or not defective ?

Thank you

Question: Would this guide here: work for the Mini as well ?


Please see the following video and picture links for the Lime-Mini playing perfect on SDRAngel hosted on a UDOO Advanced card using Ubuntu 17.10 (Artful) and with all the LimeSuite, gr-osmosdr, and SoapySDR dependencies installed and operational.



Please check your installation of the following: LimeSuite, gr-osmosdr, and SoapySDR. Be sure to have a clear SoapySDRUtil --find that shows the Lime-Mini in the list. The Installation for the LimeSDR and Lime-Mini are here:

Let us know your progress and touch back if there are any further issues.

73 de Marty, KN0CK


When using LimeSuite you have to do a Connect to your Lime-Mini before you can use the app for anything. You also have to run the app as root (sudo LimeSuiteGUI) to be able to connect and check out your Lime-Mini on LimeSuite.

Please let us know your progress and keep in touch -

73 de Marty, KN0CK

Thank you for your comments. I believe I have followed the instructions correctly. Currently the tagged release of sdrangel with tag v3.12.0 on github and the ppa version of limesuite have an issue with sdrangel described here: and As far as I understand there were other people having the same issue with sdrangel. The issue apparently is with the limesuite library. You already know that sorry for being pedantic.

I tried as you instructed using the LimeSuiteGUI as root and did connect my LimeSDR Mini (it was properly detected) and then I went to the Modules -> FFTViewer and then in that dialog i entered a frequency and and then clicked start and nothing happens. I fully accept the possibility that I am using the LimeSuiteGUI app incorrectly thats why I asked if the Quick_Test link above would also work for the Mini.

The same issue reproduces on Windows 10 after what seems to be a proper installation following this guide:

So my question is how can I definitively perform a test to verify that the LimeSDR Mini is actually in worker order? Are there any guides or instructions somewhere? Will this link with instructions work on the Mini:

Thank you

You don’t need to run as root, in fact it is a bad idea. What you need to do is add udev rules to be able to access the USB device.

No, the Quick Test procedure used with LimeSDR USB does not work with LimeSDR Mini.

1 Like


When running LimeSuite you cannot reach the connection controls to even connect the LimeSDR to LimeSuite to make adjustments unless you run in root - that’s the way it plays on all my Ubuntu installs.

73 de Marty, KN0CK

Something is wrong then. I built LimeSuite from source and have no issues running as a normal user. That also goes for all my other SDR software.

If you built from source you need to remember to run udev-rules/

Following which you shouldn’t have to run as root.


@andrewback - Andrew,

All good - I’ve not run that install script before but I’ll add that to my installations and try it again. Frankly I’ve never seen any issues running LimeSuite as root, but I’m sure there are corner-cases where that wouldn’t be healthy. Again, I’ll add that script to my procedures and installs of LimeSuite and try it in my user account - thanks for passing that along.

73 de Marty, KN0CK

Hello again,

After some testing with SDR-Console v3 I am under the impression that my LimeSDR mini is defective. Perhaps I am doing something wrong thats why I have uploaded some screenshots of SDR-Console working here: perhaps someone will share an opinion on the issue. All screenshots were taken without a single antenna connected to the LimeSDR mini except one, the first one. I have tested with an USB 3.0 extension cable and also directly plugged in the motherboard.

Does anyone know how to contact support about this issue ?

Does it look better if you reduce TIA gain from max?

No it does not ( This behavior has been observed since day 1. Along with that there is always some sense of something being wrong. For example the irregularity of how much time it takes for the data stream to start. Always varies between 3 to 15 seconds. Also when I plug it in, the red LED is always on and the green LED is blinking. Not sure if that is any indication.

Is there some way to make a definitive determination of whether this is broken or not? And if it is do you know who to contact in order to return it ?

@Zack, do you have anything else to suggest?

Yes, Crowd Supply.

A couple of lessons I have learnt so far:

My windows 10 laptop installed the FTDI driver automatically and this was the right one to go for (pre Creators update).
After the creators update that evening (it wouldn’t let me postpone any longer :frowning: ), the drivers broke and it would no longer find it automatically. Therefore I went to the FTDI site, downloaded the right driver and it worked again.

Secondly, when I use GQRX SDR, Pothos or GNURadio, I have to set the arguments as “driver=lime,soapy=2” for it to work. There is an auto-populated entry in the GQRX SDR combo box, which adds a lot more arguments, but these extra ones seem to break it.


I am having an issue very similar to @sgoudelis. I just received my LimeSDR mini and wanted to get a minimal functioning system or at least check that the hardware was functioning. SoapySDRUtil finds it correctly and identifies it as the LimeSDR mini (though it often states the connection as USB 2.0 and I have to reconnect). Gqrx, SoapySDR and LimeSuite are all compiled from source using the latest versions. The terminal output from starting gqrx seems to indicate a hardware level issue or at least a LimeSuite issue.

---------@---------:~$ gqrx
gr-osmosdr v0.1.4-98-gc653754d (0.1.5git) gnuradio 3.7.11
built-in source types: file fcd rtl_tcp hackrf rfspace soapy redpitaya
Resampling audio 96000 → 48000
BookmarksFile is /home/---------/.config/gqrx/bookmarks.csv
gr-osmosdr v0.1.4-98-gc653754d (0.1.5git) gnuradio 3.7.11
built-in source types: file fcd rtl_tcp hackrf rfspace soapy redpitaya
[INFO] Make connection: ‘LimeSDR Mini [USB 3.0] 1D398DB2355BCC’
[INFO] Reference clock 40.00 MHz
[INFO] Device name: LimeSDR-Mini
[INFO] Reference: 4e+07 MHz
[ERROR] SetPllFrequency: timeout, busy bit is still 1
[INFO] LMS7002M calibration values caching Disable
[ERROR] SetPllFrequency: timeout, busy bit is still 1
[WARNING] LNAL has no connection to RF ports
[INFO] RX LPF configured
[ERROR] MCU error code(6): Invalid Rx path

I have also rebuilt LimeSuite after doing “git checkout ebd027169defc9689d1eefa0f57d4df617b7cc4d” which was what the maintainer of SDRAngel suggested in the github issue to revert a recent change in the LimeSuite source code but that caused further issues shown below

[ERROR] SetFrequencyCGEN(640 MHz) failed:
VCO: 2560 MHz RefClk: 40 MHz
TuneVCO(CGEN) - VCO too low
[ERROR] SetFrequencyCGEN(640 MHz) failed:
VCO: 2560 MHz RefClk: 40 MHz
TuneVCO(CGEN) - VCO too low

For gqrx I am using the config file that @andrewback suggested in another thread (LimeSDR Mini Drivers and Tests - #4 by andrewback)
Looking for any definitive way to confirm that this is a hardware issue with the LimeSDR mini or if it is a software issue with the current version of LimeSuite

@Zack, any thoughts?

I have received no reply from Crowd Supply and no definitive answer from this forum. I will be sending the Mini back to Crowd Supply as per their instructions here:

I will attempt to get a replacement and if not possible a refund.

Hi @sgoudelis,

We are implementing stand alone software for board checking. Should be ready at the beginning of next week. It will perform some tests to identify hardware problems if there are any.

Meanwhile if you have a Win machine, we may try this;

  1. Download the latest compiled LimeSuiteGUI for Win:
  2. Connect to the board;
  3. Got to SXT tab and push Calculate button. The same for SXR and CGEN tabs;
  4. Let me know the results.
1 Like