New limeSDR mini is acting strange

Hi there,

I’m new to SDR and to the LimeSDR Mini as-well, I have an IT background so I thought it wouldn’t be to difficult to get going with it. But I’m struggling. I’m searching now for 2 days to find a solution to my problem but I cant find anything reassembling the issue.

The setup and problem
I have the LimesSDR mini (which I updated to the newest firmware) who I use with in windows 10
with the SDR-RADIO.com application. The stick is visible in the software and I can use it as-well. But I only get static and no signals at all, except for one signal in the middle of the screen (no matter what frequency I tune in the one signal stays visible in the middle of the screen)

I use 2 tplink antennas from my router, so I think I should at least be able to tune in to an FM radio station. I hope that someone can point me in the right direction. Perhaps someone here had the same issue and solved it. Thank you.

The spike in the center is DC offset and it should be possible to reduce this via settings.

Have you got the correct antenna/LNA port selected in the software? See:

https://wiki.myriadrf.org/LimeSDR-Mini_v1.2_hardware_description#RF_Frequency_Range

Hi Thank, you for your answer.

I got the correct LNA port selected and configured the software as set by the website (www.sdr-radio.com/limesdr). The only difference is that my setup states LNAL_NC and the websites settings stat LNAL. The software notes that its not connected. But I have the 2 antennas screwed on tightly and just checked again to make sure. Hope its not broke, and that its just a setting somewhere. Thanks again.

The LMS7002M chip used in the LimeSDR Mini has 3x LNA inputs, but only 2x are connected, the High (LNAH) and Wideband (LNAW) inputs. Hence why LNAL is marked “NC” for not connected. So if you select this it doesn’t matter what antenna you attach to the RX port, it will not be connected to the chip input. Hence you will not receive anything. Please select LNAH or LNAW.

https://wiki.myriadrf.org/LimeSDR-Mini_v1.2_hardware_description#RF_Frequency_Range

I did try to the other 2, but with LNAH or LNAW I don’t receive anything, not the faintest signal. Is there something else I can check? Do I need to use bigger/other antennas?

If you could run LimeQuickTest and post the results of the output.

[ TESTING STARTED ]
->Start time: Fri Jan 10 09:56:10 2020

->Device: LimeSDR Mini, media=USB 3, module=FT601, serial=1D588FF005F0D8, index=0
Serial Number: 1D588FF005F0D8

[ Clock Network Test ]
->REF clock test
Test results: 57483; 5143; 18340 - PASSED
->VCTCXO test
Results : 6710990 (min); 6711158 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 0A 16 13 0A 16 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-12.7 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-12.7 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 3.53 seconds

Try to increase gain (in your picture it is -30dB!) and add cooling fan because Mini board is to hot (over 50 degree C).

I changed the gain to 0 (and even had it on +30 for a minute), but nothing changed
I also added a DIY heat-sink as you can see form the picture.

Why dont you try SDR# program? You need SDR# installation file and LimeSDR plugin from:
https://github.com/GoranRadivojevic/sdrsharp-limesdr/releases/download/0.2/SDRSharpLimeSDR_v02.zip
On github page you can find short instruction how to add LimeSDR “magic line” into settings file.

I tied SDR# and I could not get it working with the LimeSDR. I down loaded the windows install package for SdrGlut (SdrGlut-450.msi) -

https://github.com/righthalfplane/SdrGlut/releases/download/v1.6/SdrGlut-450.msi

It installed and ran my LimeSDR mini out of the box.