LimeSDR Mini having trouble receiving/transmitting

Hello All,

I have got a LimeSDR Mini and having trouble with receiving and transmitting signals. I have been focusing on the receiver for now.

This is what I have done:

  1. Ran the LimeQuickTest utility and everything passed including loopback test.
  2. Set the frequency in SXR to my local radio station that I want to listen to, pressed calculate, tune and then in the calibration screen, calibrated the RX. Message said calibration successful, then pressed GUI->Chip.
  3. Installed all the libraries/dependencies that I could find like Boost, SWIG, Built the gr-limesdr.

In GNU-Radio if I use a QT GUI sink and set a center frequency of say 100MHz then it will always show a spike at 100MHz, it does not matter what frequency or whatever is around it will always spike at the defined center frequency regardless of if that signal is present or not.

I used a device that transmits at 433MHz and watched the spectrum at 433MHz on the LimeSuiteGUI/FFTviewer and GNU-Radio/QT GUI sink. There was no change in the spectrum, just a constant spike at 433MHz.

I tried to use the FM Receiver example from gr-limesdr and all I hear is static. I set the sample size to 44.1KHz on the audio sink and adjusted the Rational Resampler and WBFM receiver accordingly based on another answer I saw on these forums but this did not help. I have tried LimeSDR Source sample rates of 2M, 5M and 10M but it makes no difference. I have also tried osmocom sinks and sources with no luck.

SoapySDRUtil --Find and LimeUtil --Find return identical results and tell me that my device is a LimeSDR Mini and the serial number.

I am a newbie to SDR in general so I am likely missing something, any pointers would be helpful? Thank you.

Note that any setting you make via LimeSuiteGUI will be lost once you close this and then re-open the SDR in another application, e.g. GNU Radio, since the transceiver will be reset.

The spike is DC at the SDR center frequency. Before looking at how to remove this and GR issues etc., probably best to start with a turnkey application and would suggest installing SDRangel.

And be sure to make sure you have the correct LNA selected when configuring the LimeSDR Mini within this (people sometimes get no signal when using it, because they have an NC port selected).

On GNURadio source I selected LNA-N and LNA-W previously on channel A and B with no luck.
I now have the SDRAngel running but I can’t find the LNA setting, is there a tutorial you could guide me to? I see nothing being recieved on SDRAngel either. Thank you.

Under Sampling Devices you should have at least receiver R0 and this as a LimeSDR type device. Then in this panel there will be an antenna (tree-like) symbol and next to which a drop-down where valid options are Hi and Lo (the other “NC” ones are for ports on the transceiver IC that are not in use).

Can you also post the full output from LimeQuickTest just to be sure.

I tried the antenna setting, None, NC, Hi, Lo and none of those work they just change the background of the waterfall.


->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial= , HW=3, GW=1.30
Serial Number:
Chip temperature: 25 C

[ Clock Network Test ]
->REF clock test
Test results: 3051; 16247; 29444 - PASSED
->VCTCXO test
Results : 6711102 (min); 6711261 (max) - PASSED
->Clock Network Test PASSED

->Read data: 13 0A 15 13 0A 15 02

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-14.0 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-14.1 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 2.52 seconds

I also tried to follow this thread (LimeSDR USB Signal issue) but the links are dead so I did not get to diagnose anything HW related. Should I go to a really old firmware and try that?


What do you have connected for an antenna? And have you tried changing the Rx gain?

Thanks for your reply. I don’t remember what brand specifically but I have SMA antennas which are optimized for 700-2700MHz. Do you think this is my problem? But even between 700-2700MHz I can’t see anything.
I am not sure about Rx gain. To the far left of the antenna icon you mentioned in your earlier post there is a drop down box which says “Aut/Man”. I selected Aut and changed around the automatic global gain but had no luck. I then switched to Man and changed the manual LNA and PGA gain but still nothing changed. Is this what you are referring to by “Rx gain”?

Corrent. Can you please send a screenshot of your settings? Don’t forget to set the antenna to Lo or Hi too.

I have set it up so music is playing on a bluetooth speaker.

Music is playing at Hi ----

No music is playing at Hi ----

No music and bluetooth is turned off ----

Music is playing at Lo - 1 ----

Music is playing at Lo - 2 ----

No music is playing at Lo ----

No music and no bluetooth at Lo —

So it looks like there it is picking up something. I found best setting to be PGA Gain at 32 and LNA Gain at 8. Higher LNA gain just makes the waterfall green and the spike you see in the middle goes away. Doesn’t really seem to work at any other frequency, I tried different channels of a WiFi which is 2.4Ghz I think. I have tried lower frequencies around 100MHz for radio stations too and nothing shows up.

It looks fine to me. Try changing the Software Decimation Factor “Sw” from 4 to 1 and scan again the FM frequencies. Increase a bit more the gain. Also if you have any garage door opener or a car key fob for which you know their working frequencies (mine for example is at 433Mhz) you can test it out.

I have tried different HW and SW decimation factors including 1 and maximum gain settings for both Aut and Man and I don’t see anything for any other frequencies. I have tried 433MHz before too and various radio station frequencies. It does not pick them up.

Try with a car keyfob

That is what I used for a 433MHz signal. I know for a fact this key fob uses 433MHz because I used to have a Nooelec receiver and it used to show up around 433 on the spectrum. I just saw another post here which relates to receiving FM so I am going to try some of the GNU flow graphs posted on there. I don’t know what else to try or change. I have also tried this LimeSDR Mini in two computers now (windows and linux).

Are you sure you have a good connection to the antenna? If you use a cable with reversed sma connector it will never work. I just ask because one day i had the same here and that was because for experiments i changed a sma-male to sma-male cable abusively with a sma-male to sma-male reversed polarity cable and than of course there is no connection…cost me an hour because you think about all things like software and drivers but forget that the cable is changed hi hi.

The antenna screws onto the LimeSDR Mini SMA connectors so there is no cable. I have tried it with no antenna as well with a key fob operating at 433 MHz right next to it. The car responds but I see nothing on the waterfall or spectrum when using LimeSDR mini. I have tried the examples here: Trouble picking up FM with limesdr sample code and all I hear is static.

Is it possible that my device is faulty? I don’t know what else to try.

@Zack, could you take a look, please.

Hi @mynameis,

Could you try HDSDR software, please:

Is this only for windows? I only used windows as a test machine. Is there anything for Linux?