LimeUtil v17.10.0-PothosSDR-2017.11.26-vc14-x64 pulls wrong firmware

I’ve been having some issues with my LimeSDR, and in checking the status of the latest firmware updates I found that on my device (HW Rev 1.4) that when I run “limeutil --update” that limeutil pulls the HW_1.3_r3.0 .img file and HW_1.4_r2.11 .rbf file. Despite the most recent files being available. I have tried deleting the images and forcing limeutil to follow the download option rather than re-flashing the present firmware, and it downloaded the same files.

So the --update option doesn’t actually perform any updates.

Has anyone else seen this kind of issue? I’ve downloaded the most recent firmware and flashed it manually from limeutil with success.

Lime Suite always pulls the firmware and gateware corresponding to its release. In other words, to get the latest fw/gw you must be running the latest release of Lime Suite.

So you would expect the above version of LimeUtil to pull mismatched hardware revisions? I have solved a lot of interface failure issues by moving forward to the 1.4 revision, which I would expect.

Hello @andrewback,

I posed a question once before that I think triggered some back ground changes with respect to the files loaded for hardware updates from LimeSuite, the question at the time was about missing directories located at .
When I look in there today I see directories for each of the LimeSuite versions, however inside these directories I wonder if some of the files are missing, not knowing the full structure of the files, I could be barking up the wrong tree, however, if I look in the 17.09 directory I see that there are four .rbf files for the HW 1.4 version ie (r2.6, r2.8, r2.9 and r2.10), when I look in the 17.10 directory I can only see r2.11 (and one marked old). I guess my question is related to “Does LimeSuite sense the revision of the 1.4 Hardware and load a specific .rbf file?” or “does r2.11 supersede and therefore replaces r2.6 to r2.10?”
Interested to see what you find out.


This is where the image are uploaded and versions checked:

Thank you for the response Andrew,

I can see how the file structure is configured now.