LimeSDR with Gqrx is working!

That’s right and the fix was applied to master in the Lime Suite repository on Tuesday. It looks like the PothosSDR installer was last uploaded on Monday, so this can’t have it yet, but I’m sure it will soon.

Alex / Andrew,

Thanks for the info - I’ll be waiting for the next Pothos release to have the fixes in. But in the meantime, the new Lime I have is tuning V/UHF and receiving like a champ with GQRX on Windows. Are the sources for Soapy and LimeSuite updated on the Ubuntu Software Center yet for Linux? Let me know so I can tackle that next and update what I have on my Linux box.

73 de Marty, KN0CK

The Lime Suite Ubuntu packages were last updated Sunday. You can check this yourself at:

You can see the release/tags on GitHub at:

Has anyone gotten Gqrx working with the new boards on HF? If yes, are the observed signal levels on HF much lower than they were on the earlier boards? I’ve been following the LimeSDR/SDR-Console thread where much lower signal levels have been seen with the new boards. Just curious whether same experience on Gqrx? Thanks!

Chuck

I don’t see any reason whatsoever why it should be different in gqrx compared to any other console application that uses the same hardware and driver library.

Alex,

I recently upgraded my Linux box from Ubuntu 15.04 to 16.10 and reloaded GQRX along with all the regular PPAs and drivers. For some reason when it launches, I get a ‘segmentation error’ and it just bails out.

Have you seen this error? Please let me know, because I’d love to compare it with SDRConsole and the V1.2 and V1.4 hardware.

73 de Marty, KN0CK

Argh Marty, that’s a huge upgrade step :frowning:
Why not a fresh install?

Please make sure that the PPA points to the correct repository version and that you have no old versions lying around from 15.04 - and in particular no source installations.

There is a well known issue on 16.10 - even an official Ubuntu bug - that I tried working around as also mentioned by Josh. I have tested the PPA on a clean installation of 16.10, though not with limesdr, So it should be working but it may not.

At the end of the day, if you objective is to run gqrx on a stable system, do a fresh install of 16.04 and stick to LTS releases.

1 Like

Alex,

Okay - you convinced me…I’m gonna go do just that…Stay tuned for the update on this. Can you send the list of PPAs or the procedure to load those again? I can collect them from an earlier post, but if they’ve changed any, let me know the new procedure for installing the PPAs. If it’s the same as last time, then just let me know that, too.

73 de Marty, KN0CK

Sure, these instructions should be complete: http://gqrx.dk/download/install-ubuntu

Hello Alexandru,

Is it also possible to install a gqrx version that works with limesdr and hackrf under Ubuntu 16.04 amd64?

Regards Ben

Hi Ben,

There is only one version of gqrx and that supports a wide range of hardware, including the hackrf. Please see the the link above for installation instructions on Ubuntu and variants.

I was able to get my V1.4 LimeSDR working under gqrx on ubuntu 16.10.

I abandoned the ppa’s after wrestling with dependency issues, so I compiled a few things from source.

gqrx @ 96fc99d (8 days ago)
with
gr-osmosdr @ ae686c4 (8 months ago) (libosmosdr) (libgnuradio-osmosdr.so.0.1.5git)
limesuite @ 21b216e (2 days ago)

basically some fiddling required to compile gqrx with the latest gr-osmosdr.

Sorry, can you please elaborate?

believe after reading some github threads that I needed to recompile gr-osmosdr without the Ettus components, so thats what I did.

I am not sure if this is still needed - i haven’t tried the PPA’s in a few weeks

my gr-osmosdr is compiled with the following components

– ######################################################
– # Gnuradio enabled components
– ######################################################
– * Python support
– * sysmocom OsmoSDR
– * FUNcube Dongle
– * IQ File Source & Sink
– * Osmocom RTLSDR
– * RTLSDR TCP Client
– * RFSPACE Receivers
– * SoapySDR support
– * Red Pitaya SDR

– ######################################################
– # Gnuradio disabled components
– ######################################################
– * Osmocom IQ Imbalance Correction
– * FUNcube Dongle Pro+
– * Ettus USRP Devices
– * Osmocom MiriSDR
– * HackRF & rad1o Badge
– * nuand bladeRF
– * AIRSPY Receiver

Ok, I thought you meant changes were needed to gqrx.

Anyway, as written elsewhere on this forum, the PPA is now updated and gr-osmosdr is built without UHD support until we resolve that issue.

1 Like

Alex,

Rebuilt my system with Ubuntu 16.04 (Wily) and installed LimeSuite and SoapySDR first and then applied the procedure on your website for GQRX. Running SoapySDRUtil I’m able to see my Lime - it’s there and working. I’m not able to start a LimeSDR session with GQRX (even with —> driver=lime,soapy=0) and getting the following error(s):

gr-osmosdr v0.1.x-xxx-xunknown (0.1.5git) gnuradio 3.7.10
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy soapy redpitaya
[ERROR] SoapySDR::loadModule(/usr/local/lib/SoapySDR/modules0.5-2/libLMS7Support.so)
duplicate entry for lime (/usr/lib/x86_64-linux-gnu/SoapySDR/modules0.5-2/libLMS7Support.so)
[INFO] Make connection: ‘LimeSDR-USB [USB 2.0] 9060B00461418’
Estimated reference clock 30.7195 MHz
Selected reference clock 30.720 MHz
[INFO] Device name: LimeSDR-USB
[INFO] Reference: 30.72 MHz
[INFO] Init LMS7002M(0)
LMS7002M values cache at /home/marty/.limesuite/LMS7002M_cache_values.db
[INFO] Ver=7, Rev=1, Mask=1
[INFO] LMS7002M calibration values caching Enable
[INFO] SoapyLMS7::setFrequency(Rx, 0, BB, 0 MHz)
[INFO] SoapyLMS7::setFrequency(Tx, 0, BB, 0 MHz)
[INFO] SoapyLMS7::setAntenna(Rx, 0, LNAL)
[INFO] SoapyLMS7::setAntenna(Tx, 0, BAND1)
[INFO] SoapyLMS7::setGain(Rx, 0, PGA, 0 dB)
[INFO] SoapyLMS7::setGain(Rx, 0, LNA, 0 dB)
[INFO] SoapyLMS7::setGain(Rx, 0, TIA, 0 dB)
[INFO] SoapyLMS7::setGain(Tx, 0, PAD, -50 dB)
[INFO] SoapyLMS7::setSampleRate(Rx, 0, 10 MHz), CGEN=80 MHz, ADC=20 MHz, decim=2
ConnectionSTREAM::ConfigureFPGA_PLL(tx=20MHz, rx=10MHz)
[INFO] SoapyLMS7::setSampleRate(Tx, 0, 10 MHz), CGEN=80 MHz, DAC=20 MHz, interp=2
ConnectionSTREAM::ConfigureFPGA_PLL(tx=10MHz, rx=10MHz)
[INFO] SoapyLMS7::setBandwidth(Rx, 0, 30 MHz)
SetFrequency using cache values vco:0, csw:117
SetFrequency using cache values vco:0, csw:141
SetFrequency using cache values vco:2, csw:0
SetFrequency using cache values vco:2, csw:0
[INFO] SoapyLMS7::setBandwidth(Tx, 0, 30 MHz)
[ERROR] setBandwidth(Tx, 0, 30 MHz) Failed -

FATAL:
<…and other stuff>

Have you ever run across this and know the fix? Appears there’s some kind of duplicate entry in SoapySDR…Please advise if you know what the fix for this is.

73 de Marty, KN0CK

Stock PPA should work. Just tested it briefly. This error is showing conflicting files from the PPA and source build. Could be the case for libraries on the system too, but they wont be as telling in terms of the verbose. Can you remove any older stuff you may have installed from source builds?

Rebuilt my system with Ubuntu 16.04 (Wily)

Xenial 16.04 right? The PPA isnt kept up to date for wily, which is think is dropped at this point.

Josh,

You are right…16.04 is Xenial. My crumbling memory is in a blender with all the versions I’ve been rebuilding. If I was to remove the correct file (or does it matter which one) where would do that - or is this an entry in some config file? I’ll go make it happen, but if you can give me some guidance before I work it that would make me more comfortable. Right now, it’s like '…cutting the blue wire…" to me. :slight_smile:

Keep me tuned-in, Josh,

73 de Marty, KN0CK

@joshblum, @martywittrock

I’m using the latest code from git, so not quite PPA builds, and it works as long as I keep the sample rate 5 MHz and above. Below 5 MHz I get crashes like:

[INFO] SoapyLMS7::setAntenna(Rx, 0, NONE)
[INFO] SoapyLMS7::setSampleRate(Rx, 0, 4 MHz), CGEN=512 MHz, ADC=128 MHz, decim=32
ConnectionSTREAM::ConfigureFPGA_PLL(tx=4MHz, rx=4MHz)
[INFO] SoapyLMS7::setBandwidth(Rx, 0, 3 MHz)
SetFrequency using cache values vco:0, csw:117
SetFrequency using cache values vco:0, csw:139
SetFrequency using cache values vco:0, csw:114
SetFrequency using cache values vco:0, csw:114
[ERROR] setBandwidth(Rx, 0, 3 MHz) Failed - CFB_TIA_RFE step size out of range
terminate called after throwing an instance of ‘std::runtime_error’
what(): CFB_TIA_RFE step size out of range
Aborted (core dumped)

I get the same exception if I try to use sample rate > 5 MHz with narrow bandwidth settings.

But sample rate 5+ MHz and auto bandwidth (=0) seems to work.

Alex,

I’ll try that, too, once I get this conflicting Soapy issue:

[ERROR] SoapySDR::loadModule(/usr/local/lib/SoapySDR/modules0.5-2/libLMS7Support.so)
duplicate entry for lime (/usr/lib/x86_64-linux-gnu/SoapySDR/modules0.5-2/libLMS7Support.so)

…repaired on my 16.04 (Xenial) fresh install. Right now awaiting a little more guidance from @joshblum. More on this when I have the first hurdle overcome…

73 de Marty, KN0CK