LimeSDR with Gqrx is working!

Yes - but not a very good reason - it’s what was in pothos github (thought it had to be a special verison for soapysdr)

Thanks! just upgraded and now enjoying local FM radio stations.

Glad to hear the latest version is also working. I haven’t tested LimeSDR integration for a while.

I think the Pothos github fork is used to fix windows build issues and so probably only updated when Josh needs to send me a patch.

using the qqrx that came with pothos install for windows, I just can’t get it to work, set the settings as @martywittrock used and other, I cat seem to get it to start, no waterfall/spectrum at all, it does work under simons sdr-console, so I know its working…

Sorry @nn4f_radio, I have no clue regarding running gqrx on windows. If you can launch it from a terminal there may be some error messages that could give a hint.

I just deleted the config file and restarted and it’s working… :smile:

Nice :slight_smile:

LimeSDR on GQRX (Pothos Install) running at 15Msps on a bad antenna (while at work)…but it’s working… Oh and it’s just on an i3 laptop 6gb ram… 20Msps slows it down, so I think 15Msps is the limit on this laptop.

1 Like

Try to see if the bundle includes a tool called volk_profile and run it if it is there. It runs for a long time (sometimes half an hour) checking if various CPU specific optimizations run faster. It will in many cases boost the performance of GNU Radio applications.


Great to see you in the threads again…! Yeah, Josh is working the Windows issues for HF and I applying fixes to that. I’m not sure if he’s doing the changes for GQRX for Windows or you are, but right now there is no HF tuning below 26 MHz (dead) and it has to do with a sign bit on the NCO (from what Josh has mentioned). I would love it if GQRX was working for Linux and Windows again - ran fine in VHF tuning mode for me the other night with the new LimeSDR with all the new firmware changes. Local weather radio at 162.475 MHz came through fine…Just no HF…

Anyway, great to see you on again…Hope all is well.

73 de Marty, KN0CK

Hi Marty,

That NCO / HF tuning issue sounds like a general backend issue not limited to windows. I don’t think there is anything to do in gqrx in this respect. The only hardware specific code in gqrx is the list of predefined sample rates. So, if the backend is fixed it should just work in gqrx also.

That’s right and the fix was applied to master in the Lime Suite repository on Tuesday. It looks like the PothosSDR installer was last uploaded on Monday, so this can’t have it yet, but I’m sure it will soon.

Alex / Andrew,

Thanks for the info - I’ll be waiting for the next Pothos release to have the fixes in. But in the meantime, the new Lime I have is tuning V/UHF and receiving like a champ with GQRX on Windows. Are the sources for Soapy and LimeSuite updated on the Ubuntu Software Center yet for Linux? Let me know so I can tackle that next and update what I have on my Linux box.

73 de Marty, KN0CK

The Lime Suite Ubuntu packages were last updated Sunday. You can check this yourself at:

You can see the release/tags on GitHub at:

Has anyone gotten Gqrx working with the new boards on HF? If yes, are the observed signal levels on HF much lower than they were on the earlier boards? I’ve been following the LimeSDR/SDR-Console thread where much lower signal levels have been seen with the new boards. Just curious whether same experience on Gqrx? Thanks!


I don’t see any reason whatsoever why it should be different in gqrx compared to any other console application that uses the same hardware and driver library.


I recently upgraded my Linux box from Ubuntu 15.04 to 16.10 and reloaded GQRX along with all the regular PPAs and drivers. For some reason when it launches, I get a ‘segmentation error’ and it just bails out.

Have you seen this error? Please let me know, because I’d love to compare it with SDRConsole and the V1.2 and V1.4 hardware.

73 de Marty, KN0CK

Argh Marty, that’s a huge upgrade step :frowning:
Why not a fresh install?

Please make sure that the PPA points to the correct repository version and that you have no old versions lying around from 15.04 - and in particular no source installations.

There is a well known issue on 16.10 - even an official Ubuntu bug - that I tried working around as also mentioned by Josh. I have tested the PPA on a clean installation of 16.10, though not with limesdr, So it should be working but it may not.

At the end of the day, if you objective is to run gqrx on a stable system, do a fresh install of 16.04 and stick to LTS releases.

1 Like


Okay - you convinced me…I’m gonna go do just that…Stay tuned for the update on this. Can you send the list of PPAs or the procedure to load those again? I can collect them from an earlier post, but if they’ve changed any, let me know the new procedure for installing the PPAs. If it’s the same as last time, then just let me know that, too.

73 de Marty, KN0CK

Sure, these instructions should be complete:

Hello Alexandru,

Is it also possible to install a gqrx version that works with limesdr and hackrf under Ubuntu 16.04 amd64?

Regards Ben