LimeSDR with Gqrx is working!

#1

Greetings,

Today I finally had some time to play with the LimeSDR board and I am happy to report that I got to a point where I have gqrx working using the SoapySDR backend - YAY!

I am running Xubuntu 14.04 where I already have GNU Radio & co installed from our PPA. I then went on and rebuilt SoapySDR, SoapyLMS7 (from lmsuite git), gr-osmodr and gqrx from source and it actually worked :slightly_smiling:

It works quite well considering that we are at this very early stage. I need to get more familiar with the board and also learn how to configure various options through the SoapySDR interface.

Here is a 10 second video clip proving that it’s real: https://www.youtube.com/watch?v=GrvKqdhTHZk

Edit: I forgot to mention that I am using a rather old laptop with USB2 ports only.

2 Likes
#2

Awesome news! I will use this material for the architecture blog :slight_smile:

#3

I am away from home I don’t have access to good antennas here. But I do have a handheld Arrow with me and I will try to catch some satellites tomorrow.

1 Like
#4

My first attempt at receiving a hamradio satellite with the LimeSDR / Gqrx setup was a success. After some initial fumbling around trying to find the optimal seetings, I captured about 2/3 of the FO-29 satellite pass.

Below is an annotated waterfall where one can clearly see the Doppler shift of the downlink signals as the satellite passes by.

This was received with a handheld Arrow II yagi antenna connected directly to RXRF1_L input.

2 Likes
#5

This is GREAT Alex…

#6

Dang, I need to get my antenna array rebuilt. Missing satellite passes drives me nuts!

#7

It gets better :slightly_smiling:

I have also received parts of a NOAA-19 pass earlier today at 13:00 UTC. Raw and false color images below.

Workflow:

  1. Record WAV file with gqrx using it’s built-in APT FM mode.
  2. Convert the WAV file to 11025 Hz mono using sox.
  3. Process WAV file with wxtoimg.

I am used to receiving significantly better APT images, but there was lot of QRM on VHF at this location and also this is a new device for me, so all in all I am very pleased with this first result.

1 Like
#8

Hi Alex,

Can you let me know how to configure the SDR source for pothos? I was able to get some connection with the radio but will like to verify options.

#9

I haven’t used pothos so I don’t know. Maybe @joshblum can help.

#10

Hi Alex,

I have a windows with gqrx from pothos install package 2016.06.04 and LimeSDR USB 3.0, when trying to open gqrx it crash with the radio. Can you let me know which configuration you used for the driver? and also if you have a test flow-gram for GNU radio to check if my radio is ok?

Regards.

#11

I used the settings posted here:

2 Likes
#12

Just some additional notes which may help:

LimeSuite is undergoing development and bug fixes but I believe that the copy included with 2016.06.04 installer didnt have any serious bugs that would inhibit the use of the receiver in GQRX.

#13

For anyone else trying to get the LimeSDR and GQRX working on a Mac…it’s not possible…yet.

#14

Hmmm - I’ve rebuilt gqrx from the pothos repo https://github.com/pothosware/gqrx
(gr-osmosdr and gnuradio also) - and using ppa limesuite and soapysdr per http://wiki.myriadrf.org/Lime_Suite - LimeSuiteGUI now shows fft thanks to the uncheck “show this error next time” trick and I can see the local LTE tower, yay!

But gqrx using driver=lime,soapy=0 and tried all these rates:
Sample rates that work: 1.25, 2.5, 5, 10 Msps Bandwidths: 1.5, 4, 10 MHz
and I just get a flat line :expressionless: (scratching head)

I take it we need to build limesuite ?

thanks!

#15

@cswiger is that regardless of frequency and gain settings? There have been updates to Lime Suite which have not yet made it into binary builds, so worth building source from master to get them.

#16

Yea, that’s going to open up the whole can of worms of all the different dependencies and their constantly changing versions that plagues gnuradio build from source - will try to get time to see what version of wxWidgets-dev I’m missing.

[ 38%] Building CXX object src/oglGraph/CMakeFiles/oglGraph.dir/dlgMarkers.cpp.o
/home/chuck/src/LimeSuite/src/oglGraph/dlgMarkers.cpp: In member function ‘void dlgMarkers::AddMarker(int)’:
/home/chuck/src/LimeSuite/src/oglGraph/dlgMarkers.cpp:93:22: error: ‘wxEVT_CHECKBOX’ was not declared in this scope
Connect(markerId,wxEVT_CHECKBOX,(wxObjectEventFunction)&dlgMarkers::OnMarkerChange);

#17

Sorry - fixed, old wx-2.9 cruft in /usr/local/. Now LimeSuite builds a
/usr/local/lib/SoapySDR/modules0.5-2/libLMS7Support.so

which now is dupe of
/usr/lib/x86_64-linux-gnu/SoapySDR/modules0.5-2/libLMS7Support.so

causing:
[ERROR] SoapySDR::loadModule(/usr/local/lib/SoapySDR/modules0.5-2/libLMS7Support.so)
duplicate entry for lime (/usr/lib/x86_64-linux-gnu/SoapySDR/modules0.5-2/libLMS7Support.so)

so remove:

apt-get remove soapysdr0.5-2-module-lms7:amd64

and now it appears happy.

#18

rebuild gr-osmosdr and gqrx, Annnnnd w00+!

1 Like
#19

Glad to hear you are up and running, @cswiger! Would appreciate it if you could test also and HF and let me know how you get on.

#20

@cswiger Any particular reason why you are building version 2.5.2? Why not the latest version?