LimeSDR Mini RF Loopback Test Failure

#1

Hi, there

I got a LimeSDR mini a couple weeks ago, but it won’t work properly.
The LimeQuickTest always fails with the error “SetPllFrequency: error configuring phase”.

I found the following thread and tried to change USB power supply but it didn’t help.

The followings are LimeUtil and LimeQuickTest log.
I got the same error on a Window10 host.

I would very appreciate your help.

Regards,
Minoru Tomobe
JL1NIE


LimeUtil --info
######################################################

LimeSuite information summary

######################################################

Version information:
Library version: v19.04.0-myriadrf1~xenial
Build timestamp: 2019-05-13
Interface version: v2019.1.0
Binary interface: 19.04-1

LimeQuickTest

[ TESTING STARTED ]
->Start time: Sun May 26 21:38:08 2019

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D4C3C696DD242
Serial Number: 1D4C3C696DD242

[ Clock Network Test ]
->REF clock test
Test results: 56094; 3755; 16945 - PASSED
->VCTCXO test
Results : 6711035 (min); 6711193 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 02 0D 13 02 0D 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
LML TX phase search FAIL
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
LML TX phase search FAIL
Failed to set sample rate
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.60 seconds

#2

Hi @minoru,

It looks like there is interface issue between FPGA and RF transceiver on your board. Contact Crowd Supply for replacement, please. Sorry for inconvenience.

#3

Hi Zack,

I’ll contact Crowd Supply soon.
I appreciate your help.

Thank you,
Minoru Tomobe
JL1NIE