LimeSDR Mini Programming failed - Advice or RMA please


#1

I have a brand new LimeSDR Mini V1.2 that we are trying to use for our Portsdown Digital TV project that will not update its firmware or gateware.

LimeUtil --update gives:

LimeUtil --update
Programming failed! Read operation failedled! Read operation failed (/home/pi/.local/share/LimeSuite/images/19.01/LimeSDR-Mini_HW_1.2_r1.29.rpd)
Programming failed! Read operation failed

Programming update failed!

I have checked and the update file exists:

pi@raspberrypi:~ $ ls -l /home/pi/.local/share/LimeSuite/images/19.01
total 564
-rw-r--r-- 1 pi pi 577536 Feb  1 09:45 LimeSDR-Mini_HW_1.2_r1.29.rpd

The failure occurs on multiple Raspberry Pis that have successfully updated other LimeSDR Minis.

I tried reflashing the EEPROM:EEPROM2

No change. It does pass LimeQuickTest:

pi@raspberrypi:~ $ LimeQuickTest
[ TESTING STARTED ]
->Start time: Sun Mar 10 12:56:24 2019

->Device: LimeSDR Mini, media=USB 2.0, module=FT601, addr=24607:1027, 
serial=1D42593DCD4F86
Warning: USB3 not available
  Serial Number: 1D42593DCD4F86

[ Clock Network Test ]
->REF clock test
  Test results: 50505; 63702; 11362 - PASSED
->VCTCXO test
  Results : 6711065 (min); 6711219 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 07 1B 13 03 0A 03
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
  Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
  Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
  CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-15.5 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_H):
  CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-15.5 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 2.64 seconds

But is unusable in our application with this old firmware/gateware standard.

@zack - any further ideas, or is it an RMA?

Thanks

Dave, G8GKQ


#2

Quite strange. Try to update it using PC if you have a chance. Arrange RMA, if not.


#3

Thanks @Zack

Same result with a PC:

C:\Users\dave>LimeUtil --make
Make device
  Device name: LimeSDR-Mini
  Expansion name: UNSUPPORTED
  Firmware version: 5
  Hardware version: 2
  Protocol version: 1
  Gateware version: 1
  Gateware revision: 26
  Gateware target: LimeSDR-Mini
  Serial number: 0x1d42593dcd4f86
  Free connection... OK

C:\Users\dave>LimeUtil --update
Connected to [LimeSDR Mini [USB 2] 1D42593DCD4F86]
[  0%]     0/303104 Bytes Programming failed! Read operation failed (C:\Users\dave\AppData\Roaming/LimeSuite/images/19.0Programming failed! Read operation failed
Programming failed! Write operation failed

Programming update failed!

C:\Users\dave> 

So I will arrange RMA.

Dave