LimeSDR mini - Problems with transmission


I’ve been testing my LimeSDR mini these last days and I have detected some problems. Probably the biggest one is that I can not obtain any signal from the TX port. I’ve used other SDR devices (other brands) without problems and I can measure those signal using an oscilloscope (other brand devices). But for the LimeSDR mini I can’t detect any signal. Even when I use the same examples that I use with the other devices (of course changing the device option). I have tried to change all the available parameters without success. For that reason I think that there’s a problem with my LimeSDR mini.

I have follow these steps to install the software:
Gr-limesdr Plugin for GNURadio:

I updated the Firmware without problem using:
$ LimeUtil --update

The LimeQuickTest gave me this output (Apparently without problems):

This is the example I use to generate a signal (Runs OK, but I don’t obtain any signal when I use my LimeSDR mini):


I’ve tried changing the parameters available in the “LimeSuitSink (TX)” (previous picture) without success. Please, give me some feedback (steps to follow) in order to solve that problem. I’d appreciate it.

Best regards,

Unfortunately I haven’t received any comments yet.

I’ve been following some topics related to my problem, like this:

But I couldn’t find a solution to my problem.

I’ve been thinking, since I can receive signals like FM stations. At least the RX part is apparently OK and the software and configuration also OK.
Is there any additional test (besides from my test in gnuradio) that could you please suggest me.

Best regards,

@Zack, any suggestions for additional tests to perform?

I followed this suggestion:

I have installed a new system and all the installers (twice), unfortunately that didn’t work at all. I still can NOT TX. I’m still looking for a solution.

Can you try this loopback flowgraph? Connect RX and TX using SMA cable and use gain sliders to check if a signal appears in spectrum. Make sure you have newest LimeSuite(19.01), Gateware(1.29) and latest gr-limesdr from the master branch.
Here is how it looks on my side:

And here is the flowgraph:
You could also try basic TX example from LimeSuite.

@Zack ping.

Hello @Garmus

Unfortunately the loopback flowgraph gives me errors when I try to run it. I see that it was made for a LimeSDR version, not for the Mini version that I have.

I had tried a basic example as the one I mentioned in my first post, but I still have the same problem, I cannot obtain any signal from the TX port.
I had tried the basic example using another SDR device and I obtained the TX signal whitout problems.
I’d appreciate you send me an example made for the Mini version that I could test In order to figure out finally what’s the problem.

Best regards,

Flowgraph gives you errors because you didn’t update gr-limesdr. Newest version doesn’t have a setting for a specific device anymore.