Very weak reception and transmission does not work. Is my limesdr mini defective?


#1

Hello, I just got my limesdr mini and trying to test it. I installed the software to ubuntu 16.04 (already tried debian 9. It has the same problems) by this guides
https://wiki.myriadrf.org/Lime_Suite
https://www.hagensieker.com/blog/page/?post_id=104&title=limesdr---mini-on-ubuntu-with-gqrx

Everything looks OK, I can make the self test, I can update the firmware of the LimeSDR (but sometimes it see usb 2.0 instead of 3.0)
But when I trying to receive some signals with gqrx the reception is very weak, just a noise!

Ok, it’s bad, but this is not the end. Signal transmission also works very bad. I tried to use this example to tranmit data at 90 Mhz



but it looks like it only works for the first couple of seconds (program is work, but i hear a noise in FM radio from my mobile phone for about 1 second)

Please help me, i’m new to limesdr. I have no clue if I am doing something wrong, or if my limesdr mini is defective.


#2

in your screenshots LNA gain is set to 0!


#3

Hello, thanks for reply. LNA gain makes this situation a little better


But the oddity is that I only see data at frequencies close to 100 Mhz and still almost nothing on others


I’m newby to sdr and do not understand. Is the some calibration required to receive the signal?

Calibration with LimeSuite is now working properly. Sometimes it gives me error 3 and error 5
image

TX calibration is not working too


#4

Now i am not familiar with gqrx so much nor Limesuite, But
in Lime suite do the automatic update(skip if version is= i FW:5 HW:1 Protocol:1 GW:1.27 )
(Modules -->programming–>(new window) Program mode should be automatic)
unplug replug
then connect
for each tab press default after that’s done
press gui—> chip!

as for Gqrx it should do the calibrations IQ and DC spike removals it self(i think or have options like other sdr software supporting Lime mini) Sdrangel is also a good option a bit of a learning curve but has a heap load of features, also on windows only sdr-console works great thou newest version does not work with my limesdr mini so i use 3.0.2
P.S
i usually have TIA and LNA gain at max and adjust PGA


#5

Thx for fast reply. I repeated your actions in the program. But received signal is also very weak. When I use TIA, LNA and PGA gain in gqrx it just makes more noise, no signal.


In LimeSuite test signal is weak too


#6

Probably a very silly question, but what is your antenna ? (It does have a SMA connector and not a RP-SMA connector)


#7

im pondering on antenna now as well thou if we get a screen shot of 100Mhz we know if chip is working LoL
P.S
TICK
DC remove and IQ balance


#8

I have an two antennas with SMA connectors. Bought them along with lime mini from store.
The problem is that in all review articles and videos the signal was quite good. But I seen just a noise or very low signal (I can’t even catch the fm radio that my mobile phone catches.)


#9

you receive anything at all? for ex local gsm/tetra or BFM?


#10

Thou i do believe there is a change your Lime mini suffers same fuckup as mine goes Deaf and not even TETRA tower thats 500M away makes much of a signal lol and thats with a stacked dipole on freq with dual LNA’s lol but it randomly works just fine and beats my other sdr’s by a mile


#11

This is gsm (just a noise)

wifi

This is something in the fm, but signal very weak

Some signal in 400 - 500 Mhz (noise leveling at center because large bandwidth)

All tests with antenna


#12

at 100Mhz you should have a HUUUGE noise signal tis is dead


#13

100Mhz NO antenna connected


#14

Can I contact with developers to solve problem, or there is money on the river water?:worried:


#15

@Zack @andrewback ^^


#16

Hi @oh2eko,

Check the board using Quick test and paste log file here, please. You will find SW here:
https://wiki.myriadrf.org/LimeQuickTest


#17

Hello, Lime quick test works fine

[ TESTING STARTED ]
->Start time: Wed Dec 5 19:37:33 2018

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D424B5154E8D6
Serial Number: 1D424B5154E8D6

[ Clock Network Test ]
->REF clock test
Test results: 3670; 16867; 30064 - PASSED
->VCTCXO test
Results : 6710987 (min); 6711141 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 07 1A 12 07 1A 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-12.4 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-12.1 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 2.76 seconds


#18

Zack So, can I solve this problem?


#19

Hi @g0dfuzz3r,

As I can see, your board is OK. Hence it looks like configuration issues.
Do you have a possibility to connect RF output of LimeSDR–USB to RF input via cable? Then we can prepare register setup to test the board.


#20

Hi @Zack,

I have a similar problem with my LimeSDR Mini, in my case I can not obtain any signal from the TX port.
Could you please help me? Maybe a test (as you have mentioned) could help me to figure out if there’s a solution to my problem. I have a cable (SMA-SMA) to connect the output and input ports.

I’ve posted the info related to my problem, unfortunately I haven’t received any comments.

Here’s the info of my problem:

Best regards,


LimeSDR mini - Problems with transmission