LimeSDR mini output power limited to ~ -20 dbm

Running a GNUradio generated pulse signal from LimeSDR mini directly to an oscilloscope (via USB-3 port & 50 ohm cable) and can’t get better than a 30 mV peak to peak signal… am around a 127 MHz RF signal, but changing center freq doesnt help.

Trying to figure out if I’m using wrong TX mode? Can i use LimeSuite to change the output mode?

Any other ideas for cause?

(sorry for choppy post- have a broken dominant hand.)

That looks about right if you are using tx2. See graph at LimeSDR’s maximum transmitting power at different frequencies - #2 by Karolis

Tx1 should provide much more though.

Do you know if it’s possible to switch to TX1 in GNUradio-companion or in the code? I read somewhere that if I change the TX mode in LimeSUITE and then switch to GNU it will just switch back to the default channel.

As an update, I did not have the channel in the source block matching that of the .ini file. But it doesn’t seem to matter because I can’t calibrate the TX when I switch from channel A to B anyways. Not sure how it’s possible to switch channels using the LimeSDR mini at this point because it seems like it’s not possible to calibrate on anything but default settings.

  • File: Select .ini file which you configured and saved by using LimeSuiteGUI. This setting should match in LimeSuite Sink (TX) and LimeSuite Source (RX) blocks for the same device.
1 Like