LimeSDR Mini 2.0 Failing Programming and Self Tests


I am a student attempting to use the LimeSDR through GNU Radio for my senior project. A few weeks ago, I was able to run the LimeQuickTest on my Raspbery Pi5 running Ubuntu and it was passing all. I have to teach other students in my class how to setup their own Lime Mini’s, so I started on a fresh Ubuntu image to try again. I followed the same method I did the first time, and now I am not passing any tests. When I run “LimeUtil --update”, programming fails, however I am still able to see the device with “–find”.

I have already visited these threads and tried to implement their solutions with no luck:

Most specifically of all of these, replacing the 0 bytes file for programming did not seem to fix this issue. I have also attempted to run the Quick Test on my Windows 11 machine with the exact same problems. This does not seem to be board specific, I tried a fresh Mini 2.0 and experienced all the same problems. Please let me know if I can provide any more useful information

What version of LimeSuite are you using? LimeSDR Mini v2 can be seen by old version software as familiar device, even though that software might not have specific support for it, that would result in tests not working properly.

1 Like

Hello, I was able to mostly work through this problem, I think you’re probably right that it was a LimeSuite version issue. To be completely honest, I don’t exactly know what fixed it. I am now running a VM of DragonOS which seems to have all the dependencies for LimeMini 2.0 taken care of. I ran into an issue running this on my Pi5 but adding the PPA and updating the packages seemed to fix this…?

One last problem though, I don’t know how to check if I’m receiving properly, and I don’t believe I am. My idea was to just use GQRX to scan the spectrum and see higher power at FM radio stations, etc. but I couldn’t see anything besides noise at any frequency. I even used my Baofeng right next to it (and a Spec Analyzer to make sure I wasn’t crazy…) and was only seeing background noise. Any ideas?

We would strongly advise against using LimeSDR hardware from inside a VM. We’ve previously done this with workshops and the results have been highly variable, but on the whole of a bit of a nightmare. A regular VM will have latency issues and this is the last thing you want with SDR workloads. On top of which device passthrough, in particular with USB 3.0 devices, can be decidedly problematic.

Would suggest as a first step using either SDR Console on Windows or SDRangel on Linux (not in a VM!). With the latter I believe you need to add the SDR as a MIMO device when configuring the app.