Problem getting started with LimeSDR (unable to run LimeQuickTest)

I bought a LimeSDR Mini from Mouser a few days ago. I am having trouble to get it to work.

I have followed the guide at

I ran the gateware update (LimeUtil --update). The first time it downloaded new gateware and applied it to the LimeSDR Mini. If I run the update again I get the following message which indicates that I have the latest gateware:

Connected to [LimeSDR Mini [USB 3] 1D53BB2CE1D63C]
Existing gateware is same as update (1.30)

Programming update complete!

The LimeSDR blinks yellow+red when connected to an USB3 port.

I start LimeQuickTest. It doesn’t display anything (not in Command Prompt, no gui). Same result if I start it by double-ckicking in Windwos Explorer, running as Administrator in Windows explorer, start it from a command prompt, start it from an elevated command prompt.
Only change is that the LimeSDR mini starts blinking green instead of yellow+red.

When I try to start LimeQuickTest again, the LimeSDR starts blinking yellow-red for about a second and then goes back to blinking green. Still no GUI or console info.

Nothing is logged to the Windows Event log (checked Application, Security and System).

I tried starting CubicSDR. It enumrates the LimeSDR but when I click on the entry an error message is displayed: “An unhandled exception ocurred” - see screen shot below.

When I start LimeSDR Suite GUI I can connect to the LimeSDR Mini. The following message is displayed when connecting:

 INFO: Connected Control port: LimeSDR-Mini FW:6 HW:2 Protocol:1 GW:1.30 Ref Clk: 40.00 MHz

It is possible to read the temperature (45C).

The FTDI driver seems to be installed correctly (see screenshot below) and is latest version (

Platform: Windows 7
Pothos version: PothosSDR-2019.06.09-vc14-x64

Any idea why LimeQuickTest won’t work?


SDRsharp is able to see the Lime SDR mini, but it can not read the radio’s properties (firmware version, gateware version, etc) and no data is received. See screen shot below.

I have performed the same steps on a Windows 10 laptop and got the same results.

Did you copy Limesuite.dll into SDR# folder?

Without Limesuite.dll Sdrsharp does not find the device at all - the “Device” drop-down is empty.

Looks like your device is recocnized as USB 1.0 or 1.1 (… media=USB,…). Check cable and/or port. Also try FTDI FT601 utility to read configuration data.

1 Like

Thanks. I got it working for FM now. See screen shot below

Things I learned:

  • The Device info will not be populated unless the SDR is in “play” mode. Without pressing play, Device Info will always display empty Radio model, Library info, Firmware version, Gateware and Serial number.
  • Gain settings are important, and not intuitive (at least not for me). With the LNA Gain at 15dB I had good reception. I dragged the LNA gain to 16dB - signal almost died. I then adjusted the Gain (not LNA Gain) setting slightly (without touching LNA Gain), and signal was back to approximately the same level as I had with LNA Gain at 15dB.
  • If I set the sample rate higher than 6-8 msamples, I hear drops in the received audio. This is probably my computer not keeping up. I have a Core i7-3770 @ 3.4GHz (8 cores with hyperthreading) and I thought that would be enough, but I’ll have to learn more before I can conclude anything.
  • The IQ recording plugin I have been using for rtlsdr (SDRSharp.IFRecorder.IFRecorderPlugin) does not work with LimeSDR mini. When I press record a 44 byte file is created (probably the wav header), and then nothing happens.

I am still not able to run LimeQuickTest though.

Glad to hear that you are up and running and cannot think why LimeQuickTest would fail to run when other apps do, unless its an issue with that particular build of the utility.

The build I’m using has been available for almost 6 months, so I would hope that someone had tried it before me. But good idea, I’ll try an older build tomorrow.

Right, so that seems unlikely, although the reference platform is Linux and most people use this.

Thanks. I will try on Linux as well. I’ve already made two attempts. Seems the myriad ppa didn’t have support for 16.04 LTS, so I installed the latest version (19.10) but there was no ppa for that either. I think next step is to try 19.04 but installing takes a while so I’ll need to find enough free time to test it.

16.04 LTS was supported and 19.10, along with other non-LTS releases, is not supported. Would recommend 18.04.

1 Like

Great, then I’ll try 18.04 next. Could maybe be updated to include supported (and/or recommended) versions?


1 Like

LimeQuickTest runs fine in a vm running Ubuntu 18.04.

Text output:
micke@sdrlab:~$ LimeQuickTest
->Start time: Tue Dec 17 16:43:47 2019

->Device: LimeSDR Mini, media=USB 2.0, module=FT601, addr=24607:1027, serial=1D53BB2CE1D63C
Warning: USB3 not available
  Serial Number: 1D53BB2CE1D63C

[ Clock Network Test ]
->REF clock test
  Test results: 51724; 64921; 12582 - PASSED
->VCTCXO test
  Results : 6710989 (min); 6711145 (max) - PASSED
->Clock Network Test PASSED

->Read data: 13 07 10 13 07 10 02

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
  Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
  Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
  CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-14.3 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_H):
  CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-14.0 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 4.35 seconds

(Except that I wasn’t able to forward the LimeSDR to the vm when it was connected to an usb3 port, so I used an usb2 port instead.)

Uninstalled PothosSDR-2019.06.09-vc14-x64.exe and installed PothosSDR-2019.03.24-vc14-x64.exe

LimeQuickTest doesn’t start. Tried from a normal command prompt an an elevated command prompt, with --gui and --nogui and without any parameter, and with the LimeSDR connected to usb3 and to usb2.


Thanks for further testing this out. Lime doesn’t provide the Pothos SDR installer and this is from Josh Blum, the Pothosware developer.

@IgnasJ, is there a standalone LimeQuickTest for Windows that can be downloaded?