Is my LimeSDR Mini faulty

Hi, I recently received my LimeSDR mini.

Straight out of the box I followed the steps described here ( to test my device is functioning properly. LimeQuickTest fails consistently:

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
  CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-61.3 dBFS, -1.74 MHz) - FAILED
->Run Tests (TX_1 -> LNA_H):
  CH0 (SXR=2100.0MHz, SXT=2> 105.0MHz): Result:(-12.8 dBFS, 5.00 MHz) - PASSED
 ->RF Loopback Test FAILED

I went on and did the WCDMA test also on that page and I think I got sensible results, but the test is on 2.1GHz, which already passes on LimeQuickTest.

I tried updating my firmware but the issue persists. The device is connected to a usb-3, and I run Linux version 5.6.17 (hardened). I ran the test both with and without antenna (I got the small antennas along with the LimeSDR Mini from crowdsupply)

Is there something I may be missing that makes the test fail on a functional device?

When the device arrived the box of the delivery service was fine, but the green and gray box where the LimeSDR Mini came had a fold.

I attach pictures of the device as suggested in a support email.

Hi @edmeme180,

Could you try to update board firmware, please. Then run LimeQuickTest again and post log file here.
Check this post too: Fix in Lime Suite for LimeSDR Mini loopback test failure

1 Like

The limesuite version from git works fine, thanks!

1 Like