LimeSDR Mini faulty?

I purchased a LimeSDR either last year or the year below.

The first thing I tried (after adding a heatsink) with it was to see if I could get OpenAirInterface or srsLTE running. I got it running…once. I constantly had issues with things like self-tests failing and whatnot. I constantly had issues with calibrations failing and whatnot. I set it aside and picked it back up every few months, assuming that it was simply user error. I tried a multitude of host computers, operating systems, drivers, utils, and no matter what I did I was constantly getting USB resets and device-busies and whatnot, but I still thought I must be doing something wrong. Oftentimes it would work at the start but quickly stop working after only a few minutes.

Only after searching for many hours today after sitting in front of a 10-foot satellite dish trying to even get gqrx to work did I wonder: perhaps my device is faulty? I’ve been having these issues since day 1.

LimeQuickTest usually fails.

->Start time: Tue Apr 27 21:47:29 2021
->LimeSuite version: 20.10.0-20.10.0

->Device: LimeSDR Mini, media=USB 2.0, module=FT601, addr=24607:1027, serial=1D4C38EA89638A, HW=2, GW=1.30
Warning: USB3 not available
  Serial Number: 1D4C38EA89638A
 Chip temperature: 37 C

[ Clock Network Test ]
->REF clock test
  Test results: 36109; 49306; 62502 - PASSED
->VCTCXO test
  Results : 6711060 (min); 6711212 (max) - PASSED
->Clock Network Test PASSED

->Read data: 13 02 0D 13 02 0D 02

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
  Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
  Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
  CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-21.1 dBFS, 5.00 MHz) - FAILED
->Run Tests (TX_1 -> LNA_H):
  CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-22.0 dBFS, 5.00 MHz) - FAILED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.65 seconds

What can I do? Is my board really faulty?

The loopback test values are not far out of spec. If the board is completely cold (has just been plugged in) it is just marginally below specified performance, but should still work fine. Though if the board has been plugged in for any period of time and warmed up, such values are to be expected.