Installed PhotosSDR with latest .exe but Limesdr blocks are missing in GNU Radio Companion

Hi guys!

I am currently starting to work with the Limesdr. I managed installing PhotosSdr (i took the latest version from here:

I can start the LimeSuite and I also installed the driver software for the Lime USB board which i can connect with the LimeSuiteGUI. I can also start the GNU Radio Companion software, but i cannot find the Lime Sink / Source block.

I tried to download the .zip file which is usually used when installing GNURadio by binaries and extracted it to the PhotosSDR folder, as there where no files like gnuradio-limesdr.dll in the bin folder of the PhotosSDR folder.

Do I have to run any python script or something like that in order to import the blocks for th LimeSdr or did I do anything wrong in general? All other topics in the discussion were unfurtunately not helpful for me…

Thanks in advance!

sudo apt-get install gr-limesdr

should get you going.

I maybe should have adressed that I am using windows - is there a similar solution for this case?

Indeed I also have ubunto on my computer (using parallels on mac for windwos and Linux). The installation of gnu radio and the LimeSuite worked fine, but my problem is that SoapySDR cannot find my LimeUsb device. So if anybody could help me with one of those problems I would at least be able to run it on one operating system

Okay guys i have found i out by myself. The problem was, that the GNU Radio version was 3.8 and the available gr-limesdr zip from the link was for GNu Radio 3.7.

I did now install the GNU Radio not using Photos if anybody else having problems like me.