GNURadio Companion Source Block

I just got my limeSDR yesterday! I have it working in Pothos and the correct driver in Device manager. What I am having trouble with is using LimeSDR as a source in GNURadio- which is what I know how to use. I have tried Ossmocon with "driver=lime,soapy=0(tried 2 as well) but it always says port disconnected. Please Help. Using windows 10 (yuk), its for work. I have tried Kali and Skywave using flash drive boot but without much luck either. Need wisdom please.

Sounds like you’re using the correct device string and if you have the Pothos SDR installer on Windows, you should have everything. @joshblum, any ideas?

Can you share the terminal output, or the message window output? Any additional verbose might help.

I don’t recognize the error, but FWIW I just built and uploaded a new installer. I tested gr-osmosdr with the limesdr using those same arguments driver=lime,soapy=0 and it seems to be fine.

I did a fresh install of Windows 10, installed Cypress bootloader the myriad limesdr drivers, which come up correctly in device manager. It communicates with lime suite and pothos. In gnuradio I use osmocon source block with device arguments of driver=lime,soapy=2 tried 0 as well. When I apply in osmocom properties it says Source-out1(1):
Port is not connected.

How do I get limesdr working with gnuradio? Please help

I uninstalled the version of gnuradio that was not part of the Pothos install. the reason i installed it was because when ran the Pothos supplied one i get this error “Failed to open registry key HKLM/SOFTWARE/PythonCore/2.7InstallPath
Is Python 2.7 Installed?” Im hoping if I fix this problem with gnuradio(supplied with pothos) i will hopefully be able to get LimeSDR to work with GNUradio!!! How to i fix this Please

In installed a 64-bit version of python 2.7 and get the py helper thing- heres the readout
== Runtime and import checks

  • Check locate GNURadio runtime… PASS
  • Check locate GTK+ runtime… FAIL
  • Check Python version is 2.7… FAIL
  • Check import gtk module… FAIL
  • Check import numpy module… FAIL
  • Check import lxml module… FAIL
  • Check import Cheetah module… FAIL
  • Check import wx module… FAIL
  • Check import OpenGL module… FAIL
  • Check GRC blocks path set… PASS
  • Check import GNURadio module… FAIL

== Checks passed summary

GR_RUNTIME: C:\Program Files\PothosSDR\bin\gnuradio-runtime.dll
GRC_BLOCKS: C:\Program Files\PothosSDR\share\gnuradio\grc\blocks

== Checks failed summary

GTK_RUNTIME: failed to locate the GTK+ runtime DLL
PYVERSION: can’t find pip executable C:\Python27\Scripts\pip.exe
IMPORT_GTK: No module named gtk
IMPORT_NUMPY: No module named numpy
IMPORT_LXML: No module named lxml
IMPORT_CHEETAH: No module named Cheetah
IMPORT_WX: No module named wx
IMPORT_OPENGL: No module named OpenGL
IMPORT_GR: No module named numpy

== Fixing problems

Handling issues for GTK_RUNTIME…
The system cannot find the path specified.
Error: pip failed to install requests
Error: No module named requests"

any help?

got the Pothos bundled version of GRC working after installing a 64-bit version of python 2.7 but still not working. “port not connected” when using osmoscom source block.

simple restart of computer and everything working. Python 2.7 can suck it.

Hello Merc,
Not sue if this will help you, have you read this other discussion?