Error: Python 2.7 Inspection Failed

When I try to open GNU radio companion it says “Failed to open registry key” …has a registry path that ends with “Is python 2.7 installed?”

This is on a new install of windows 7. I downloaded and reinstalled python, then uninstalled and reinstalled it a couple of times. Same thing.

Any ideas?


Hello @fltech,

I had the same issue on a windows 10 machine and was about to give up on trying to get it working, but one last ditch try seemed to work.
I started off by uninstalling anything related to Python, GNU radio and PothosSDR, I then deleted any directories that had been left behind, especially the python directory that may have been installed inside the program files directory, but also any that had been installed in the root directory.

I then choose to follow the instructions on this page:

and specifically this

  1. Install Python2.7 for amd64

This is a 64-bit installer and GNU Radio requires the 64-bit version of Python 2.7. Look for the “Windows x86-64 MSI installer” on the python downloads page.

Note: If you choose to customize the python install options, make sure that the “register extension” box is checked. This tells the installer how to find Python at runtime through the windows registry.

I don’t have that PC in front of me at the moment, but from memory the new install defaulted to the root directory.

After following the instructions on the above page and the linked pages of installing PothosSDR I eventually got to a point where I could get GNURadio running on my machine.

I guess I had better put a disclaimer here, Since doing the install this way, I have not yet tried connecting my LimeSDR to that laptop, but I would expect it will work once I finally do get the LimeSDR and the Laptop in the same physical location at the same time.

Hope this helps,

1 Like

Hey Bevan,

Thanks for the input. I figured someone else had to of seen this error before.

I following the directions you gave. I’m getting a different error though in the stage of installing the driver with this Zadig program.

LimeSDR is in device manager under USB devices. But the steps involve running this Zadig then testing. Neither are working. :frowning:

On the left is what its supposed to look like, the right is what’s actually happening.

Hello @fltech,

I will have to do some testing of my setup to be able to qualify this answer, however, before doing the Zadig driver modification, I wonder if it is not necessary and that for this install the official LimeSDR drivers should work, did you try the SoapySDRUtil.exe software to see if it was able to find your LimeSDR?

I will make an effort to get both the LimeSDR and my laptop in the same place in the next 24hrs and see if I can get the two talking to each other, from the laptop I had previously used LimeSuite to do the testing of the LimeSDR with out the need for the Zadig driver modification. From memory using Zadig for RTL dongles, I had to right click and run Zadig as administrator even though I was logged in with admin permissions, maybe that is worth a shot?


Hey Bevin,

I wonder if running LimeSDR right from my laptop affects it? I don’t have a cable right now.

I used your idea of running it in admin, along with some other things. Oh, the big thing was having windows update the driver for Lime. It amazingly found one and moved it to a different place in the device manager.

After that, the Cube program would work. But the others would crash right after trying to run them. So I uninstalled and I’m re-downloading the Pothos file and will see what that does.

The Cube worked, but was fuzzy, and it sounded like I was getting 2 radio stations at once. It changed some when I moved the coax to my antenna around. I bought it used. But I’m sure its a settings or software issue too.

Hello Daniel,

Running the LimeSDR directly from the Laptop should be fine, the biggest issue / risk is breaking the USB connections due to flexing, thus a cable between the two will help with strain relief, the cable also needs to be USB3 capable (ie has the blue connectors) as there are more connections involved in USB3 than previous incarnation. The LimeSDR was supplied with a Y cable that I think was mostly about increasing the supply capability for the LimeSDR to run nicely, one of the connectors only had a power supply connection and no data connection.


Ok, thanks for the info. I was wondering. Good point on the flexing. I have my Lime propped up with something on the far end thats just the right height. Until I get a case going.

Mine didn’t come with any kind of connectors or cables. Which I thought was odd. And no heat sink seems strange for something that runs hot.

I just reinstalled Pothos, and the same thing happens. Ugh. Man, this is a pain.

These pics tell the story of trying to open GQRX.

And mostly what I’m trying to do is generate good waveforms for some research.

crash detected

error 2

error 3

error 4

Here’s the second half of the error if it helps:

error 5

Hello Daniel,
I plan to take my laptop into work tomorrow to test against the LimeSDR, however I wonder if leaving the bandwidth at zero causes some issues with the maths behind the code. I had read that having the input rate below 3.6Mhz can cause issues but you were using 5Mhz so that shouldn’t be the issue

Hello Daniel,

I finally got the LimeSDR connected to the Laptop after reinstalling PothosSDR on my WIndows 10 64bit machine, I have not used Zadig to change the driver. I tried running Gqrx using the same settings as yourself and also experienced the crashes.
I had read other posts about the use of Gqrx with LimeSDR and they seemed to be using the “Other” as the input device and setting the Device String to use the SOAPYSDR driver, however I tried the option of Device “Ettus SOAPY (U…09060A0243121E” as it seemed to have the SOAPY component and also the serial number of my LimeSDR,
Gqrx Configure IO Devices
I choose and input rate of 5Mhz and a Bandwidth of 5Mhz also,
Gqrx Configure IO Devices Settings
and was able to tune to the local FM radio station.

Hope this helps,


Great find there! This may work in a lot of other places.

Hey Bevin,

I was excited to try it out. The settings allow the program to open, but it still doesn’t work right. At least all the Gqrx gets is snow.

Removing the pre-made coax to the antenna improved the reception of the Cubic program, but it has odd behavior… and its kinda fuzzy. I can put it on the talk radio station frequency, but it gives me the R&B station. Another station that should be there has no audio.

I ran the GNU helper to see what would happen. A DOS-like screen with errors popped up, but said it was fixing them and installed a dozen different files. But the Gqrx still doesn’t work. It starts up but won’t play anything other than static.

I reinstalled the Pothos package. I installed it to the C: drive this time, instead of the programs director. That seemed to help the GNU helper. But same results as before with radio. Is this normally this difficult?

Excited with error! (haha)

excited with error

Hello Daniel,

In Gqrx did you select an antenna, it is in the input controls section?


1 Like

Yay Bevan! It works now.

The Gqrx didn’t work before. Yay! : )

About that time, I turned off “IDT audio” in msconfig, that was running in the background. But I figure it definitely wouldn’t work without the antenna specified.

The antenna that works is “LNAL”. Which must be short for “13ft of magnet wire wrapped around a dowel rod”. :wink:

I’ve been messing with the other settings to see what does what. The music stations are pretty clear. Still a tiny bit fuzzy, so I wonder if the settings or antenna are not just right. But to give it a measurable description, no one would notice if this was the source of the radio during a party or something.


1 Like