External power supply damaged board?

#1

Hi,
I ran into an issue with my LimeSDR. I plugged in a external 12v .75a power supply into my board while it was connected to USB and the lights went out. Now the unit wont power up. I’ve tried both the external supply as well as the normal usb and it doesn’t light up at all. I’m concerned that there is an component failure The board says it accepts 6-12v supplies so I’m not sure why this occurred. Is there some issue with my unit, possibly defective components?

Edit: The PS was .75a not 1a

#2

Did you check the polarity of the external P.S

#3

+1. I’d check the polarity and measure the actual voltage.

#4

+1 BTW the power jack is center-positive.

Just a note from experience. Wall warts power supplies vary widely in their quality and can vary widely from their rated power. Plus their have been counterfeits that were very bad. i.e. fake Apple branded, etc.

#5

I measured the voltage and it was 12.4v center positive. If that extra .4v caused the board to burn out then it has very tight tolerance and should be rated lower on the board. I put an email into Crowd supply and haven’t heard a response after giving them this same information.

#6

Have you tried updating it just in case still works even no light. Is the hardware been detected at all even no light?

#7

No such luck. It is not being detected in my usb devices nor when I try to connect to it in LimeSuite.

#8

External P.S has reverse plug in protection for over voltage not sure but try used different usb cable and plug it in different usb port. One thing some P.S has higher voltage output than rated on the mark 12v but sometimes they have 14 volts or more specially the Chinese one in case on that possible got zap from over voltage.

#9

Hello @jslatten,

Ancer is correct - there is a reverse voltage protection.
Do you have an access to multimeter or a scope?

#10

I have a multi-meter. I tested the power supply with it and measured 12.4v.

#11

I’ve tried other usb cables and still same result. Measured the power supply and got 12.4v.

#12

Are they both connected when you doing the test.

#13

I’ve tried several different configurations with the same result. External power supply connect and usb. USB alone. Power supply only. No lights and not being detected by my computer.

#14

Have you tried another computer you never mention what kind of computer you have and whats O.S?

#15

I haven’t tried a different computer yet, but the USB ports work with other devices/sdr’s/etc. I’ll try my mac mini as well as a raspberry pi 3 I have. I’m running Ubuntu Linux 16.10. I have tried different ports, and through a powered hub

#16

I have win10 and ubuntu 16.04 i admit took’s me a while to get everything i want to work after over a month come software once in a while but still usable now than before.

#17

Can you show a picture of the power supply showing the specs?

Maybe show a picture of the LimeSDR too.

Also measuring PS output depends on load vs. no-load, etc. PS vary widely and never can trust them.

FWIW when I hunt for old PS at flea market/swap meet/thrift shop/second hand store I usually grab the Sony/Panasonic/Nikon/ and other known makers.

#18

I tested from both a Raspberry Pi and Mac Mini with the same result. (No lights and device not detected). Here some pictures I sent support. I connected and took measurement from the power jack this time. Also in case anyone was wondering- This device was working fine prior to connecting the external power supply. As soon as I connected it the lights went out and hasn’t turned back on since.

#19

Looks like your FR38 component let out the magic smoke. It also looks like pins 2 and 3 on the amphenol usb3 may be shorted. Maybe you can give closer pictures of the top and bottom sides of that side of the board?

#20

Your right his FR38 burn if you can replace it or make jumper try 6 v P.S for now then you’ll see if its going to work.