CS-lime-01 Board test failure

HI ,
I have one board which fails in quick test and also gets very hot. Logs attached. Do anyone has idea what could possibly go wrong?

logs:
[ TESTING STARTED ]
->Start time: Mon Dec 14 13:09:10 2020
->LimeSuite version: 20.10.0-g1480bfea

Gateware version mismatch!
Expected gateware version 2, revision 23
But found version 2, revision 22
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

->Device: LimeSDR-USB, media=USB 3.0, module=FX3, serial=0009081C05C1281D, index=0, HW=4, GW=2.22
Serial Number: 0009081C05C1281D
Chip temperature: 45 C

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 32315; 36071; 39827 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112941 (min); 5113081 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 01 18 13 01 18 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
->Run Tests (TX_2-> LNA_L):
CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-15.2 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-17.6 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-43.3 dBFS, -20.00 MHz) - FAILED
CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-20.3 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_2-> LNA_H):
CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-17.0 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-15.3 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 6.61 seconds

[ TESTING STARTED ]
->Start time: Mon Dec 14 13:22:44 2020
->LimeSuite version: 20.10.0-g1480bfea

Gateware version mismatch!
Expected gateware version 2, revision 23
But found version 2, revision 22
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

->Device: LimeSDR-USB, media=USB 3.0, module=FX3, serial=0009081C05C1281D, index=0, HW=4, GW=2.22
Serial Number: 0009081C05C1281D
Chip temperature: 37 C

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 27922; 31678; 35434 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112941 (min); 5113081 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 01 18 13 01 18 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
->Run Tests (TX_2-> LNA_L):
CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-14.5 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-16.8 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-43.5 dBFS, -20.00 MHz) - FAILED
CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-19.0 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_2-> LNA_H):
CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-17.3 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-15.8 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 6.72 seconds

[ TESTING STARTED ]
->Start time: Mon Dec 14 13:29:23 2020
->LimeSuite version: 20.10.0-g1480bfea

Gateware version mismatch!
Expected gateware version 2, revision 23
But found version 2, revision 22
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

->Device: LimeSDR-USB, media=USB 3.0, module=FX3, serial=0009081C05C1281D, index=0, HW=4, GW=2.22
Serial Number: 0009081C05C1281D
Chip temperature: 34 C

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 28795; 32551; 36307 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112941 (min); 5113080 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 01 18 13 01 18 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
->Run Tests (TX_2-> LNA_L):
CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-14.3 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-16.3 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-43.1 dBFS, -20.00 MHz) - FAILED
CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-18.5 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_2-> LNA_H):
CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-16.2 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-14.9 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 6.50 seconds

Looks like there may be damage to a Tx/LNA port.

@Zack, do you have anything to suggest?

Hi @rohit.soni,

Update the firmware to the latest and try LimeQuickTest again, please. If the same problem remains, then contact CrowdSupply for replacement.

Hi @Zack,
Did update on the same board. The firmware still did not updated and the LimeUtil --update command says no need to update and stays on 22 version.
logs below after running test again.
[ TESTING STARTED ]
->Start time: Wed Dec 16 11:18:59 2020
->LimeSuite version: 20.10.0-g1480bfea

Gateware version mismatch!
Expected gateware version 2, revision 23
But found version 2, revision 22
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

->Device: LimeSDR-USB, media=USB 3.0, module=FX3, serial=0009081C05C1281D, index=0, HW=4, GW=2.22
Serial Number: 0009081C05C1281D
Chip temperature: 45 C

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 19835; 23591; 27347 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112941 (min); 5113080 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 01 18 13 01 18 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
->Run Tests (TX_2-> LNA_L):
CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-15.1 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-17.4 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-43.3 dBFS, -20.00 MHz) - FAILED
CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-20.0 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_2-> LNA_H):
CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-17.8 dBFS, 5.00 MHz) - PASSED
CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-15.6 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 6.49 seconds

Can you provide CroudSupply contact link so I can request replacement?

Regards,
Rohit Soni

Can you please post details of the error as the firmware update fails.

Here is the attached image. it says no firmware update required

Hello @andrewback , Any update on error message?

Old software then ?
The current gateware for LimeSDR-USB hardware revision 1.4, since 2020-05-21 is version 2, revision 23 which was officially released 2020-10-29 ( ref: https://github.com/myriadrf/LimeSDR-USB_GW/blob/master/src/revision/revision.vhd#L17 )