SoapySDR doesn't find LimeSDR libs

hi everyone, I’ve to reinstalled my Ubuntu and installing LimeSDR with SoapySDR. However I’m getting this:

Lib Version: v0.7.0-g2a266d60
API Version: v0.7.0
ABI Version: v0.7
Install root: /usr/local
Search path: /usr/local/lib/SoapySDR/modules0.7
No modules found!
Available factories… No factories found!
Available converters…

  • CF32 → [CF32, CS16, CS8, CU16, CU8]
  • CS16 → [CF32, CS16, CS8, CU16, CU8]
  • CS32 → [CS32]
  • CS8 → [CF32, CS16, CS8, CU16, CU8]
  • CU16 → [CF32, CS16, CS8]
  • CU8 → [CF32, CS16, CS8]
  • F32 → [F32, S16, S8, U16, U8]
  • S16 → [F32, S16, S8, U16, U8]
  • S32 → [S32]
  • S8 → [F32, S16, S8, U16, U8]
  • U16 → [F32, S16, S8]
  • U8 → [F32, S16, S8]

Here’s a commands that I used:

#packages for soapysdr available at myriadrf PPA
sudo add-apt-repository -y ppa:myriadrf/drivers
sudo apt-get update
#install core library and build dependencies
sudo apt-get install git g++ cmake libsqlite3-dev
#install hardware support dependencies
sudo apt-get install libsoapysdr-dev libi2c-dev libusb-1.0-0-dev
#install graphics dependencies
sudo apt-get install libwxgtk3.0-dev freeglut3-dev

git clone
cd LimeSuite
mkdir builddir && cd builddir
cmake ../
make -j4
sudo make install
sudo ldconfig

cd LimeSuite/udev-rules
sudo ./

LimeUtil --find - works.

After this I’m begining SoapySDR installing:
sudo apt-get install
cmake g++
libpython-dev python-numpy swig

git clone
cd SoapySDR
git pull origin master
mkdir build
cd build
cmake ..
make -j4
sudo make install
sudo ldconfig #needed on debian systems

SoapySDRUtil --info - getting info that I posted at the begining

Where I missed? I’m using Ubuntu 16.04

Tried this on clean Ubuntu 17.10 and 16.04 and got the same result

Oh, I understood. Firstly need to install SoapySDR and just after this - LimeSuite.

1 Like

So you installed SoapySDR dev files from package, then build Lime Suite from source, following which SoapySDR form source (after dev files are already installed for another version from package…)

Either install packages or from source if you can. if you need to mix, e.g. SoapySDR packages and Lime Suite from source, just make sure that you don’t have more than one version of something installed. E.g. SoapySDR sources from package and git.

My mistakte was in installing LimeSuite before SoapySDR, after I firstly installed SoapySDR and after it - LimeSuite. All works fine. Sorry for this sticky mistake.