SetFrequencySXR(30 MHz) - cannot deliver frequency

#1

When I attempt to set the the frequency on my LimeMini to 30 MHz, I get the following error:
SetFrequencySXR(30 MHz) - cannot deliver frequency

It is my understanding that 30 MHz is the frequency of the NCO. To set the frequency bellow 30 MHz, i set the receive frequency to 30 MHz and then set the NCO to the difference between the desired frequency and 30 MHz, causing a down convert.

This doesn’t work for me anymore. My current version of LimeSuite is 19.04. Current version of firmware is 6. I tried gateway versions 1.29 and 1.30 with the same results.

Questions:
Is this method of setting receive frequencies bellow the NCO frequency still valid?
Is the frequency of the NCO no longer 30 MHz?

#2

I also caught this problem.
It seems that at some point they have changed the behavior of the LMS_SetLOFrequency function, now it sets the NCO Frequency and makes the frequency shift inside itself.

#3

NCO with 19.04 Limesuite works as before. NCO success depends on sample rate (CLKGEN): higher sample rate allows lower HF frequencies. Post your CLKGEN and RxTSP screens.

#4

I do not know how it was before, but in your frontend for sdrsharp when using 19.04 limesuite dll, it sometimes began to give an error that the frequency could not be set.
I was not very deeply versed in the mechanisms for calculating the possible operating frequency.
I climbed into the code and saw that the LMS_SetLOFrequency already has the logic of working with frequencies below 30 MHz, and removed (LMS_SetNCOIndex / LMS_SetLOFrequency) from the sdrsharp frontend And this is a good works.
and of course in LimeSuiteGUI you can see that the NCO (index 0) frequency is set below 30mhz when the HF band is used.

It seems that in 19.01, (30MHz below) also works without manual installation of the NCO, only there, it seems the error is not generated

#5

When I start to play with LimeSDR-USB over year ago I run into board overheating problem which caused instability bellow 40MHz. This is why I use LMS_SetLOFrequency to set 30MHz LO and then NCO frequency and NCO index( also LimeSuiteGUI use same algo). LimeSuiteGUI do not allow set HF in one command (SXR frequency has 30MHz limit).

p.s. current LimeSuite library do not give error text for LMS_SetLOFrequency function when exception occur (error like bad NCO).

#6

I rolled back to an older version of limesuite and the error went away.
thank you

#7

Hi @yindra,

  1. What board do you use?
  2. What is older LimeSuite version you rolled back to?
  3. What version you rolled back from?
  4. What frequency causes issues to you?
#8

@Zack

  1. a LimeSDR - Mini
  2. i rolled back to gitrev: abf8214
  3. I tried running on Windows (I don’t know the build number but the version was 19.04). I tried gitrev 24e3e35 and one other version (it was the latest and greatest when I started this thread) on Ubuntu. All three produced the error “SetFrequencySXR(30 MHz) - cannot deliver frequency”.
  4. i was trying different frequencies bellow 30.05 MHz and all produced the same result. I’ve attached the GNU Radio flow chart I used in the linked issue number bellow:
    https://github.com/myriadrf/LimeSuite/issues/271
#9

“SetFrequencySXR(30 MHz) - cannot deliver frequency” means that RX PLL failed to lock at 30 MHz. It can be because heat problem, insufficient power or defective board. It is unlikely, that I will be able to reproduce it (I have just tried 4 LimeSDR-Mini boards and their all lock at 30 MHz with both commits). Are you sure that rolling back really solved the issue (maybe it is just warm board vs cold)?
Do you get the error only when using GNU radio or also if you try set Rx to 30 MHz from LimeSuite (connect, press ‘Default’, in ‘SXR’ tab enter 30, click ‘Calculate’)?
Also, is you board v1.1 or v1.2 ?

#10

@IgnasJ
My board is LimeSDR-Mini v1.1

When I rolled back the software and it started working I was under the worst case power conditions (USB 2.0 power). When I was getting the error in the Windows build of LimeSuite 19.04, I was in the best case power conditions (USB 3.0). Other tests were made with a USB cable that draws power from two USB 2.0 ports to power one USB 3.0 device (are you thinking some Linux tests were the result of a bad USB cable?)

I’m sorry to hear that the LimeSDR-mini has heat related timing issues. Would you like for me to RMA?

#11

Hi,
Can you check you board with LiemSuiteGUI using a more recent version of LimeSuite (one that does not work)? I see one difference that may affect PLL locking for v1.1. If you get error when trying to set SXR to 30 MHz from LimeSuiteGUI, try lowering “Scales VCO bias current” setting. After pressing default it should be 192 but in older version it was 180. So try setting it to <180 and see if it locks then.

#12

On Windows 10 with the LimeSDR-mini (version 1.1) connected to USB 3.0:
LimeSuite version 19.04.0-PothosSDR-2019.06.09-vc14-x64
build date: 2019-06-09

I got the following errors with the first LimeSDR-mini after clicking the “Calculate” button but not the second LimeSDR-mini:

#13

On Ubuntu 18.04 (arm64) with LimeSDR-mini (version 1.1) connected to USB 2.0:
LimeSuite version: 19.04.0-gabf82140

I got the same LimeSuiteGUI error when I tried to calculate SXR with either LimeSDR-mini.

I was able to use that GNURadio flow graph (attached to the linked issue) to set the receive frequency bellow 30 MHz on the second LimeSDR-mini, but not the first.

So I have an error when setting receive frequency bellow 30 MHz that follows one LimeSDR-mini. This issue does not follow the second LimeSDR-mini.

#14

What happens with only one device connected at a time ? (One is not connected to the computer)

#15

@mzs
I am only able to connect one (or the other) LimeSDR-mini to my system because I do not have a spare USB port.

#16

Can you try setting “Scales VCO bias current” to 180 or lower and trying “Calculate” again. I want to find out if that setting might be the reason why it works with release 19.04 version but not current master.

#17

@IgnasJ
I tried changing the “Scales VCO bias current” but it changes to 255 when ever I click the “Calculate” button. I always get failed to set frequency with this LimeSDR-Mini board and software setup.

#18

I created a new thread for this issue: Programming failed! LimeSDR-mini