SetFrequencySXR(1812,5 MHz) - cannot deliver frequency

Hi, I am using LimeSDR-USB v1.4s with LimeSuite v20.07.2 (built from source) and srsLTE.

I have problems setting certain frequencies - I get “SetFrequencySXR(1812,5 MHz) - cannot deliver frequency” error. I can reproduce this with LimeSuiteGUI - tab “SRX” - I would type the desired frequency and would press “Calculate” button.
Then I get the following debug log:

[10:37:22] DEBUG: INT 114, FRAC 1365, DIV_LOCH 1, EN_DIV2_DIVPROG 1
[10:37:22] DEBUG: VCO 7250.00 MHz, RefClk 30.72 MHz
[10:37:22] DEBUG: ICT_VCO: 255
[10:37:22] DEBUG: TuneVCO(SXR) - VCO too low
[10:37:22] DEBUG: VCOL : csw=0 tune fail
[10:37:22] DEBUG: ICT_VCO: 255
[10:37:22] DEBUG: TuneVCO(SXR) - VCO too low
[10:37:22] DEBUG: VCOM : csw=0 tune fail
[10:37:22] DEBUG: ICT_VCO: 255
[10:37:22] DEBUG: TuneVCO(SXR) - VCO too low
[10:37:22] DEBUG: VCOH : csw=0 tune fail
[10:37:22] DEBUG: Selected: VCOH
[10:37:22] ERROR: SetFrequencySXR(1812.5 MHz) - cannot deliver frequency

I found that the error happens for frequency ranges: 1710-1920MHz, 859.5-964.0MHz, probably others.

I found out that if I change(usually increase) the Reference Clock from 30.72MHz to 36.72MHz, for example, the desired frequency will be accepted.

I also found that LimeQuickTest fails:

[ TESTING STARTED ]
->Start time: Fri Sep 18 10:55:43 2020

->Device: LimeSDR-USB, media=USB 2.0, module=FX3, addr=1d50:6108, serial=0009081C05C1361B, HW=4, GW=2.23
Warning: USB3 not available
Serial Number: 0009081C05C1361B
Chip temperature: 53 C

[ Clock Network Test ]
->FX3 GPIF clock test
Test results: 23803; 27559; 31315 - PASSED
->Si5351C test
CLK0: 17554 / 17554 - PASSED
CLK1: 17554 / 17554 - PASSED
CLK2: 17554 / 17554 - PASSED
CLK3: 17554 / 17554 - PASSED
CLK4: 17554 / 17554 - PASSED
CLK5: 17554 / 17554 - PASSED
CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
Result: 10 - PASSED
->VCTCXO test
Results : 5112941 (min); 5113077 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 01 18 13 01 19 03
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
CGEN: Freq=80 MHz, VCO=2.4 GHz, INT=77, FRAC=131072, DIV_OUTCH_CGEN=14
CGEN: Freq=80 MHz, VCO=2.4 GHz, INT=77, FRAC=131072, DIV_OUTCH_CGEN=14
CGEN: Freq=491.52 MHz, VCO=1.96608 GHz, INT=63, FRAC=0, DIV_OUTCH_CGEN=1
CGEN: Freq=491.52 MHz, VCO=1.96608 GHz, INT=63, FRAC=0, DIV_OUTCH_CGEN=1
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
SetPllFrequency: error configuring phase
LML TX phase search FAIL
Failed to set sample rate
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.29 seconds

I use the LimeSDR device with external power supply (12V, 1.5A).
Eventually I got another SDR device and the issue was not present there.

I have already posted this same topic as LimeSuite GITHub Issue:


The conclusion there was that I face a hardware issue.

Still I was advised to post the issue here as well, before starting RMA process.
Could you please share some comments?

Thank you.

Please contact Crowd Supply for RMA, as advise in the GitHub issue.

https://www.crowdsupply.com/contact#i-want-to-return-a-product-rma-request