PPA update for Ubuntu 18.04


#1

Greetings,

The gqrx and MyriadRF PPAs are now updated to support Ubuntu 18.04 LTS. I tried to use as much as possible from the official repositories and only rebuild what was absolutely necessary:

  • libairspyhf
  • libad9361
  • libiio
  • gr-iio
  • limesuite
  • gr-osmosdr

All other packages are now provided by Ubuntu. This means we are making progress :slight_smile:

New installation should work without problems, see for example the gqrx instructions.

If you upgrade, some of the packages may appear obsolete as they go from being provided by a PPA to being provided by Ubuntu. In such case uninstall the PPA version and let the package manager install the Ubuntu version. At the end it may be easier to reinstall the packages, e.g.

sudo apt-get purge --auto-remove gqrx
sudo apt-get purge --auto-remove gqrx-sdr
sudo apt-get purge --auto-remove libgnuradio*

and then, assuming you want gqrx:

sudo apt-get install gqrx-sdr

#2

That is interesting - playing with docker on Ubuntu16.04 you can start a container version 18.04 with bash shell, then apt install limesuite, a bunch of other stuff, commit the image and pass in the LimeSDR and run osmo-trx:

# docker run -it --device=/dev/bus/usb/004/009 limesdr18a bash
root@7d4b7e0cf8de:/# osmo-trx -f -s4 -b4 -a “driver=lime,device=1”

CGEN: Freq=61.44 MHz, VCO=2.4576 GHz, INT=79, FRAC=0, DIV_OUTCH_CGEN=19
– Transceiver active with 1 channel(s)

Still over my head but would be nice to have a docker images for LimeSDR/Applications to just run and use :slight_smile:


#3

works perfect.
cubicsdr 2.3 is broken as far as i can tell.
i mean it comes on but its not working correctly
im on ubuntu 18.04 LTS Desktop x86_64
tried the ubuntu repo, appimage and building.

thanks for getting gqrx-sdr and limesuitegui working
gqrx 2.11.4 and limesuitegui 18.04.1 working fine as far as i can tell


#4

Thanks for the feedback; glad to hear it is working. Fortunately, all I had to do was to rebuild the already existing packages for 18.04 so it was easy.

Perhaps cubicsdr just needs to be rebuilt with the SoapySDR that comes with Ubuntu 18.04?

Alex


#5

i tried with soapysdr 0.6 from the ubuntu repo but maybe i was doing something wrong but i followed this guide.


made it all the way though to this step ‘make’ without errors under the “BuildCubicSDR” section
:frowning:
installed a couple different versions of wxWidgets and still no go
im no expert in compiling and i also have done a complete reinstall of ubuntu 18.04 lts so i dont have the exact errors i was getting
maybe someone else can give it a go.
i also tried to follow this guide for installing pothosware

i was not able to add the PPA’s


#6

Good news is that the soapysdr and friends packages are in the official ubuntu package repositories: https://packages.ubuntu.com/search?keywords=soapysdr&searchon=names&suite=bionic&section=all

One item of note is that apt-get install soapysdr becomes apt-get install soapysdr-tools. It looks like the upstream ubuntu/debian packaging renamed this, I will have to look at backporting it to the PPA and renaming the instructions to match.

I’m aware the pothosware ppa is not updated yet. I just tagged a release yesterday. I like to update to the latest release at the same time so I dont have to do it twice. It should be up soon, there is an open issue which I will close when ready: https://github.com/pothosware/PothosCore/issues/160


Ubuntu 18.04 LTS Lime Suite install issues