LimeSDR-USB Transmit with gr-limesdr

I would like to transmit from the LimeSDR-USB using gr-limesdr and GNU Radio. I downloaded the new limesuite and gr-limesdr a few hours ago. Attached you will find the flow graph I used and the picture I got. I expected to see the two tones on the spectrum analyzer; I only see the IF frequency.

Why don’t I see two tones transmitted?

Hi @yindra,

Our guys came up with this gr file:!AsTX3WCH_RLChyjhvf-JtfOpLT9I

The result is as follows:

1 Like

I ran the file you sent and here is my result:

I ran LimeUtil --update and got the same result with image 18.06/LimeSDR-USB_HW_1.4_r2.17.rbf
What firmware version are you running? do you think my LimeSDR-USB might be broken?

I tried one more thing: Using different revisions of LimeSuite, I transmitted the same data file with limesdr_toolbox.

First I created the file (2e6 sps) with Gnu Radio and a USRP, so this is my expected output:

Second, I reverted LimeSuite to version 17c3e05 which is firmware version 18.04 and I sent the data with limesdr_send application from limesdr_toolbox and I got this:
04_Limesuite 17c3e05
But, in limesdr_send, LMS_SendStream returned the error “L”. I don’t know what “L” means.

Finally, I updated LimeSuite to version 739bd85 which is firmware version 18.06 and I sent the data with limesdr_send application from limesdr_toolbox and I got this:
06_Limesuite 739bd85
NOTE: this is only the IF. The limesdr_send application never terminated. I expected limsdr_send to terminate after about a minute because that’s how long I recorded to create the data file. I have a feeling that the data was never transmitted to the limesdr.

Hi @yindra,

I would suggest to use the latest LimeSuiteGUI (pre-compiled Windows version preferred) and perform a Quick Test procedure. Update the gateware to the latest one using LimeSuiteGUI.

For me the file worked with LimeSDR_USB and LimeSDR_miniFor some freq the TX cal failed until I increased TX gain. (Tx Calibration: MCU error 5 (Loopback signal weak: not connected/insufficient gain?)

Here is the Quick Test result:

Here is the RX test signal:

Here is the TX carrier signal:

Here is the TX test signal:

I got the same results when I loaded the 18.06 firmware with Modules->Programming (it then downloaded the 18.06 firmware and installed it) with LimeSuiteGUI_20180613_1cb1723.exe

Yes, I have seen this error in Gnu Radio occastionally, but, in post about limesdr_toolbox tests, the only error I got was “L”.

Is there a reason for switching off the analog filter? I think the analog filter would reduce aliasing.

I’m also seeing this for reception:

e[1me[31m[ERROR] Rx calibration: MCU error 5 (Loopback signal weak: not connected/insufficient gain?)e[0m

@Zack: is this a real error (for Tx and Rx) or more of a warning? Things seem to be working well on the Rx part even with this message.

If gain is insufficient, the calibration is terminated and has no effect.

Hello @yindra,

As far as I see, the board is working correctly. So, it looks like the problem is in software (used in GNU Radio chain) version mismatch.

I still get the same result with new software, and on a different computer.

So here are the versions of software that I’m using

  1. I’m on a Intel Core i5 running Windows 7 Professional (64 bit)
    a) I uninstalled Pothos and GNU Radio and rebooted.
    b) The windows driver hasn’t changed in git, so I didn’t re-install that.
    c) I programmed the 18.06 firmware yesterday with this version of LimeSutie: LimeSuiteGUI_20180613_1cb1723.exe
  2. I installed GNU Radio (gnuradio_3.7.12_win64.msi) from here
  3. I installed gr-limesdr from here:
  4. I started GNU Radio and ran two_tone.grc
  5. I get the same picture as I did on my Ubuntu computer:

EDIT: I removed the USB 2.0 extension cable I was using and now the picture looks correct:

It was not just the cable because plugging the LimeSDR-USB directly into the USB 2.0 port gave me the same picture as the pictures with the USB 2.0 extension cable. All pictures, except the one where I said that I removed the USB 2.0 extension cable, were using the cable; this cable was used for taking the self test pictures in my previous posts.