LimeSDR-USB transmitting issue


I’m experiencing some issues trasmitting with my brand new LimeSDR-USB (v1.4s) and GNURadio.

My setup is:

  1. GNURadio 3.8.2 with gr-limesdr (latest commit from gr-3.8, 47511dd) and LimeSuite (latest commit from master, a45e482)
  2. LimeSDR-USB v1.4s with latest gateware connected through USB3.0
  3. Spectrum analyzer connected to TX1_1 port from LimeSDR-USB

I configure GNURadio to produce a tone at 10kHz, amplitude 0.5, like this:


What I obtain in the spectrum analyzer is this:

I have a LimeSDR-Mini as well, so I’ve tried just swaping one Lime for the other, same configuration and flowgraph, and I get this:

Then I’ve tried setting gain for LimeSDR-USB to 0, with the same result, just different scale.
I have several LimeSDR-USB units, and all of them show the same results, so I think it’s a configuration issue.

I gave it another try using the ENABLE_NEW_GAIN_BEHAVIOUR option in LimeSuite and recompiling everything, but was without luck.

Do you have any idea how to fix this?

Thanks in advance.

I’m experiencing the same issue with basicTX example from LimeSuite so I guess this is not up to GNURadio or gr-limesdr.