LimeSDR TX issue

Hi, I am working on a project with LimeSDR and I got an issue as shown below. May I know what is wrong and how do I rectify it.

<<< Welcome to GNU Radio Companion >>>

Block paths:

Loading: “/home/yeoenghoejason/Gen2-UHF-RFID-Reader/gr-rfid/grc/reader_live.grc”


Generating: ‘/home/yeoenghoejason/Gen2-UHF-RFID-Reader/gr-rfid/grc/’

Executing: /usr/bin/python3 -u /home/yeoenghoejason/Gen2-UHF-RFID-Reader/gr-rfid/grc/

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-yeoenghoejason’
[INFO] [UHD] linux; GNU C++ version 9.3.0; Boost_107100; UHD_3.15.0.0-74-ge35f66e8
[INFO] [UHDSoapyDevice] Make connection: ‘LimeSDR-USB [USB 2.0] 9072C0288371F’
[INFO] [UHDSoapyDevice] Reference clock 30.72 MHz
[INFO] [UHDSoapyDevice] Device name: LimeSDR-USB
[INFO] [UHDSoapyDevice] Reference: 30.72 MHz
[INFO] [UHDSoapyDevice] LMS7002M register cache: Disabled
Traceback (most recent call last):
File “/home/yeoenghoejason/Gen2-UHF-RFID-Reader/gr-rfid/grc/”, line 256, in
File “/home/yeoenghoejason/Gen2-UHF-RFID-Reader/gr-rfid/grc/”, line 232, in main
tb = top_block_cls()
File “/home/yeoenghoejason/Gen2-UHF-RFID-Reader/gr-rfid/grc/”, line 98, in init
self.uhd_usrp_source_0.set_antenna(‘RX2’, 0)
File “/usr/local/lib/python3/dist-packages/gnuradio/uhd/”, line 3696, in set_antenna
return _uhd_swig.usrp_source_sptr_set_antenna(self, ant, chan)
RuntimeError: SoapyLMS7::setAntenna(TX, RX2) - unknown antenna name

Done (return code 1)

LimeSDR has 3 RX antenna choice (RX_L, RX_W and RX_H) and 2 TX (TX_L and TX_H). I guess you are trying to set TX antena with wrong number RX2.

Hi, I tried setting my TX antenna choice to the other and still got the same error.

I have GNUradio 3.7 under Windows 10. Only issue is that RX and TX must be same channel (A or B). In LimeSuite Sink (TX) block select Band1 or Band2 for PA Path. TX signal is received with RTL SDR dongle.