LimeSDR and GNSS-SDR

Hello

I made some efforts and finally both GNSS-SDR and LimeSDR are installed on ubuntu 18.04 and ready to work. The GNSS-SDR passed My first position fix and SoapySDRUtil --prob find the LimeSDR without any problem. Now I’m trying to feed the LimeSDR with an active GNSS antenna and run the GNSS-SDR by using this conf. file https://github.com/gnss-sdr/gnss-sdr/blob/next/conf/gnss-sdr_GPS_L1_LimeSDR.conf

I encounter the following error:

Initializing GNSS-SDR v0.0.14.git-next-419eff942 … Please wait.
Logging will be written at “/tmp”
Use gnss-sdr --log_dir=/path/to/log to change that.
OsmoSdr arguments: driver=lime,soapy=1
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.11
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp

FATAL: SoapySDR::Device::make() no match

Trying to fill up 1 missing channel(s) with null source(s).
This is being done to prevent the application from crashing
due to gnuradio bug #528.

Set RX Antenna:
Actual RX Rate: 0 [SPS]…
Actual RX Freq: 0 [Hz]…
PLL Frequency tune error: -1.57542e+09 [Hz]…
Actual RX Gain: 0 dB…
Actual Bandwidth: 0 [Hz]…
E0122 12:46:28.883955 29576 pass_through.cc:99] This implementation only supports one input stream
E0122 12:46:28.884174 29576 pass_through.cc:100] 8
E0122 12:46:28.950374 29576 gnss_flowgraph.cc:701] itemsize mismatch: hybrid_observables_gs0:0 using 152, copy2:0 using 8
E0122 12:46:28.950464 29576 control_thread.cc:303] Unable to connect flowgraph
Total GNSS-SDR run time: 0.00653797 [seconds]
GNSS-SDR program ended.

Any idea what is the problem and what should I do? I appreciate it…

Best regards
Amir

Does anybody know how I can reset all settings, including FPGA programming, to the factory setting? I’m a newbie at using SRD and accidentally changed the programming part in LimeSuiteGUI. Now the SDR can not receive the signals. It is connected but cannot receive the signals. I really appreciate it if you help me with this matter. I think this is the main problem that GNSS-SDR doesn’t find the LimeSDR.

Best regards
Amir

There are no settings persisted to the SDR hardware, hence this is not necessary. The only things that are written to the device are firmware and gateware. To confirm that it is operating as it should be, run LimeQuickTest, while ensuring that the board is cold and nothing is connected to any RF port.

If LimeQuickTest checks out OK, but you are still experience problems, it is software related.

1 Like

Problems like yours are usually caused by having the wrong version of soapy installed.

What is the output of “SoapySDRUtil --info” ?

If it does not find things in the path -

/usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/

You should uninstall the wrong version of Soapy -

Then, It may work or you may need to install the correct version of Soapy -

sudo apt-get install libsoapysdr0.6

sudo apt-get install libsoapysdr-dev

Or you may need to do the complete re-install of gnuradio.

1 Like

It solved, I first installed using docker, it did not work. I then installed Soapy bu using:

sudo apt install soapysdr-tools

and then installed the dependencies. There was an error
Failed to parse '/usr/share/mime/packages/gnuradio.xml

So I removed the gnuradio.xml and Symlink gnuradio-grc.xml to gnuradio.xml and then update the mime database. Then make and installed GNSS-SDR and run it with sudo to have the permissions to open the USB port. It worked!

If you need to be root to access a USB device under a debian based Linux, check that you are not missing a rule’s file under: /etc/udev/rules.d/ e.g. https://github.com/myriadrf/LimeSuite/blob/master/udev-rules/64-limesuite.rules

EDIT: After you add the rule, you will probably need to unplug and replugin the USB device again for the rule to actually change the permissions for the USB device.

1 Like

Thank you